Sign in with
Sign up | Sign in
Your question

Soyo Dragon 2 BIOS update Problem

Last response: in Motherboards
Share
August 12, 2003 2:58:21 PM

Hello All, hope some one can help.

I have been an owner of Soyo's Dragon 2 mobo for over a month now and i am resonably happy with it. However i ran into a few stability problems at first as well as random crashing. But after its teething problems i was able to get my rig stable.
However, i came across a review on this board at OCTools.com which disturbed me. Basically they said that they had loads of issues of getting this board to work and more importantly they could not update the BIOS. The review can be found here
http://www.octools.com/index.cgi?caller=articles/soyo/d...
Now i tried to update my BIOS with the latest from the Soyo website and guess what. Same problem. I can't update my BIOS either, it comes up with an error message basically saying that the BIOS does not match the motherboard. And i am positive that i have downloaded the right BIOS.
Then i saw good old toms latest review about over clocking a P4 to a 1000 FSB. Guess what, they used the board i have, more importantly they have the latest BIOS used in the test as indicated here
http://www.tomshardware.com/motherboard/20030812/ddr500...
BIOS Version/Date 4AA2(July 14,2003)
My BIOS is 4AA1 (May 16,2003)

The question is
a) was the board that was shipped to Tomshardware already with this BIOS version
b) if it wasn't, how did they update the BIOS?
c) did they experience any problems when updating the BIOS?
d) how did they resolve them?
e) where did they get the BIOS from? Was it from the offical website or some where else.

Final question is, does any one else who maybe an owner of this board have the same problems the OCTools have reported. If they have, have you found a way round them, and more importantly can you update your BIOS?

Any help would be greatly appreciated as i don't know what else to do other than send the board back and get them to play around with it. So far i have clock over three hours trying to resolve these problems.

Many Thanks

Lord Jago.
August 12, 2003 9:20:19 PM

Seem to be 3 Soyo p4i875p.
Which edition do you have?
a) Plus Dragon 2 - P4I875PE
b) Dragon 2 - P4I875P
c) Dragon 2 (Platinum) - P4I875P

Perhaps only Mobo no "c" will permit the aa2 flash?

The loving are the daring!
August 13, 2003 10:12:53 AM

Thanks for the reply, I have the Platium version. But it looks like ive cracked it. After i posted this post i started to look deeper into the problem. And found a way to update the BIOS.
The first way i tried was the use the 'Alt + F2' @ the BIOS boot up with the new BIOS on a floppy Disk. This did not work as before.
I then tried the Windows 98 bootup disk to get into DOS and flash the BIOS from the hard drive. Again this did not work.
I then tried the final way of flashing the BIOS which was using the win98 bootdisk and then flashing the BIOS from a floppy. This did not work, however when i typed the following 'awdflash p4cw4aa2.bin /f' the BIOS updated. Success.
It appears that the '/f' made the difference, even thou this is highly unusal. I have never come across this before in all the BIOS updates i have done.

Now i am attempting to address the other problem. Using the Serial ATA connections via the southbridge and building an operating system on a serial ata drive. This is a weird one, you can build an OS on a serial ata drive and all works fine. But as soon as i install the chipset drivers or any other drivers into the OS the board appears to lose sight of the OS, even thou the partition is still intact. A very weird fault. This board appears full of them sadly.

Lord Jago.
!