Sign in with
Sign up | Sign in
Your question

ABIT IC-7G motherboard and SATA configuration

Last response: in Motherboards
Share
August 16, 2003 2:20:19 AM

Hi!
I've installed my new IC-7G mobo today, and have worked like mad to get it going like I want it to.
First, a short rundown on what I have in my rig:

ABIT IC-7G
Pentium 4 2,6 GHz 800MHz FSB
Corsair TwinX 1024Mb PC3200 DDR-RAM (2 x 512Mb)
Hercules Prophet Radeon 9500Pro
Creative Soundblaster Audigy
Creative Dxr3 decoder
Pioneer DVD-117 DVD player
Sony CD-RW
Maxtor 4G160JB 160Gb ATA150 hdd
Western Digital WD-600BB 60Gb ATA100 hdd
Western Digital WD-360 Raptor SATA 36Gb hdd

Now for my problem:
I've hooked up the CPU, RAM and slotted the cards, no probs. The system starts and seems happy....until it starts searching for hdd's.
What I had planned, in my ignorance, was this:
Use the Raptor as primary disk on a SATA interface, running WinXP from 1st partition, then 2 very system hungry apps from 2 separate partitions.
Then use my WD-600 with the SERRILEL2 SATA converter for other programs, like games and such, and shared files on network.
Finally, the 160Gb Maxtor on IDE 1 would be used for large scale storage, for pictures, among other things.
Also wanted to squeeze in at least the DVD somewhere in this system, for example IDE 2.

This is the way I have connected things now and, no surprise, it don't work....
Whenever I boot up, the PC spends an extrordinarily long time searching for hdd's, and often dont find all or any. This is usually followed by a Sil RAID config utility, but I don't really know what to do with it. After a while, the PC starts to wail a distress signal (sirene-type).
I go "Hmmmm...that cant be good...." and switch off or reboot.
Now, I've tried configuring the SATA RAID options in the BIOS, but no matter what I try, the results are the same. Either the RAID utility and wailing starts, or I'm prompted with a primary hdd failure, depending on what I've touched in BIOS. Also, sometimes the SATA drives show up during start, other times the Maxtor, and yet other times the DVD player. But not every one at the same time.

Well, I guess none of you are surprised to learn that I'm not a hardware guru. This is the first time I've installed a mobo all by my lonesome, and I've never touched a S-ATA drive before, and don't really know two things about it.
So, I desperately need help here.....

How do I set up and config my system to get it at least as close as possible to what I had planned?
And what do I need to do in the BIOS to achieve this?

Thanx in advance!
August 16, 2003 3:29:37 AM

I just set my IC7-g up today, and connected four hard drives. 2 WD raptors (striped on intel sata controller), and 2 WD 120(striped on silicon image sata controller). Worked fine, but your mixing p-ata and s-ata. Do you have the two sata drives on serial #'s 1 and 2? If so, I would disable the silicon image controller (#'s 3 and 4) in the bios. If not, move them both to 1 and 2, then disable the sil sata controller(in bios under on-board devices, I think) . Also, change the on-chip sata controller to enhanced, because on auto it will assign any drives on sata 1 and 2 to primary master and primary slave. That may in fact fix your problem because if you already have one ide drive and addition to two drives on the intel sata controller, your system is trying to put 3 drives on one ide channel! No wonder your system's going nucking futs! Let me know if that fixes it. I would disable the sil image controller, before anything else to take that problem out of the equation. Doesn't sound like you need it anyway, as the performance on the intel chip is better anyway. Remember to change the on-chip sata mode to enhanced right after you disable the sil image controller. I bet that will fix it.
August 16, 2003 2:10:45 PM

Thnx for answer, I will try it out.
One other thing that struck me though, is that some people have said (on other forums..) that the SATA-interface on this card is enabled for RAID setup only.
If this is correct, I guess I need 2 Raptor's, right?
Or is this incorrect, ie the mobo can also handle a single hdd on SATA?
Also, I can't find any "Enhanced" option for the on-chip SATA controller.....so I just flashed it, and hopefully things will begin to work. I'll let you know!

Regards,
Related resources
August 16, 2003 4:41:49 PM

Ok, status so far.....
I've flashed my BIOS to IC7.16, and the Enhanced option on the on-chip SATA controller popped up.
The BIOS states that up to 6 IDE drives is supproted in that mode, so thats what I'm trying for...or rather 5 drives in my setup.
Currently it looks like this in my rig:
160Gb Maxtor ATA150 as master on IDE 1
Pioneer DVD-117 as master on IDE 2
Sony CD-RW CRX120E as slave on IDE 2
WD Raptor 36Gb SATA as master on IDE 4, via on-chip SATA 1
WD600 60Gb ATA100 as master on IDE 3, via on-chip SATA 2 and using the Serillel2 converter.
Everything shows up in POST and BIOS, except the WD600.....

Any ideas?
Also, as I wanted to run the Raptor as the OS disk, is this recommended, and will I need to put it onto another IDE-channel or is my current setup ok?

Thanx so far!
August 16, 2003 11:57:48 PM

I think you answered your first question yourself. No, you don't have to run RAID on the intel controller. I am wondering if the converter is working. Or maybe the drive? Is this a known good drive? If you like, your can try plugging it into the sil image sata controller just to see if the intel controller doesn't like the converter for whatever reason. Or slave it to the Maxtor to see if it works. SOunds like your making progress anyway.
August 17, 2003 12:00:26 AM

I should have made sure you already flashed the bios. Just assumed. Sorry. That's true on all of the i875 boards. BIOS update is usually necessary to get very far.
August 17, 2003 3:06:58 AM

Thanks for all the help!
You got me going here, and the rest I used the fameous trial and error method.
I am now writing from my newly configured AND working IC-7G equipped rig....hehe.

What did I do wrong? How did I manage to get it going?

#1 Flash the BIOS! This enabled the "Enhanced"-option for on-chip SATA, and made all my drives available in BIOS (and elsewhere).
#2 The WD600 hdd was setup as the "manual" said, with the jumper in the MASTER-position....it did not show up at all.
Removing the jumper completely fixed all that.

So, right now I'm a very happy man, and thanx for all help!

Best regards,
!