Sign in with
Sign up | Sign in
Your question

Graphical Tearing and Corruption in Some Games

Last response: in Video Games
Share
November 27, 2009 4:47:48 AM

I didn't find any recent discussions of this in the forums.

I am having significant problems with graphical tearing and corruption in some games. My cards should be able to run these games (like Far Cry 1 and 2, GRID, and Supreme Commander) with no problem. In addition, there are other games that run perfectly (Left 4 Dead, Unreal Tournament 3 Black, Assasins Creed, Bioshock, Company of Heroes etc.)

System Specs:
MB: Asus P6t Se
CPU: Core i7 920
Ram: 6gb Corsair DDR3
GFX: Two Radeon 4850s (512mb) in Crossfire
Monitor: Acer H243H
HDrives: Two Hitachi 500gb in Raid 0
PSupply: Kingwin 700watt

Things I have tried:
1. Latest Drivers for Radeons are installed (and reinstalled--the correct way).
2. Direct X is repaired/reinstalled.
3. Games are run as administrator and in several different compatibility modes.
4. Temperatures were checked none get above 75c under load.

Other thoughts:
1. I should note that most of those games are steam games, one or two direct2drive.
2. I realize that some times one's Power Supply is the issue, but other graphics intensive games run perfect. I highly doubt that is the issue here (not withstanding my no name power supply).
3. Here is a screenshot of Supreme Commander corruption: http://tinyurl.com/yfujd86


Any help you could offer would be appreciated.


November 27, 2009 4:49:06 AM

Sorry, and I'm running Windows 7 Professional.
November 27, 2009 6:13:38 AM

Try enabling V-Sync.

i can't view your screenshot though...

But as you said yourself "noname PSU"... i have seen some strange issues caused by a bad PSU so don't rule that out.

Why i suggest the v-sync is most graphical tearing is fixed by this simple setting...
Just another suggestion is to check that your monitor is running at its native resolution AND refresh rate...
Related resources
November 27, 2009 11:26:51 AM

Completely agree with n@no. Although most gamers (from what I've read) have v-sync disabled I can't stand the tearing!
November 27, 2009 2:15:53 PM

Thanks for the suggestions. I too had thought of VSync after I had posted this last night. However that didn't seem to be the problem.

After about 3 months of this happening and trying to figure it out, I think I'm on to the problem. I went in to Catalyst control center and turned off all the settings such as VSYNC, antialiasing, anistrophic filtering, Catalyst AI, and triple buffering. I then went through and disable everything and tried the settings one at a time for different games.


It seems that each of the games reacts to a different setting in the Catalyst Control Center. For instance, last night I figured out that Far Cry 2 reacted to the crossfire setting, but not the others (which is ironic considering that they have a giant sized ATI Crossfire logo in their startup sequence). GRID on the other hand was fine with Crossfire, but was reacting to some other setting (haven't pinpointed it yet). I'm hopeful that this will help with the other games (it was late, like 3:00am) as I try them I'll try and post the results.

Thanks for your replies. I appreciated them.
!