Sign in with
Sign up | Sign in
Your question

Dragon Age - Radeon 5850 - artifact (?) problem (+screenshots)

Last response: in Video Games
Share
December 1, 2009 7:24:51 PM

Here are my specs:

i7 920 @ 3.7ghz
Corsair 6GB Dominator Triple Channel
1000W Corsair PSU
Samsung 2333sw 23.3" monitor
XFX Radeon 5850
Catalyst 9.11 drivers
Windows 7 64-bit

Basically I have some serious problems and was really helping someone could help. I can ALWAYS enter the main menu. Whether I can load the game or not depends entirely on my settings. I can NEVER load the game when the Graphic Detail is any higher than LOW. If I try to raise this, the game crashes when I try to begin play or resume game.

I can run at any resolution and would like to do so at 1920 x 1080. I CAN adjust the texture quality all the way up to very high. I have done this at each setting level with v-sync on AND off. The problem is that it always looks terrible. I would like to hope this is a driver problem. Here is what I am working with:

------------------------------
* Graphics Detail LOW, Texture Detail HIGH, v-sync OFF, Frame Buffer ON


Some black flickering in random places...(where you see black triangles)

* Graphics Detail LOW, Texture Detail High, v-sync ON, Frame Buffer ON


Black flickering again

* Graphics Detail LOW, Texture Detail LOW, v-sync OFF, Frame Buffer ON


Strange objects jutting from head. I have seen the guards eyeballs stretch out of their head as well.

* Graphics Detail LOW, Texture Detail LOW, v-sync ON, Frame Buffer ON


Objects, but a little bit less. Some on guard's legs.

* Graphics Detail LOW, Texture Detail MEDIUM, v-sync OFF, Frame Buffer ON


Black flickering triangles. The picture can't explain the flickering but it's rapid.

* Graphics Detail LOW, Texture Detail MEDIUM, v-sync ON, Frame Buffer ON


Strangest of all. Lots of objects and guard's helmets and woman's dress turns teal.

* Graphics Detail LOW, Texture Detail HIGH, v-sync OFF, Frame Buffer OFF


No flickering...and red faces?

* Graphics Detail LOW, Texture Detail HIGH, v-sync ON, Frame Buffer OFF


Mega objects and black flickering.
--------------------------------

So it's bad no matter what...

Why do you think I can never raise the Graphic Detail above LOW without crashing?

Why do these objects appear?

Why do the flickering black objects pop up?

Why, under one setting, do colors get weird? The same thing happened for Modern Warfare 2. All the snow covered trees turned yellow.

Driver issue? This is really frustrating. Any help is greatly appreciated. Thanks
December 1, 2009 9:31:08 PM

Overheating or bad driver install - power is not a problem (if anything having a 1000W PSY in that system is SERIOUSLY overkill)

Check your airflow around the 5850 and try putting it in a different PCI-E 16x slot and reinstall the latest drivers. You could also try using a different power cables for the card and check it they're seated in the PSU body properly.

Other than that I'm not sure - have you overclocked the 5850?
m
0
l
December 1, 2009 9:36:29 PM

I have not overclocked the video card. It looks like the temperature is around 55 degrees in the Catalyst Control Center. Do you recommend any other software for monitoring video card temperature (perhaps similar to RealTemp for CPU)?

I have no problem with some games and serious, similar problems with others which makes me think it's the drivers. Then again, I don't see a lot of people with the 5850 having similar problems.
m
0
l
December 2, 2009 1:03:22 PM

had that prob with my 5850 till i baked it (200c for 10min in the oven without heatsink, think of it as a ghetto reflow job), no joke.

Working fine now.

Try driver sweeper 1st to remove any old drivers then reinstall with the latest ones.
failing that send the card back.
possibly faulty memory
m
0
l
!