Closed

Empire earth 2 error

the game worked just fine 2 weeks ago, now when i click the launcher it gives me this error FATAL PROBLEM at C:\EE2\src\EE2\Render.cpp:580:
-->Failed to create Direct3D Device. Cannot continue.

the only changes ive made to the computer is a new flat screen monitor. ive tried reinstalling direct x 9c but that didnt do anything. ive also tried copying and pasting the game over from another computer but that didnt do anything. i would try to reinstall but the original disks were destroyed beyond repair.

i dont think its my video card dying becuz i can still play fallout 3 without a problem

my machine is a...
AMD athlon x2 kuma black edition 2.7 ghz
4gb of ddr2 pc 6400 G-SKILL
80gb sata, 200gb pata hardrives
asus radeon 4850 republic of gamers edition
asus m3a78-em motherboard
winxp pro service pack 3

thank you
3 answers Last reply
More about empire earth error
  1. Your specs are good, but still, the only way to know is re-install the game... :)
    U must install it not just copy-paste from the other computer...
  2. well, i tried plugging my old monitor back into the computer and it worked fine. the only difference is the old monitor is a old bubble monitor, and the new one is a acer flat screen. i tried screwing around with my screen resolution but nothing works so idk wats wrong
  3. that's weird... :(
Ask a new question

Read More

PC gaming Video Games