Sign in with
Sign up | Sign in
Your question

Anyone try the new GA-8KNXP (Rev. 2.0) BIOS (FD)?

Last response: in Motherboards
Share
November 11, 2003 6:18:48 PM

I see that Gigabyte has released a new revision (FD) of BIOS for the 8KNXP (Rev 2.0) boards. Looks like they went directly from (FB) to (FD), skipping a (FC) release entirely.

Has anyone tried (FD) yet? I looked for release notes but didn't see anything other than the brief description that appeared next to the file download: "Support Intel Prescott and P4Extreme family CPU; Fixed CDROM can't boot issue". That doesn't help too much.

I got the file and expanded the archive, but no release notes are included there either.

Since I'm really only looking for memory support changes, I'm not sure that I'll bother flashing to the new revision.

Post a reply if you've loaded this version successfully. Thanks.

More about : 8knxp rev bios

November 16, 2003 10:05:59 AM

I down loaded and upgraded the new fd bios, it changes how it looks at the SATA 0 drives and load order I wasn't too familure with the old bios and unfortunately the book that came with the motherboard was for the old ga-8knxp not rev 2.0 I haven't noticed any other differences but i'm still putting the system together and finding out how she flies. MY main issue from the beginning was the bios was set to PCI graphics instead of AGP and boy did that cause some grief even resetting the bios didn't cure that so with some good advice i put in a pci card and was able to get into the bios so i could change it, before all i got was the splash screen with gigabyte and intel inside logo's imagine an upgraded board for agp 8x set to pci standard?????

when all is said and done, what you've done for your neighbor is most important
November 18, 2003 5:23:59 AM

Thanks for the heads-up regarding the boot sequence change (SATA became HDD). That would have kept me guessing for a while. Why Gigabyte didn't generate release notes for something as critical as a BIOS update is beyond me.

Sounds like you are putting together a nice system. Glad to hear that it's working out for you.

I still haven't upgraded my BIOS from FB to FD yet. I'll check in again once I do.
Related resources
December 3, 2003 10:38:54 PM

I saw that Gigabyte quickly released the FE version of BIOS just a few days after the FD version, and the "release notes" (if you can call 5 words "notes") indicate that the latest version "Fixed memory PAT mode issue". So in hopes of improving my performance a little, and possibly being able to run my memory at lower CL values, I tried flashing the new BIOS.

I started by backing up both the revsion FB code in the Main and Backup BIOS to floppy, and then backed up the Main to the Backup BIOS, all using the QFlash utility within the CMOS Setup. I then flashed the Main BIOS to revision FE. But when the system reset it only got as far as the IAAR chip BIOS screen and then hung up. I reset it and tried to enter CMOS Setup, but it would not go there and hung up at the same IAAR BIOS screen.

I tried booting to floppy or CD-ROM, but it never got that far. I finally left it in the stuck mode for a few minutes while writing some notes regarding the failure, and noticed that after about 4 or 5 minutes the PC freed itself and continued through the boot process. But it failed to boot from my HDD (two SATA drives connected to the ICH5R in a RAID-1 configuration). So I don't think that this was due to the features of the DAUL-BIOS, but rather a timeout in the new BIOS.

I generated a bootable floppy on another PC, and installed the auto-flash utility and my saved version of the Main BIOS onto the floppy. I then went through the boot process again, including waiting for another 4-5 minutes, and found that the system did seem to boot from the floppy and run the flash utility. It didn't work right away, getting stuck one more time during booting, but this time it let me enter CMOS Setup where I was able to use QFlash again to copy the Backup BIOS to the Main BIOS. After that I was back to where I started, booting to XP without problems.

I called the US Gigabyte support number, but was told that I "was the only person who has called with that problem". They assured me that they would investigate the issue, and "will call you back", but I have not heard anything from them yet.

This may be related to the boot sequence change that was mentioned by someone else who tried flashing to the FD revision, but I haven't yet had the time to try again after changing the boot sequence from SCSI to HDD.

Anyone have any ideas or recommendations on this one?
December 4, 2003 4:11:20 AM

I haven't upgraded to the new bios yet, well didn't know they had put out a new bios. I imagine the problem will be in the boot up sequence, though with the issues you had I'm going to be leary about upgrading very soon.

when all is said and done, what you've done for your neighbor is most important
December 4, 2003 7:49:47 PM

I noticed you went from FB to FE maybe going FD inbetween and setting up the SATA would have prevented some of the problems... Just a thought. I'm not having any issues with the FD setup I'll let you know what happens this week-end. Thats when I'll have the time to do a bios upgrade and fix what ever happens

when all is said and done, what you've done for your neighbor is most important
December 5, 2003 7:33:11 PM

I bought this board based on recommendations from this site. I'm pretty disappointed, 200.00 (and change) headache, do any hardware sites give scores for stability? At this point I'm sorry I strayed from Abit and Asus.

I'm trying to figure out which board I have, whether its rev 2.0 or other. Where is this information printed on the board? NONE of the bios versions on Gigabyte/Gigamistake site even match the version I see when I pause the post screen. Am I nieve to think if I install the correct bios I'll be able to run xp/graphics/software without errors and lock ups? This thing isn't even running on optimized settings and its crashing through my floor.

I don't claim in anyway to be "super tech" but I've lost count of how many systems I've built for myself and others. I've never seen BS like this. Any advice would be greatly appreciated.
December 6, 2003 3:44:35 AM

look for the rev in the upper left hand corner of the board. looking at the board with the PCI slots up. the rev number will be silk screened on the mother board. A rev 2 is printed with rev 2
Don't get confused with the Award Bios type version that is not the version number we are talking about in this tread. If you are having problems post what periphials you have on the board and maybe we can help. Also remember you can use "control F1" to get into a higher level of Bios configuerations which is needed for some of the stability issues. I haven't had any problems with this board or overclocking the board except as noted above when it came with PCI as a default instead of AGP.

when all is said and done, what you've done for your neighbor is most important
December 6, 2003 7:43:22 AM

I figured it out, its an fb. I installed the latest bios, reformatted after reseting cmos. I set board up for fail safes and disabling serials and giga raid to open irq's, booted to xppro after fresh format with errors I've never seen before.

Initially I found an irq conflict with an audigy II. I straightened that out by moving the card. Still...nothing but errors. No further irq conflicts (yes the onboard sound is disabled).

I'm using a 3ghz intell,512x2 Corsair ddr3200xms, ATI 9800xt, pletxtor cdrw, western digital raptor connected to the silicon channel 0.

I've had enough...board is going back, its possibly just a bad board. With other forums I have read regarding problems coupled with the urge to turn the board into a 200.00 frisbee. I've had it...I'm not the only on consistantly having problems with this board I don't want to chase my tail. I'll stick with ASUS, ABIT, and Intel...Thanks for the help anyway.

I would keep this thread updated in the case others buy this board and come here for help. Gigabytes support is almost non-existant comparitavely to others.
!