Stalker clear sky - kills my FPS

hi all,

i had a search but couldnt find much of an answer...

i am playing clear sky and whatever i seem to do it just kills my system to the point i am getting 20fps or lower at times!

i have tried various options such as turning off dynamic lighting and reducing the quality to medium/low, it helps a bit but not much.

i guess its the graphics card- maybe some other tips??

i have a e6600@2.4 stock speed
asus p5b motherboard
4gb corsair xms2 ram 1066mhz
evga 8800gts 320mb

resolution is 1440x900 due to the widescreen monitor

any help will be greatly appreciated, If i need a new graphics card can someone suggest something? im not looking to link 2 cards or change the MB.

Many thanks
8 answers Last reply
More about stalker clear kills
  1. hmm i was getting reasonable fps on CS with an E6600 and a 8800GTX@ 1680x1050 and 6Gb of RAM. Can't test right now for actual numbers, but mid 30's ring a bell.

    Try reducing texture detail specifically, the lower vRAM might be an issue. AA is off? All patched up? Latest drivers?
  2. odd. i tried it again today and i was getting about 50 FPS, only thing i didnt do was change the resolution and left it at the pre selected setting. ill try it again at 1400 and update
  3. I can test it tonight, and let you know what i get, i've a q9550 now, but its a very single threaded app so shouldn't matter.
  4. The low (by current standards) ram on the graphics card might be the problem.

    Clear Skies is one of 2 games I can't max out at 19x12, it's a pretty demanding game.

    I'd recommend setting all settings to their lowest, and start from there. Build up bit by bit, and see how your FPS fares. You may need to keep textures towards the low end, as the game may need 512MB or 1GB vram for the larger textures.
  5. I would suggest changing from the 1.5.10 version to the "Clear Sky Complete" version. It fixes a lot of video problems from the previous versions. It is considered a mod, so it hasn't been released by Steam yet, but it is available on the net, just look for "Clear Sky Complete", download the update, install it with the provided instructions, and you should be good to go.
  6. I get lag problems as well. I get it on all 4 Stalker games and I have about 19 FPS in the main menu and in the game. My integrated graphics laptop from 2007 handles this game better then my PC with:
    GPU: Nvidia GeForce GTX 1060 6Gb
    CPU: AMD FX 8320 (8 core)
    RAM: HyperX 8 Gb (8x1) (I forgot the MHz but something above 2000)
    MoBo: Asus 970 Pro Gaming/Aura
    Os: Windows 10 x64 bit
    HDD: Seagate Barracuda (Brand new) -- Game is installed on it
    SSD: Kingston 256 Gb SSD -- Os is installed on it

    Is there any way to fix it?

    EDIT: Fixed - for the fix search for my next comment below.
  7. Have got tried the last part from 2010?
  8. There is a very good fix for this. People with Nvidia cards will be suffering a lot here. Here are the steps to improve FPS by about 80 FPS:
    1) Ensure that you have the newest GPU drivers. (Start>Search>"Nvidia">Geforce Experience>(In program)Second tab)
    2) Turn on administrator mode, Windows 7 compatibility mode and turn off fullscreen optimalization. (Right click your icon and go into properties. Then Compatibility, the third tab. Turn on Compatibility mode for Windows 7 and tick both of the options on the bottom.)
    3) Turn off DVR, game mode and game bar. (Start>Search>"Settings">Gaming. Then on all tabs turn everything off. You won't be needing DVR as you have Shadowplay, game mode doesn't help FPS (tends to do the opposite for most games). The game bar may be important to you if you use it, but turn it off for now. Later on if you fix the problem you can try to turn it back on.
    4) Set your GPU as the default PhysX processor. (Right click on your desktop, then click the Nvidia control panel. In 3D settings select "Configure Surround function, PhysX" and set the Processor to your graphics card. Don't forget to click "set/save" on the bottom right.) Leave this panel open.
    5) Set your Nvidia game options as specified by me. (In 3D settings select manage 3D settings. Then choose program options. You may have to run the game so that is shows in number 1.. Select one of the four stalker games. Set the following: Power managment mode - Prefer maximum. Tripple buggering - Off, Threaded optimization - On, Vertical VSync - Off.)
    6) You can now close that. Now set your power managment on your computer. (Start>Search>"Edit Power plan" or Start>Search>"Control Panel">Sound and Devices>Power options. In there set it to high performance.)
    7) Restart your PC. After try turning one of the games on, IF YOU GET NORMAL FPS, DO NOT DO THE FOLLOWING STEP. Otherwise if the problem continues turn on debugging mode for your GPU. (Right click on your desktop, then click the Nvivia control panel once again. Then Help>Debbuging mode (On) and Help>Allow (The one below that one)... (On).)
    8) Now once again run the game. If the issue still persists for you guys, just pm me with the following stuff:
    -system utility (Win+R>msinfo32 or Start>Search>"msconfig32". Then click File>Save As and send me it in a PM.)
    -Nvidia system info file. (Right click your desktop. Nvidia panel once again... (System info (bottom left corner) and then save that and also send it to me.)

    I will be making a tutorial on this for youtube soon. So if you do not understand this then wait for that.
Ask a new question

Read More

PC gaming Graphics Cards FPS Video Games