Sign in with
Sign up | Sign in
Your question
Closed

Got Crysis 64 bit to work on Windows 7 64 bit....not impressed

Last response: in Video Games
Share
January 19, 2010 4:45:37 PM

To get 64 bit Crysis to Run on my 64 bit Windows 7 Ultimate, I had to scrounge around the internet and install multiple times. So I decided to do 3 things. First, I reinstalled, but before I did, I opened the DVD directory (This is a Retail Copy of Crysis: Maximum Edition by the way), and I went to the setup and autorun files and changed them to run as administrator and Vista Service Pack 2.



Second step, disable firewall.



Third Step, install the game.



Fourth Step. Go to Antivirus program and add the directory of Crysis (the entire Crytek folder, as well as the bin 64 and bin 32 files) to the excemptions list.



Fifth Step. Install patches up to 1.2 only (1.2.1 takes a *** on Windows 7, it is useless on Windows 7)



Sixth Step. Enable Firewall and run the game. It worked for me.



I have a new problem.



I built my first gaming rig ever in my life (I am 21), I am a technology enthusiast who spent $3300 on this rig. This game was made in like 2004 and I still cant run it on Very High Max 16QxAA and 1920x1080 resolution and get more then 20fps. This is horseshit! This game must be crappily coded. I thought my specs were good enough but I guess not. If something is up that I am doing something wrong let me know, since you guys are smart when it comes to these things. (I'm not a dumbass either, lol, just not as much of an enthusiast as you guys.)



Here are my specs:



Windows 7 Ultimate 64-bit Build 7600

Bloomfield Intel Core i7 920 2.7ghz quad core CPU

EVGA Nvidia GTX 295 GPU (896 MBx2)

Asus Rampage II Extreme Motherboard

6 GB Corsair XMS 3 tri-channel 1333MHz RAM (Overclocked to 1600Mhz with proper Ram cooler from Corsair)

HAF 932 Full Tower Chassis with about 6 fans (blowing air out of the back, top, and bottom, while the front blows air in.)

Seagate 7200RPM Harddrive with 32MB of Cache. (Also have an HDD cooler for it.)

Lite-on Blu Ray Drive with DVD and CD capability

Corsair HX 850w Power Supply

Samsung 2494hm LCD monitor (native resolution is 1980x1080p with 60Hz refresh rate and 16:9 aspect ratio.) 1920x1080 resolution is not even in the crisis menu, I had to go to the .ini file and include it.



My cpu and gpu temps dun even hit 60 when i run the game. So temperatures are not a problem. The only way I can get 30fps is if i run medium settings and 1600x1200 resolution with only 2xAA. But hell, an fps needs 60fps to run good, and i will probably only be able to achieve that with all low settings which i don't want. I will accept 30fps if I can run 16QxAA and Very high everything. As far as I know, the GTX 295 is the most powerful single graphics card on the planet at the moment (according to this website, it even outperforms two GTX 285’s SLI’ed). Yet some people on the internet can max out crisis and get 45fps. So is something the matter. I did a windows performance index scan and I scored a 7.8 on everything except hard drive (got a 5.9). What the hell is going on.



I even tried to see if Overclocking my gpu would do the trick and it didn’t. I used EVGA precision to make the clock speed 701mhz and the memory over 1GB on each GPU! Also broguth the shader clock up to over 1GHz. So technically, the GPU has 2GB of memory and the performance did not improve, hell all it did was raise the temps of the GPU and increase the fan speed.



P.S. When I go to the task manager it has DX10 in the name of the program, but Windows 7 used DirectX 11. So I assume it is just using dx10, but I heard dx9 provided more fps so maybe I should try that. I even switched my Nvidia Control Panel settings to performance mode of the GPU’s instead of quality (it was on quality before) and it added about 3fps.
January 19, 2010 8:27:22 PM

The first thing I'd try is allowing Crysis to make it's own settings, rather than play around in config files and Nvidia's control panel. There is a 1920x1080 setting in the resolution list, there's a very difficult to see scroll bar on the right of the resolution drop down to get to higher settings at the bottom.

Crysis is demanding (but look at the little details in game and you'll see why). With motion blur on, 30fps looks perfect and is definitely playable - 60fps isn't needed on this game, and isn't achievable without drastically lowering quality/resolution.

According to this benchmark, the results you're seeing are about right for the graphics you're running:
http://www.tomshardware.com/reviews/geforce-gtx-295,210...

DX10 in theory is easier to run than DX9, so should run quicker. In practice, most games will run the same speed, just look prettier with DX10, so I wouldn't worry about that. Crysis uses DX10 on Very High , and DX9 on High and below so don't worry about trying to select which one to use.

Although Windows 7 does contain DX11, you need the OS, GPU and game to each support it. Crysis doesn't support DX11, and nor goes your GPU so the best you'll be using is DX10, again don't worry too much about it.

Short version - set the graphics to the highest you can without noticeable slow-down and enjoy the best looking game out there. :) 
The best I can manage is with crossfired 1GB 4870's is 1920x1200 all on Very High with 4xAA, although one or two outdoor scenes would be happier at 2xAA for a second here or there. Match or beat that and be happy dude.

P.S. Crysis was released in 2007 and was designed for the best rig possible then to run it on "Medium". Running on "High" or "Very High" is brilliant even now, being able to hit AA as well is a sign of a brilliant rig. You've built a nice one, enjoy it and don't let one game give you a sour taste. :) 
January 19, 2010 10:00:52 PM

Oh ok...thanks for the reply. I added DX10 on the end of the shortcut file and i will find the small drop down list if its there. I am running it all on very high with 16QxAA and i am getting 28-32fps. I guess that is ok then. Someday...somebody will rock this game at 60fps fully maxed...someday....
Related resources
Anonymous
a b $ Windows 7
October 1, 2010 11:38:41 AM

even i had the same issue for around a week, then somehow i managed to crack it...
the thing that worked for me was that...
1.After installation install the patches upto 1.2 (1.21.1 not neccessary)
2.The game folders will have two folders, bin32 and bin64.
3.Use the nocd/dvd patch if u have and paste it in both the folders and replace it.
4.Now instead of opening from bin64 open the crysis file from bin32 folder (even if the shortcut says otherwise :p )
5. it worked ..:D 

REMEMBER most people after doin everything like applyin patches, compatibilty issues, crackes etc..
make the mistake of opening the game from bin64
bin64 has two files namely 'crysis' n 'crysis64', both of which won't work
after the whole stuff use crysis from bin32 even if its vista or 7..
:) 
hope it works for you

......
:D  :D  :D  :D  :D  :D 
a b $ Windows 7
October 1, 2010 12:23:18 PM

This topic has been closed by Mousemonkey
!