Sign in with
Sign up | Sign in
Your question

Problems with Bf2

Last response: in Video Games
Share
January 19, 2010 5:31:56 PM

I'm sure anyone who's installed bf2 have have spent numerous hours of sweat and frustration of trying to fix several bf2 problems and issues , I know ... I've fixed my own bf2 and 4 of my friends. It's a pain in the ass :kaola:  Though it's one of my favorite games and i really do want this solved. The problem is : Whenever i'm running the game it once in a while( like every 5 minutes at least , but in a totally random intervall) the framrate drops significally and becomes unplayable virtually. This phenomenon passes in everything from 10 secs to 1 minute and I cant seems to work out what's the problem. I'm running on vista , and a laptop but anyways i think my computer should be able to cope with the game.
My laptops(Acer aspire 5930) stats are :
Intel core2 duo P7350(2GHz)
NVIDIA 9600 GT with 512 mb dedicated memory
3GB DDR RAM



I've fixed to other problems that i think were related ( audiodg.exe using like 50 % of my CPU and PunkbusterB wich was unupdated was doing roughly the same)

Also I had the process monitor up in the background whenever i was playing and i minimized whenever the game started to lag , but alas the problems above wich i fixed were the only ones I could find.

But still ! the problem hasn't gone away , this all only decreased the intervall ... i think

So please , if anyone happens to lie on the answear help me out. :hello: 

More about : problems bf2

January 19, 2010 6:46:07 PM

dorf said:
I'm sure anyone who's installed bf2 have have spent numerous hours of sweat and frustration of trying to fix several bf2 problems and issues , I know ... I've fixed my own bf2 and 4 of my friends. It's a pain in the ass :kaola:  Though it's one of my favorite games and i really do want this solved. The problem is : Whenever i'm running the game it once in a while( like every 5 minutes at least , but in a totally random intervall) the framrate drops significally and becomes unplayable virtually. This phenomenon passes in everything from 10 secs to 1 minute and I cant seems to work out what's the problem. I'm running on vista , and a laptop but anyways i think my computer should be able to cope with the game.
My laptops(Acer aspire 5930) stats are :
Intel core2 duo P7350(2GHz)
NVIDIA 9600 GT with 512 mb dedicated memory
3GB DDR RAM



I've fixed to other problems that i think were related ( audiodg.exe using like 50 % of my CPU and PunkbusterB wich was unupdated was doing roughly the same)

Also I had the process monitor up in the background whenever i was playing and i minimized whenever the game started to lag , but alas the problems above wich i fixed were the only ones I could find.

But still ! the problem hasn't gone away , this all only decreased the intervall ... i think

So please , if anyone happens to lie on the answear help me out. :hello: 


I think i've experienced this too, but only after the new patch a few months ago. The game lags for the first minute or so of entering it, before freeing up and running as normal until these lag spikes you describe. I've asked around on the server I usually play on ([EPIC]) and nobody else was experiencing it to my knowledge. The new patch was also around the same time I switched ISP to Tiscali (bit of advice, nobody move to them...or TalkTalk which is what it is now). Connection was terrible for the first 5 months before settling down, so i don't know if it's an issue to do with connectivity? I never really attempted to diagnose it i recall the gameplay improving when disabling background apps through msconfig, so that could be a possible solution to figure out which background app is causing it (you mentioned no cpu usage problem though).
January 19, 2010 7:14:33 PM

Well you said this is on a laptop and laptops have been none to have this problem (like mine). So from what i saw in my laptop, its has something to do with the laptop overheating so maybe you can try to run core temp and see what the temps are when the laggs start. Before you do that i just thought about something! do you get these lags only in multilayer or is it in single and LAN play as well ?!

Related resources
January 19, 2010 7:55:15 PM

i'm seeng nothing like this on the latest patch, so its not an inherent problem. +1 to ilikegirls heat could be an issue, but did you say that you saw it on 4 other machines?
January 20, 2010 12:48:35 PM

I havn't seen the same problem anywhere else , and thank you for your advise , i'm gonna check everything out.

It dsn't lag in singleplayer however I havn't really played it LAN that much and I also think this hasnt really happened until the latest patch ... I may recall wrong though :) 
January 20, 2010 1:11:20 PM

Well please feel free to update me on anything you need or any info you think might help us solve thie problem i know i love battlefield 2 but it rarely works like it should therefor on the 28th of this month the PC beta of Battlefield bad company 2 is coming out sweet !
January 23, 2010 12:34:31 AM

I need to install the 1.5 patch but I will keep an eye out for lags now. Have you guys checked on the EA forums to see if a lot of people are getting this?

Did anyone monitor GPU and CPU temps? Does any one run Fraps?
January 23, 2010 12:39:12 PM

SpinachEater said:
I need to install the 1.5 patch but I will keep an eye out for lags now. Have you guys checked on the EA forums to see if a lot of people are getting this?

Did anyone monitor GPU and CPU temps? Does any one run Fraps?

Well i can tell you only what i know. I know that my bf2 was running at 60fps at all times on my laptop. im sorry i never checked temps so i cant tell you but that would be something good to check !
!