Sign in with
Sign up | Sign in
Your question

Why do Directx 10 games not run in Directx 10 mode?

Tags:
  • PC gaming
  • Games
  • Directx
  • Video Games
Last response: in Video Games
Share
January 26, 2010 4:00:33 AM

Recently I have updated my PC to Windows 7. I have purchased some pc games that I know are Directx 10 Compatible. However, when I run the games my graphics tool (EVGA Precision Tool 1.8.1) shows that the program is running in Directx 9. At the moment I am attempting to troubleshoot with Prince of Persia (2008), though this poblem has occured with other games including Borderlands and Assassins Creed. The only game that has worked is Bioshock. I have attempted the following fixes:

1) Running the Program as the Adminstrator AND through the unlocked administrator account

2) Number 1 plus a compatibility to mode to Vista

3) Number 1 and 2 with running the installation program as the administrator and with vista compatibility mode.

4) Running DxDiag to ensure DX 11 is installed...it is

5) Updating Drivers for both Directx and Graphics Card

6) Reinstalling Game with and after all above attempts

All have not resulted in any success. My specs are below, and any and all help would be most appreciated. Thank you.

Windows 7 32-bit
Custom Build Computer
EVGA NVidia 260 Graphics Card
Pentium Dual Core 3.0 GHZ
4 GB DDR2 RAM

More about : directx games run directx mode

January 26, 2010 4:01:47 AM

As a quick addon, Only Assassins Creed mentioned above is a STEAM game. The rest are retail games.
m
0
l
Related resources
January 26, 2010 12:05:57 PM

^^ Thats only for DX9; DX11 includes the entire DX10+ library.

Make sure that settings are maxed; most games leave DX10 for the highest settings only.
m
0
l
January 26, 2010 12:18:21 PM

Check that you are using the DX10 exe file.
Often dx 10 games come with 2 icons after install, one for dx9 and the other for dx10.
Resident evil 5 for example does this and also give the option of either from the splash screen of the dvd.
m
0
l
January 26, 2010 1:56:30 PM

Thanks to both responders. I believe I already tried the End User-Runtime Update but I will try again. For the DX10 exe file, I am familiar with this procedure for a couple of games such as Lost Planet...don't know if Prince of Persia installs one though but I will try to find it. Thanks again, I'll update with results ASAP.
m
0
l
January 27, 2010 3:00:34 AM

Sorry for not noticing that there were three responders earlier.

So I updated Directx on Windows 7 with the August 2009 End User file from Microsoft and maxed out all settings on the game. I checked for another executible file in both the installation folder and the disk but I found none that specifically had a DX10 extension to it. All this was done in the unlocked admin account.

The game still runs in Directx 9 according to the EVGA precision tool
m
0
l
January 27, 2010 10:59:33 AM

Maybe the tool is just wrong? I tend to stay away from that type of software, as from my experiance, they never work properly.
m
0
l
January 27, 2010 11:55:16 AM

That is a possibility I have considered, though I have seen the tool register directx 10 before with Bioshock. Perhaps I'll try other games and see what happens. Is there any other way of knowing for sure that you are running a game in D10 or higher rather than just eyeballing it?
m
0
l
!