Sign in with
Sign up | Sign in
Your question

Fallout 3 freezes.

Last response: in Video Games
Share
January 28, 2010 6:49:49 PM

OK, I have the Fallout 3 game on patch 1.7 and it STILL freezes randomly. No rhyme or reason that I can figure. The sound marches on, but the screen freezes. No artifacts, it just locks. CTL/ALT/DELETE to the descktop and end task and start again.

Has anyone figured out what it is? I've tried the quad core to dual core .inf field change to make sure it sees only two cores to no real effect. I updated to the latest 64-bit Nvidia 196.21 drivers, too, and no difference. Running in XPSP3 mode does nothing, either.

This is driving me nuts, as well as hundreds of others. The game is pretty good, but it is a drag to save every two minutes. I'm wearing my F5 key out!

Nothing except this game is doing this. I have a very conservative system settings. It can lock in ten seconds, or one hour (never longer than that). It isn't heat.

My system;
W7 64-bit PRO (all drivers are 64-bit)
MSI P55 DG80 main board BIOS 1.60
Corsair 1600 4Gig RAM
MSI GT260 Video card
Corsair 750 watt supply
Creative Xtreme gamer sound card
WD 760 Gig Hdrive
i5 750 CPU @ 20 * 160MHz, 3.2Gig
Cooler Master hyper 212 cooler.

Best,
Rower30


More about : fallout freezes

January 29, 2010 7:45:00 AM

I've never been able to get FO3 to work and Bethesda tech support was useless. But spending as much time as I have on their forums, the nforce drivers cause problems and they suggest using older drivers not new.

http://www.bethsoft.com/bgsforums/index.php?s=&showtopi...


If that doesn't help, spend some time in that forum, lots more problems than answers, but its them most complete list of fixes I've found.

Good Luck
January 29, 2010 10:49:52 AM

OK all, I think I found the solution, at least on W7 64-bit. My error, it seems, is caused by the DEP program function buried into W7, and if DEP is in XP, it doesn't work the same as the game ran on XP SP3.

And no, Nvidia drivers aren't it besides, I have 64-bit W7 and I have but two driver versions to use, nor was it the four core i5 750 CPU needing to be limited to two cores in the .inf file. Then again, it may be updating the Nvidia drivers, limiting the CPU to two cores AND DEP setting to ignore Fallout3! Not till I changed the DEP settings did I seem to get anywhere. So far, I played an hour with no lock-ups, a record, but that's not to say 100% sure. But, I've never got this far before without a few.

So, if you have W7, go into the Data Execution Prevention, DEP, as shown in the link below, and add the fallout 3 file to the list of programs to leave alone.

What is truly aggravating, is windows doesn't even show these setting exist in a search for "DAP" or "data execution prevention"! let alone what it really does if you find it. Nor, does the file dump hint at this program stopping fallout 3 program execution.


http://www.itechtalk.com/thread3591.html
How to change Data Execution Prevention (DEP) settings in Windows 7?
!