Sign in with
Sign up | Sign in
Your question

Mass Effect 2 issues

Last response: in Video Games
Share
February 5, 2010 3:21:59 PM

When i play Mass Effect 2 i generally get good frame rates (low 50s - high 40s).
During cut scenes however, the frame rates plummet to 20 fps, or sometimes 0.
Then, it seems like the texture crashes, the screen turns purple and sometimes the game recovers. the sound never lags, but the video seems to stop.
If the game doesn't properly recover, i have so many random polygons covering everything that i have to restart the game.
Twice i've had to restart the PC (once i ended up having to do a system repair after, because windows wouldn't start).
Any Ideas?
Thanx for taking your time reading.

My computer is:
AMD: Athlon 64 X2 5200+ 2991 MHz
Mobo: Gigabyte M57SLI-S4 v.2
RAM: 4GB Mushkin DDR2 PC2-6400
OS: Win 7 64bit
VC: EVGA 8800 GTS 320MB

More about : mass effect issues

February 7, 2010 9:41:32 PM

maybe not enough memory on the video card, loss of textures and drop in framerate, try reducing resolution, tex,and depth of field, change the fsutil to 2
go to Start,Accessories, Command prompt, RIGHT click and select Run as Administrator, type fsutil behavior query memoryusuage, then Enter, it will probably return =0
type fsutil behavior set memoryusuage 2, Enter then play the game again
BTW I have even seen increasing the video optons to max everything helps, so figure
m
0
l
February 8, 2010 3:29:29 PM

thanx for the suggestion...
i found this tweak on howtogeek.com a while back when i had Vista and applied it to that OS. When i installed Win7 i used the same tweak again since it seemed worked at speeding up multi application launches
m
0
l
!