Installing an old CDROM win95

Hi

I'm trying to put a CDROM in an old Pentium 166, running windows 95b.

Basically what’s happened is I’ve transferred a hard drive from an old 486 that died into the newer Pentium 166 but can't get the CDROM to read anything.

I'm pretty confident the CDROM works; it powered on, and windows detected it when it booted for the first time with the new hardware wizard.

I've searched the net for ages trying to find drivers, but didn’t have any luck. I found a long shot at driverguide.com but it had a sys extension and windows would only look for inf extensions.

Is it possible to pull generic drivers off of the windows cd put them on floppy and simply transfer them to the appropriate place?

I've also tried using a 95 boot disk from bootdisk.com which apparently has 4 universal CDROM drivers. The default one didn't work, but I was a little unsure of how to change it to the others (will have another look a bit later). Even if this works though, I’m still not sure if it will help. If I do find one of the universal drivers work, can I simply copy it into windows somewhere and use it?

If anyone can help me out with this problem it will be greatly appreciated, its starting to wear me down. I don't have much experience with old software so its eating up way too much time, especially for something in the good will category.
8 answers Last reply
More about installing cdrom win95
  1. It's probably not ATAPI compatable. What kind of CD-ROM is this?

    <font color=blue>Only a place as big as the internet could be home to a hero as big as Crashman!</font color=blue>
    <font color=red>Only a place as big as the internet could be home to an ego as large as Crashman's!</font color=red>
  2. Thanks for the help Crashman

    I'm not actually able to tell you what drive it is right now (I've left work for the day ).

    I can tell you it’s a generic brand drive, its 24 speed, and it’s really hard to find a driver for p) at least for me :)

    I was getting non atapi compatible errors, with some jumper configurations, but I’m pretty confident this isn't the issue. I pulled the drive out and tested it in a fedora core 2 client and it worked (it sounded like a beefed up lawnmower but it worked :)

    I've also tried a few other old drives and had the same results. I'm pretty confident its a software issue, because of the way it was successfully probed by windows during its first boot.

    I'm almost certain it’s simply getting the right device driver for the cdrom. Where are the CDROM device drivers stored in win95?


    As a side note; what data transfer standard did we use before atapi?

    or... and does anyone have any driver search tips? They would be appreciated immensely, now & in the future. Thanks heaps


    <P ID="edit"><FONT SIZE=-1><EM>Edited by maxthepadewan2 on 10/17/04 07:54 PM.</EM></FONT></P>
  3. When you said old, I thought you meant pre-ATAPI.

    Windows 95 doesn't need a special driver for ATAPI compatable CD-ROM drives. And any IDE drive of 24x speed is ATAPI compliant. I haven't seen non-ATAPI IDE drives since the 2x days (although there were a few early 4x drives with the issue).

    So that leaves us with a configuration problem, or a problem with the cable itself. Make sure the drive is jumpered correctly and set properly in motherboard BIOS.

    <font color=blue>Only a place as big as the internet could be home to a hero as big as Crashman!</font color=blue>
    <font color=red>Only a place as big as the internet could be home to an ego as large as Crashman's!</font color=red>
  4. I've tested the CDROM, data cables and IDE slots and there fine.

    I'm 99% sure; I need to configure some windows files to get it working. I've been trawling around the net for the last few days, and found reference to mscdex which I guess is what you’re talking about. Came across this stuff at http://support.microsoft.com/default.aspx?scid=kb;en-us;142096

    4. To install Windows 95 from a CD-ROM, the real-mode CD-ROM drivers must be loaded in the Autoexec.bat and Config.sys files. If they are not, continue with these steps. If they are, proceed to step 9.
    5. View the Autoexec.dos file and note the line referring to the Mscdex.exe file.
    6. View the Config.dos file and note the line referring to the CD-ROM driver.
    7. Edit the Autoexec.bat file and add the MSCDEX statement you noted in step 5. Edit the Config.sys file and add the CD-ROM driver line you noted in step 6.

    The article is about installing Windows 95 to a new folder, but it’s kinda what I’m after.

    I used sysedit to have a look at the file they where talking about, and got cannot open autoexec.bat, so I think I’m getting closer to the problem (I forgot to mention this isn't a clean install, it was just a HDD transplant)

    I searched for autoexec and nothing came up, so I'm guessing it was removed/disabled for some reason at another time.

    Is there a way to recreate the autoexec.bat file?


    <P ID="edit"><FONT SIZE=-1><EM>Edited by maxthepadewan2 on 10/17/04 07:23 PM.</EM></FONT></P>
  5. I see the problem: You don't know what you're talking about!

    Joking dude, OK, let's get started!

    To begin with the article you brought up discusses making a bootable floppy with CD drivers or similar actions to provide DOS mode CD-ROM support. Anyways, that's a diversion, if you wanted to install Windows 95 from CD you'd be best off downloading a 98SE boot floppy from bootdisk.com.

    Getting back to what you REALLY want to do, there are a few reasons an ATAPI drive might not show up in Windows 95.

    The first and easiest is a backwards cable. If your CD-ROM activity light stays on, you have at least 1 end of the cable switched. The good news is, for unkeyed cables you can have both ends switched and everything will work normally, so under the situation where the drive activity light stays on with no CD in the tray, it doesn't matter which end you flip over to correct the issue.

    Moving on, a more serious problem under Windows 95 that would prevent the CD-ROM from working, or any other drive for that matter, on the secondary IDE cable, is the IDE controller driver. It's often the case that the primary IDE controller works, but not the secondary. And it can be a real pain to find the correct driver and get it installed. A shortcut would be to install the CD-ROM as primary slave, rather than secondary master.

    With Western Digital hard drives, that means changing the jumper from "Single" to "Master". Most other drives use the same setting for single as for master, WD just had to be different.

    <font color=blue>Only a place as big as the internet could be home to a hero as big as Crashman!</font color=blue>
    <font color=red>Only a place as big as the internet could be home to an ego as large as Crashman's!</font color=red>
  6. The best cure for w95 was ALWAYS the old and trustworthy Mitsumi CD rom driver for DOS which is loaded at the system start up (and it created that Autoexec thing as well also too). The issue you have is with the IDE controller driver and there is nothing you can do but find the Mitsumi floppy (I'll dig one out somewhere in my closet if you'll ensist with the long green paper bill ;o) or delete IDE drivers and let it find it again.

    PS: to tinker a little, remove the secondary and then primary IDE driver from the Device Manager and let it find it after the reboot again (reboot manually, caz it is going to hang after Primary IDE will be deleted), that fixes the problem sometimes, but it is a tricky thing to do, sometimes I had to do it a few times to get it back to normal breathing and see CD rom again;) I forgot from the top of my head, but I did load IDE drivers from 98 CD when it was asking for them after the reboot, so that works too.

    ..this is very useful and helpful place for information...
  7. by the way, type your massage here first, then copy paste into Word for spell check and copy paste the message back here again, caz those " ' " apostrophe thingies are displayed as a # signs if you copy them directly from word into here first.

    ..this is very useful and helpful place for information...
  8. Yes, I know this is a long time ago.

    The problem does have to do with what the person is talking about when they mention the Autoexec.bat and Config.sys.

    The solution is to Restart Windows 95 in DOS mode at shutdown.

    Type the old DOS command at the C:\ prompt Edit Autoexec.bat.

    You should have something like:

    @echo off
    setup
    Path C:\Windows;C:\Windows\Command
    The line you need should look something like:

    C:\WINDOWS\COMMAND\MSCDEX /V /D:CD003 /M:10

    If it is there and has a REM note, use that line, and remove the REM. Save the file.

    Go back to DOS. Tye the old DOS command at the C:\prompt Edit Config.sys

    The line you are looking for should look like this.

    Device=C:\CDROMDRV\USDIDE.SYS /D:CD003

    Save the line or remove the REM and use the line as above.
    I tried to put in an old hard drive on the system and put a REM in front of those lines to get the old hard drive going. I realized my mistake and went to the Autoexec.bat and Config.sys and removed the REM and it worked for Windows seeing the CD-ROM. Before I removed the REM, DOS was seeing the CD-ROM and Windows was not.
Ask a new question

Read More

Windows