Sign in with
Sign up | Sign in
Your question
Closed

Cant connect BC2

Last response: in Video Games
Share
March 2, 2010 9:52:41 PM

I just installed the game, but i cant connect to any servers, play now never works, and when i do server browser, all that shows up is like 10 port valdez games. WTF is happening?

More about : connect bc2

March 2, 2010 10:04:52 PM

UPDATE: problem solved, needed update, sorry, posted before using my brain.
Score
0
March 2, 2010 10:41:58 PM

You pwning with your l33tsauce now? I am at 53% ATM. TIME IS CRAWLING>>>
Score
0
Related resources
March 3, 2010 4:20:34 AM

the game is buggy, singleplayer works flawless but once you try to play a decent multiplayer game you either cannot connect or get a PB error... well at least that is my issue..
Score
0
March 3, 2010 11:09:13 AM

I know theres a connection bug that kick out some users after 5 minutes [Its a firewall problem for some routers; I debuged this WAY back when 2142 came out; you need to totally disable your routers firewall if you get this issue...], but other then that, game works almost flawlessly thus far. Truly a replacement for BF2.
Score
0
March 3, 2010 11:20:31 AM

I have connection issues on MP and sound issues on singleplayer. While playing SP, I have to read the captions as their voices do not work. The graphics are beautiful though. The game is buggy, but I have come to expect this from dice. It happens with every battlefield release.
Score
0
March 3, 2010 3:32:16 PM

Yep =)

well this morning I woke up at 6am just to be able to play for at least 90min before work, I had no issues at all other than a few admins kicking me out of a few servers. As time goes by it will get better..

Now the game is really GPU demanding, on some maps my FPS drops to 40ish in heavy combat (medium settings). On Ultra the game is unplayable with a single GTX 260.
Score
0
March 3, 2010 5:40:55 PM

How GPU intensive? I'll be trying to run it with two 8800 GTS's (320MB) in SLI as soon as I get my check this week.
Score
0
March 3, 2010 6:35:03 PM

you are fine =) , just make sure you lower the settings if you do experience any lag.

also make sure you run the game at 3Ghz or higher if possible.

Score
0
March 3, 2010 7:07:40 PM

EDIT: I OFFICIALY VOTE THAT THIS GAME SUCKS. UNTIL EA CAN GET THEIR S**T STRAIGHT, IM DONE. This is seriously PATHETIC of a company like this to screw up a game that was anticipated so greatly.
Score
0
March 3, 2010 7:43:36 PM

????

lol, its working like butter for me =)
Score
0
March 3, 2010 7:44:11 PM

WHAT? HOW? everyone i talk to has the same problems as me
Score
0
March 3, 2010 7:47:47 PM

Dude if you go into the servers area you will see hundreds/thousands of people playing online.

What problem are you having?

Score
0
March 3, 2010 7:49:53 PM

EVERYPROBLEMIMAGINABLE
No connecting and when i do its for a maximum of 2 minutes. im reinstalling right now. fatal and spinach were have exact same probs last night as me.
Score
0
March 3, 2010 7:58:08 PM

Nooooooooo, it has nothing to do with the installation.

There are still a bunch of users that are having the same issue as you, its on EA's side, has nothing to do with you. I had the same issue last night, today when I got home from work it was kicking me out, so I kept on trying till it let me play for about an hour. Then I logged off the PC and when I came back I was having the same issue. It's hit or miss till they fix the problem. Right now my nephew is playing on my comp just fine, but he had to try at least 10-15 times till he found a server that actually works. I have about 10 buddies that are playing right now from my list and about 6 that are having issues. This should be fixed soon..
Score
0
March 3, 2010 8:01:26 PM

Already isntalling for 2nd time.
and this is still totally pathetic, well, EA is pathetic so its expected.
Score
0
March 3, 2010 8:41:34 PM

AAHHHHH now anytime i try to even play single player it crashes!
Score
0
March 3, 2010 10:37:01 PM

really?

My single player works flawless, did you download from steam or buy the game at a store?
Score
0
March 4, 2010 1:19:07 AM

Store
Score
0
March 4, 2010 1:26:25 AM

yea the servers went down again...now its a waiting game..
Score
0
March 4, 2010 3:27:50 AM

Ah! finally up and working! got 3 hours of gaming in! wooot!
Score
0
March 4, 2010 3:47:57 AM

wha?

ahh!! now its me that cannot connect...lol
Score
0
March 4, 2010 11:51:23 AM

So are you guys playing the full ver? 1 day to go for uk..... As for EA cocking up the release they have cocked up every BF release since 1942. BF2 had a 1.5gb patch with a month or so of release. Expect the game to run flawlessly in a year or 2 hehe
Score
0
March 4, 2010 1:36:47 PM

The game runs fine, I played last night for about 5-6 hours on multiple servers. The issue was that EA did not anticipate the number of users that purchased the game at launch and it caused a malfunction on EA's side. This has been resolved AFAIK. This morning I was also able to play for a bit w/o any issues.
Score
0
March 4, 2010 2:19:25 PM

I will have to try MP again when I get home. SP leaves a lot to be desired and is not the core of the battlefield series. I want to smoke some of you guys, but have only gotten on one server for about 3 minutes before being kicked. I even made sure PB was up to date before trying yesterday. I will try again today...hopefully it works :-/
Score
0
March 4, 2010 3:34:43 PM

JDV28 said:
EVERYPROBLEMIMAGINABLE
No connecting and when i do its for a maximum of 2 minutes. im reinstalling right now. fatal and spinach were have exact same probs last night as me.


Again, I debugged this for EA back when 2142 had the same exact problem. Heck, other EA games [Dragon Age, Bioshock 2, etc] have the same exact problem with EA servers. You connect fine, then get dropped every 5 minutes.

Based on my testing, I *think* its built in SPI protection built into router firewalls that causes the connection to drop, although until I get a router that has this as a seperate option, I can't say I'm 100% sure.

In my case [and several others I tested with], turning off our router firewalls completely off solved the problem. DMZ didn't work, nor did forwarding EVERY TCP/UDP port in existence. Its a firewall/EA issue. Something built directly into router firewalls causes the loss of connection.

As I understand it [from the last time I debugged this], the EA master server basically querys all connected players every 5 minutes to get global statistics updates. For some reason, that connection ends up getting blocked, which causes the disconnect (as the Master Server thinks you are disconnected at that time).

I know disabling your routers firewall isn't exactly a *fix*, but it does prove theres a compatability problem somewhere. Then you can give the router type to EA, and help them debug the issue [despite the fact they released a patch that fixed the issue in 2142, so theres no possible reason this bug still exists almost 5 years later...]
Score
0
March 4, 2010 6:18:46 PM

gamerk316 said:
Again, I debugged this for EA back when 2142 had the same exact problem. Heck, other EA games [Dragon Age, Bioshock 2, etc] have the same exact problem with EA servers. You connect fine, then get dropped every 5 minutes.

Based on my testing, I *think* its built in SPI protection built into router firewalls that causes the connection to drop, although until I get a router that has this as a seperate option, I can't say I'm 100% sure.

In my case [and several others I tested with], turning off our router firewalls completely off solved the problem. DMZ didn't work, nor did forwarding EVERY TCP/UDP port in existence. Its a firewall/EA issue. Something built directly into router firewalls causes the loss of connection.


That is good to know. I am going to try plugging directly into my modem tonight to see if it makes a difference with the connectivity.
Score
0
March 4, 2010 6:28:41 PM

If you guys a did a bit of research you will see where the issue has nothing to do with firewalls/connectivity etc.. This is an issue on EA's side. Once you click on the BC2 icon on your desktop and the game comes up you will see a bar on the bottom of the screen that describes what is going on =). Also, if you have the beta installed it may cause conflicts with the game itself, why? Im clueless but that is what the rep told me to do. Since then I can connect everytime I try, hope this helps..

If you are still in doubt call EA tech dept and you will see what I mean...
Score
0
March 4, 2010 7:26:35 PM

Yea, OvrClkr is right, EAs deal, but they finally fixed it!
Score
0
March 4, 2010 7:46:01 PM

JDV28 said:
Yea, OvrClkr is right, EAs deal, but they finally fixed it!


hehe, I see you are much happier compared to yesterday :lol: 
Score
0
March 4, 2010 9:05:09 PM

Yea, i was so P'd off lol.
but now they screwed up the friends.... none show up and friend requests dont even work.
Score
0
March 4, 2010 9:45:49 PM

yea it will be a few weeks till they can resolve all the issues, hopefully..
Score
0
March 4, 2010 10:11:49 PM

NO, that is unacceptable. Im sure it will be perfect by sunday. A few weeks? HAH nobody would keep playing. It shouldnt take anytime at all! it should work on release.
Score
0
March 4, 2010 10:28:44 PM

Well im not talking about yesterdays issues because that was already resolved, im talking about the bugs and a few glitches here n there. All games go through this stage, its up to you to hang in there =)
Score
0
March 4, 2010 10:30:53 PM

The no friend issue should have never happened though.
Score
0
March 4, 2010 11:51:57 PM

yea well my friends list works on and off, im cool as long as i can play plus all my friends connect through steam so even if the in-game list fails you always have steam =)
Score
0
March 5, 2010 10:19:51 AM

Ew, steam.
Yea they fixed it late afternoon yesterday, so i think everything is fixed. Well the major stuff is fixed anyways.
Score
0
March 5, 2010 6:22:22 PM

OvrClkr said:

Now the game is really GPU demanding, on some maps my FPS drops to 40ish in heavy combat (medium settings). On Ultra the game is unplayable with a single GTX 260.


Dude. go out and get the 5770 1gb. Runs pretty much flawlessly maxed out settings. Im getting anywhere from 40-60 fps.. Rarely dipping to 35.
Score
0
March 5, 2010 6:38:56 PM

FATAL STR1K3 said:
Dude. go out and get the 5770 1gb. Runs pretty much flawlessly maxed out settings. Im getting anywhere from 40-60 fps.. Rarely dipping to 35.


When I say ULTRA I mean all settings maxed out including x16AA ;) 

The 5770 cannot achieve playable frames at the above settings, my GTX 260 is about 5-10% faster than the 5770 depending on game ;) 

Without xAA i get a constant 60FPS (v-sync enabled) with occasional drops to about 52FPS.




Score
0
March 5, 2010 6:41:35 PM

OvrClkr said:
When I say ULTRA I mean all settings maxed out including x16AA ;) 

The 5770 cannot achieve playable frames at the above settings, my GTX 260 is about 5-10% faster than the 5770 depending on game ;) 

Without xAA i get a constant 60FPS (v-sync enabled) with occasional drops to about 52FPS.


don't judge me. :kaola: 
Score
0
March 5, 2010 6:56:58 PM

FATAL STR1K3 said:
don't judge me. :kaola: 


hehe, not judging you just pointing out the difference between having xAA enabled vs. no xAA at all ;) 
Score
0
March 5, 2010 6:59:40 PM

OvrClkr said:


Now the game is really GPU demanding, on some maps my FPS drops to 40ish in heavy combat (medium settings). On Ultra the game is unplayable with a single GTX 260.

NO, my gtx 260 handles the game perfectly with everything and I mean EVERYTHING totally maxed out, including AA and all.
Score
0
March 5, 2010 7:05:46 PM

JDV28 said:
NO, my gtx 260 handles the game perfectly with everything and I mean EVERYTHING totally maxed out, including AA and all.


Well it depends on what you mean by "handles the game perfectly" ;) 

My definition of flawless is a constant 60FPS with rare drops.

I will post a video tonight so you can get an idea ;) 
Score
0
March 5, 2010 7:15:04 PM

UGH i hate when people think they can tell a difference between 50 and 60 fps..... Its like saying you can count how many times a propellor on a plane spins by looking at it.
Score
0
March 5, 2010 7:26:58 PM

Well in most games you cannot tell the difference but BC2 is not one of them. When I blow up a tank that is 5 feet away from me my FPS drops to about 52ish for about a second and the game lags.
Score
0
March 5, 2010 7:29:14 PM

Because you can tell a difference when the screen is orange and red only from the explosion.
Score
0
March 5, 2010 7:45:32 PM

JDV28 said:
Because you can tell a difference when the screen is orange and red only from the explosion.


No, what I mean is that the game still has a few bugs that need to be fixed. This same issue happend when BF2 came out ;)  . 52FPS should still be smooth and not laggy even if it is for a split second.




Score
0
March 5, 2010 7:47:02 PM

Oh ok i see what you are saying. Do you mean that you shouldnt be able to tell a difference between 50 and 60fps, but in this game you can?
Score
0
March 5, 2010 8:16:38 PM

JDV28 said:
Oh ok i see what you are saying. Do you mean that you shouldnt be able to tell a difference between 50 and 60fps, but in this game you can?


Well sorta because you cannot compare BC2 to other FPS since there is much more going on (flying debris GALORE/bigger explosions/ bigger maps etc..

In games like MW2/DIRT2/L4D2 I really cannot tell the difference when it comes to 50FPS vs. 60FPS. Of course this has to do with BC2 being a brand new title that still has some glitches here n there that need to be addressed.

In other words BC2 at 50FPS is not as smooth as other games at the same frame-rate.

Score
0
March 5, 2010 8:29:03 PM

Yea i wasnt sure if anyone noticed that it seems like its raining broken buildings and vehicle parts haha. And ok, that makes more sense than what i got out of that first post. I havent been keeping fraps open, so im not sure what im getting and i really do not care. If i dont see any stuttering or lag, than as far as I'm concerned, i am getting 400fps.
Score
0
!