Sign in with
Sign up | Sign in
Your question
Solved

Bad Company 2 Problems...

Last response: in Video Games
Share
March 7, 2010 11:13:00 PM

Multiplayer works fine besides EA's over populated servers that constantly kick you.

My problem happens in single player I can't even get passed the very first level because right after the dialog finishes the screen goes black as if its going to load the movie and it never loads. I tried running it in administrator mode and backwards compatibility mode just to see if that my fix it and it never did. The game ran fine on my old 9800GTX but i could only run it on medium. Anyone have any idea what my problem is?

System specs:
CPU: Phenom II X4 955 BE 3.2GHz
RAM: 4GB OCZ 1066
GPU: Gigabyte ATI 5850
HDD: WD x2 500GB
Motherboard: GA-770T-USB3
OS: Win 7

More about : bad company problems

March 8, 2010 12:53:01 AM

It should work even without compatibility mode, since BC2 is designed for modern OSes.

Do you encounter problems with other games? Or is your issue limited to BC2 only?
March 8, 2010 1:23:37 AM

I kinda figured that but i thought it couldnt hurt to try. So far its only been BC2
Related resources
March 8, 2010 1:50:43 AM

You should try reinstalling the game.
March 8, 2010 2:06:21 AM

If you check EA forums, you'll find there's a wide array of serious crashing problems, though ironically most of them are only in multiplayer, rather than being only in single player. Problems seem to be on a wide array of different systems, old, new, AMD, Intel, ATI, nVidia, you name it, people are having serious problems. Driver reinstalls, OS and game reinstalls, there's several people claiming workarounds by disabling your onboard audio (yes, this means playing without sound if you don't have a separate sound card) or editing the settings.ini file to turn off bloom and force DX9 mode. I, however, have tried every and all of them to no avail after over 20 hours of work on this issue, leading me to believe this is a game bug that isn't readily fixable. So, you might be waiting until, or rather if, EA/DICE fix the problem.
March 8, 2010 2:20:20 AM

yea I just tried to switching around all the setting to see if i can get it to work and nothing seems to work. At least i can run multiplayer well except for PB on some servers. (I updated PB BTW)
March 8, 2010 3:26:32 PM

The game has major issues right now, sometimes I play a flawless game and when the game is over it auto crashes to desktop and I lose any progress that I had.

To the OP, just FYI.. When you get kicked from a server it has nothing to do with the server being overpopulated, the server admin kicks you becuase he can =) . I know it is frustrating but that is one of the few downsides of dedi-servers.

Best solution

March 8, 2010 7:36:50 PM
Share

I had a problem similar to this a few days ago, except in single player right when the first little clip finished, it crashed. Fixed by reinstalling for me.
March 10, 2010 4:32:28 AM

im going to try and reinstall and see if that fixes my problem
March 10, 2010 2:25:06 PM

Here's one for you guys

Hope you can help. I have a Q6600 quad core, 3 gig ram, ATI radeon 2600 hd pro 512 card,G15 gamers keyboard and a logitech LX7 cordless optical mouse.Also runnin windows 7. The problem is game interaction, keyboard and mouse specifically. Keyboard when you push W A S D player will only move right or forward, even when S or D is pushed..The mouse, player will only look right and up no matter which way you move it. Now I've re-installed game 3 times..patched it once(caused crashing after openin creds). updated drivers on both keyboards and mouse..I've even swapped out the mouse for a corded one, no luck..Any suggestions???

March 10, 2010 5:13:17 PM

Your video card WILL NOT run this game.
March 10, 2010 5:38:10 PM

thanatosjkm said:
Here's one for you guys

Hope you can help. I have a Q6600 quad core, 3 gig ram, ATI radeon 2600 hd pro 512 card,G15 gamers keyboard and a logitech LX7 cordless optical mouse.Also runnin windows 7. The problem is game interaction, keyboard and mouse specifically. Keyboard when you push W A S D player will only move right or forward, even when S or D is pushed..The mouse, player will only look right and up no matter which way you move it. Now I've re-installed game 3 times..patched it once(caused crashing after openin creds). updated drivers on both keyboards and mouse..I've even swapped out the mouse for a corded one, no luck..Any suggestions???


If this issue only comes up when playing BC2 it is most likely your GPU. If not then it has nothing to do with the GPU itself, might be a board issue (usb).




March 10, 2010 8:23:25 PM

Your GPU is out dated. I use to have a 2900xt, and I would have trouble running CSS sometimes. (custom maps... lol) and my old 9800GTX can barley run it on medium. It can also be your keyboard but your GPU definitely cant run this game.

By the way reinstalling did the trick and it kept me up all night playing Single player. Thanks for the help guys! JVD you get best answer.
March 10, 2010 8:24:48 PM

Best answer selected by Smacky2.
March 16, 2010 11:46:35 PM

I have the same problem cant move forward in single player or multiplayer sometimes..makes the game unplayable...yes its the retail- no i dont have anything plugged in ( joystick,pad) I have updated all my drivers, switched to a different mouse, different kepboard, uninstalled graphics drivers, the game...all with no luck.. Not sure what else i can do but wait for a patch :(  Thanks Dice!!!

Intel 9550 (2.8)

ATI 4890

8 gigs ram

vista-64
!