Sign in with
Sign up | Sign in
Your question

Age of empires 2 wont load

Last response: in Video Games
Share
March 12, 2010 4:03:25 PM

I've just bought a new laptop with windows 7 installed. I intalled my fave game age of empires II the age of kings and it installs fine but when I go to load and play it all it does is load a pic saying 'loading' then that disappears and it sounds like it's loading for a few seconds then nothing happens.
Please help.

More about : age empires wont load

a b $ Windows 7
March 15, 2010 3:53:55 PM

According to Microsoft's website, it states this is compatible with either the 32-bit or 64-bit version of Windows 7 -> http://www.microsoft.com/windows/compatibility/windows-...

Have you installed all drivers? What are your laptop specs? Laptops are not necessarily the best platform for gaming unless you specifically purchased one that was built for gaming. Of course, with AOE, it probably shouldn't be an issue.

Having you also set the compatibility mode to XP to see if that works? Just go to the AOE icon, right click on it and go to the compatibility tab and set it to XP SP3 or XP SP2 or XP mode and see if that fixes it.

March 15, 2010 4:34:33 PM

try alt ctrl delete and see if it says it still runnig 1st then come bck and say if it is or not.
Related resources
May 9, 2010 8:35:05 PM

Any further solutions to this problem? I experience the same thing with AOE 2 on one of my laptops that is running Windows XP. It loads up fine on the other laptop and the PC (both with the same operating system...).
4 minutes ago

Hey, so I have AoE2 and the expansion on a disc from like 8 years ago and they won't play on my new laptop. My new laptop has windows 7. When it starts, it loads the "pre-loading" screen with the logo on it but then it doesn't do anything else. I have tried troubleshooting the compatibility and that worked to no effect. Please help, I miss this game and Steam will not have my money.
!