Sign in with
Sign up | Sign in
Your question

Bad Company 2 crashes my system.

Last response: in Video Games
Share
March 13, 2010 4:07:23 AM

I've been playing since BETA and this has only been happening since yesterday, My comp has crashed about 3 times now in this 2 day period while playing, sometimes its within 20 minutes sometimes about 3 hours of constant playing.

My system temps are always low, my GPU never exceeds 51C and my processor never exceeds 46C while playing.

My system specs are:
XFX 5870
Intel I7 920
OCZ gold 1600mhz tri-channel RAM
EVGA E758-A1 motherboard
WD caviar black 500gb SATA HD


All my drivers are up to date. This problem only happens when im playing bad company 2, never in any other game i play. And it also never happens in single player only multiplayer

I never lag in bad company 2 and i know my machine can easily handle it.

the BSOD message was BCCode 124 and the Locale ID: 1033
March 13, 2010 3:07:06 PM

Reinstall
m
0
l
March 14, 2010 12:17:03 AM

I agree with JDV28, try re-installing. Also maybe try disabling the anti virus/firewall while playing and see if it still crashes.

Probably not the problem but what kind of power supply do you have.
m
0
l
Related resources
March 16, 2010 3:49:06 PM

I'd uninstall the game and make sure the BETA is uninstalled as well, then reinstall. Sounds odd to me.

You GPU never exceeds 51C? really? I have a 5870 and it hits 85C. I used MSI Afterburner to change the fan profile a little bit to keep it around 75C. I have no issues. I had slight artifacts in one map but it might have been a glitch in that round or something, as I haven't had it since.

I have 2 buddies with Nvidia cards that reported the screen studders though., but that is all I've heard of an issue with the game.
m
0
l
March 16, 2010 10:58:55 PM

Are you getting bsods or just crashing to the desk top?

For what it is worth, I was crashing quite a bit too and only in BC2 for some reason. I took my OCs down one at a time and it was for certain my CPU OC that was doing it. I was at 3.4Ghz with temps that were just fine but it seems like I have to be at 2.8Ghz to avoid crashing.

Jay, my 5870 runs around 55C under full load but I set my fan to 45%. If yours is at 85, you might benefit from a thermal paste renewal. I did that with on of my 4870s that ran in the high 80's out of the box and it took it down into the 40's.
m
0
l
March 17, 2010 1:10:02 AM

I might have to try that. Im not that concerned really. I don't have any issues. Maybe if I OC it someday. I did OC it and didn't really get any benefit in 3Dmark. Although that is a bad way to compare performance. But no real games put a hurting on it so until then I will run stock.
m
0
l
March 18, 2010 12:41:15 AM

I have been getting a few C to Ds in this game also, or it just freezes and i gotta kill the game process, not really concerned though.
m
0
l
March 18, 2010 3:26:28 PM


Try reinstalling and patching your copy of BC2 to the latest version.
After unistalling use CCleaner to clear all the registry entries of the BC2 prevous installation. That should take care of the problem :D 
m
0
l
March 18, 2010 4:04:15 PM

JDV28 said:
I have been getting a few C to Ds in this game also, or it just freezes and i gotta kill the game process, not really concerned though.

I have some buddies that have Nvidia cards and have had a few wierd issues. The game is choppy even though they have a decent card and is running 60FPS. One is a 260 the other a 285 on liquid OCed. I think there is something funny with the Nvidia drivers and this game. I'm sure they will patch it. I've had the game close out on me in the menu twice, and once during a game it froze, but could have been the server.

Here is a humorous story. So i was in a squad with 2 buddies and we were on SKYPE. This was right after we all got the game and were exploring a little. The one dude is like, man if you blow up the big gas tanks they go BOOM and take down the one warehouse. I was an engineer so they were ragging on me to RPG it. Side note, these are the two dudes with the Nvidia cards. So i turned blew it up, and was like "WOW!". The next thing I heard was "what the crap, my game just froze" both said this at the same time. I laughed and said "go Nvidia". It was just a funny moment and sotta adds to my thought of there is an Nvidia driver issue with BC2. But I'm sure Nvidia is all over it.
m
0
l
March 18, 2010 5:01:01 PM

Haha, that is funny. I have had some crashing from explosions as well with my ATI card. I think it is something Dice has to fix unless there is a vga driver conflict going on. I remember crashing when my RPG hit a tank and various other times when getting blown up in a vehicle. It seems like the beta had a known bug that the game crashed when getting blown up in a tank. Who knows though...it could even be an issue with the sound of the explosion that is causing crashes.
m
0
l
March 18, 2010 5:33:09 PM

2 nights ago BC2 downloaded a HUGE patch. Well it was huge to me on my 1MB cable connection. It took probably 20-30 minutes to download. Not completely sure what all is fixed. I have been seeing slight changes. for examply it says how many hours you played instead of some number. And it has a kill to death ratio rather than actual kills and deaths.
m
0
l
March 19, 2010 2:27:04 AM

I am having the same problems. This game is a major crash fest in my PC. My temps are low as well and I don't any kind of problems running other games.

Sometimes I get the crash to desktop thing and other times it freezes and go to BSOD, it says something about crash dump or dumping system memory to disk. It must be sometihng with this game, it's definitely not my machine.

My game is not BETA, I bought the full version from Steam. Every thing is up to date, because Steam does every update automatically before the game starts.

Does anybody knows how to fix this crap?

Thanks in advance.
m
0
l
Anonymous
June 22, 2010 4:14:43 AM

Same issues here unfortunately..

I crash whenever i use the tank and try to shoot.. sound stays on, video is done.. frozen.

Why did i buy this game :( 
m
0
l
!