Sign in with
Sign up | Sign in
Your question
Solved

Assassin's Creed, 1.02 patch and cd-rom recognition

Last response: in Video Games
Share
March 21, 2010 12:03:24 PM

Assassin's creed ran fine until I downloaded the 1.02 patch. Then it refused to recognize the DVD. It is an original, purchased DVD. I have no virtual drives (which I heard can be an issue). I have tried uninstalling and reinstalling with no 1.02 patch, but I continue to have the same problem.

Any help out there?

Thanks in advance.

Ivan
AMD Phenom II 955 3.2Ghz
4G Kingston DDR-800
ASUS M4A785 MB
Seagate Barracuda 200G
PHILIPS 6216 DVD
PHILIPS 1628P1 DVD+/-RW
Windows 7 Home Premium 32-bit

Best solution

March 21, 2010 12:26:55 PM
Share

Well, if it's occurring even without the patch, it makes me wonder if either the DVD is dirty or scratched or if your DVD lens is dirty?

Have you tried it in another DVD drive? Do other DVDs work in the drive? If it does work in another DVD drive, then I would get a DVD lens cleaner and run it through your DVD drive in question.

Otherwise, I have no idea other than to take the game back to the store and see if you can exchange it, depending on how long ago you purchased the game.
March 21, 2010 12:38:29 PM


Thanks, isamuelson.

The disk looks new and is legible for a reinstall or a read in other drives. I tried it in both drives on my computer, and both only have a problem reading this disk for a game launch (no problem for reinstall or reading other disks).

I have been looking around a bit, and the problem seems to possibly be related to the 1.02 patch install. I am going to uninstall the game and nuke every reference that I can find (to make sure I get all the patch) and then try reinstalling it.

Thanks again.
Related resources
March 21, 2010 5:26:51 PM

I tried reinstalling again. The only thing that seems to work is to use a NO CD Crack. I don't like to go that way, but, since I did buy the game, I don't feel that bad. Just hope it doesn't come back to haunt me.
March 21, 2010 11:19:05 PM

I just bought Assasins Creed two days ago.
The game disc took care of all updates at UBIsoft upon installation.
I didn't have to do a thing.
I noticed the date said 2008 and this game was $19.99
(as Assasins Creed II PC is out and it is $59.99)
I can't imagine it not updating itself automatically though.
Check for a download manager update or you may need to contact UBIsoft for a solution.
Sorry I coudln't be of more help.
March 22, 2010 2:44:21 PM

Where did you purchase the game from? How long ago did you purchase it? I'd return it and try and get an exchange.

March 29, 2010 1:50:02 AM

Best answer selected by Iman_.
!