Sign in with
Sign up | Sign in
Your question

Low FPS playing BFBC2

Last response: in Video Games
Share
March 22, 2010 5:05:00 AM

I have been playing BFBC2 and getting 20-30 FPS with low settings and 1024 x 768 resolution. I recently upgraded my graphics card from a 7900GT to a 5750 and I feel like I should be getting better fps especially at the low settings.

My setup is :

AMD Athlon 64 X2 5400+ Windsor 2.8 Ghz
XFX HD5750 1gb
3gb corsair DDR2 ram
650w ABS PSU

I also get a lot of VPU recovery errors. I have the latest video drivers and my card only gets to 51 degrees C. What do you guys think the problem could be?


More about : low fps playing bfbc2

March 22, 2010 10:55:31 AM

It's your CPU more than likely. Minimum is a core 2 duo but the recommended is a quad core CPU. You could probably drop a 5770 in there and you still wouldn't see much of an improvement because your CPU is bottlenecking your GPU.

Have you turned down the details to the lowest settings to see if that helps? Also, did you connect the power cable to the video card?
m
0
l
March 22, 2010 10:57:10 AM

you're first step to deal with kind of stuff is to make sure. to clean reinstall you're graphic card driver.
you may use driver sweeper
http://downloads.guru3d.com/Guru3D---Driver-Sweeper-%28...
, first uninstall the current driver ----- reboot
download and install the new catalyst driver 10.2 ,, 10.3 will be out soon next week.
after installing reboot again,
and you are done.
m
0
l
Related resources
March 22, 2010 1:35:45 PM

isamuelson said:
It's your CPU more than likely. Minimum is a core 2 duo but the recommended is a quad core CPU. You could probably drop a 5770 in there and you still wouldn't see much of an improvement because your CPU is bottlenecking your GPU.


Nail on the head buddy. BC2 is CPU heavy. Check out this page for a BC2 performance review. Granted it uses 2 i7 models but you can see the difference in FPS. http://www.xbitlabs.com/articles/video/display/battlefi... My buddy has a stock clocked 5770 on a new AMD 965 Phenom II system and he runs at 1280x1024 and maxes the game out, so put that in perspective to a 5750, which performs only about 10% under this. It's your CPU.

This shouldn't generate VPU errors though, I would upgrade your drivers to the latest from AMD's site, 10.2. 10.3 will be coming out within a few days, but 10.2 should be sufficient for stability. If you used the drivers from the CD alot of the newer 5xxx models are having issues with them, just get the latest directly from AMD. If that doesn't solve the issue you could have a faulty card.
m
0
l
March 22, 2010 5:02:57 PM

OK thanks all for the advise. I will probably end up rebuilding the computer in the near future, but I was hoping I would get by for a little while with this CPU.

I will clean my drivers off and reinstall and see if that helps at all. I never used driver sweeper when I deleted the nvidia drivers from my 7900GT, i just manually deleted them, do you think that could cause a problem?

I will play around with different resolutions also. Do you think running the game in DX9 would help?
m
0
l
March 22, 2010 5:24:48 PM

Turning off DX10 usually doesn't help. I know with Resident Evil 5 it does because the only reason they have DX10 is to enable the nVidia 3d vision. However, your card is more than capable of rendering DX10 and that's not CPU bound as far as I know.

The main problem is just as jay2tall stated. BC2 is very CPU heavy and as the article he pointed states, it appears to be the physics calculation that is being offloaded to the CPU as they don't see the same issues with an nVidia card. I myself don't know if BC2 uses PhysX or not, but it almost appears that way.

I do know that if you enable PhysX in a game with a non-nVidia card, your framerates will drop (such as in Batman: Arkham Asylum). I don't know if BC2 has a way to turn that off. I don't own the game so I can't help you much more.
m
0
l
March 22, 2010 5:35:58 PM

isamuelson said:
Turning off DX10 usually doesn't help. I know with Resident Evil 5 it does because the only reason they have DX10 is to enable the nVidia 3d vision. However, your card is more than capable of rendering DX10 and that's not CPU bound as far as I know.

The main problem is just as jay2tall stated. BC2 is very CPU heavy and as the article he pointed states, it appears to be the physics calculation that is being offloaded to the CPU as they don't see the same issues with an nVidia card. I myself don't know if BC2 uses PhysX or not, but it almost appears that way.

I do know that if you enable PhysX in a game with a non-nVidia card, your framerates will drop (such as in Batman: Arkham Asylum). I don't know if BC2 has a way to turn that off. I don't own the game so I can't help you much more.


BC2 does not use PhysX, but used Physics like all games. PhysX uses a PPU (Physics processing unit) which is found in the Nvidia cards after they bought Ageia. Physics are calculated by the CPU, but I am sure that the Nforce drivers from Nvidia allow their cards to offload some of the Physics to the video cards. Batman: Arkham Asylum was FULL of PhysX enabled things which killed the ATI performance. Your Physics calculations are probably reduced as you turn down the effects of the game. So I'm sure turning the effects down in BC2 will help. However, don't things look so good in that game when they go BOOM!?
m
0
l
March 22, 2010 8:40:07 PM

Quote:
The VPU recovery error is common. It's common with ATI and Nvidia cards. It's common in XP, Vista and Win7. There is no one fix for it. It has been a problem since 2006!

You can spend days reading through various forums about ways people fixed there problem, but likely it wont help you.

Here's just one forum with thousands of people who have the problem. There's also several links on this page to other forums dedicated to this same problem including Nvidia and ATI's website.

http://www.repairyourpcnow.com/resources/atikmdag-has-s...

I've had the problem 3 times myself.

The way I fixed it was:

Uninstall your video drivers (and CCC)
reboot in safe mode (f8) and let windows load it's own graphics drivers
download driversweeper and remove anything ATI or Nvidia or CCC. ( obviously do not remove your chipset drivers if you have a AMD/Nvidia chipset)
reboot and install your graphics driver ONLY from AMD.com
Do not install the package with CCC, only install the graphics driver.
Reboot.

This has fixed it for me all 3 times, but I have talked with several people who still have the error after doing this.

What OS do you have?


I am going to give this a try now. I have XP home 32bit. Will windows load it's own drivers by itself in safe mode?
m
0
l
March 23, 2010 9:41:46 PM

Thanks! I used driver sweeper and cleared all of the old drivers out, it appears that I had a few parts of my old nvidia drivers still there. Everything is working a lot better now i get higher fps and no more VPU errors.

One more question though, I downloaded GPU-Z and it shows that my vid card is always at 100% load when playing BC2 and even after I exit the game it stays at 100% until I restart. Is this normal? or a bug with GPU-Z?
m
0
l
March 23, 2010 10:58:12 PM

Do you have refresh screen selected in GPUz?
m
0
l
March 23, 2010 11:02:56 PM

SpinachEater said:
Do you have refresh screen selected in GPUz?


Yes I do.
m
0
l
March 23, 2010 11:09:55 PM

If you open CCC does it also say your load is 100%?
m
0
l
March 23, 2010 11:22:54 PM

SpinachEater said:
If you open CCC does it also say your load is 100%?


I don't have CCC because it was causing some of the problems.
m
0
l
!