Sign in with
Sign up | Sign in
Your question

| Mass effect Frame stutter

Last response: in Video Games
Share
March 23, 2010 10:28:13 AM

Hi
I´m running mass effect 1 with this system:
Amd pehnom II 3.4 GHZ
DDR 3 ripjaws 1333MHZ CL6
Ati Radeon HD 5770 1 GB DDR5
Windows 7 ultimate x64
All settings maxed out @ 1440x900
I have the lateste catalyst drivers and game patches.

Even though my hardware exceeds the requirements and i run the game @ 62 frames per second i get extremely annoying frame stutters that hamper immensly hte performance of this game..
What can i do to stop this?
March 23, 2010 10:55:20 AM

How much memory do you have? You give the memory type but not the amount of memory.

Have you defragged your hard drive lately? Also, do you have a lot of services running? What about the Windows Indexing service?

One of the things you could try is downloading the AMD Fusion program. This program allows you to optimize your PC right before you play a game. What it does is shuts down unnecessary services. When you're done, just exit out of the program and it starts all of them back up. You could try using this to see if shutting down all the services helps.

You can get AMD Fusion at http://game.amd.com/us-en/drivers_fusion.aspx?p=1.
March 24, 2010 9:55:01 AM

Quote:
How much memory do you have?

4 GB
Quote:
Have you defragged your hard drive lately? Also, do you have a lot of services running? What about the Windows Indexing service?

I installed my OS 2 , 3 days ago so i haven´t defragged , i usually close everything when i game , i don´t have widnows indexing service
Related resources
March 24, 2010 8:24:10 PM

Try different combinations of vsync, anti aliasing and triple buffering, on and off, by forcing them with the Catalsty Control Center and the options menu of the game.
March 25, 2010 12:57:19 PM

Quote:
Try different combinations of vsync, anti aliasing and triple buffering, on and off, by forcing them with the Catalsty Control Center and the options menu of the game.

i usually disable AA and play at balanced settings in the catalyst when i play ME
This game doens´t have AA or Vsync and i sually disable/ put them at low levels when i play this game
I tried to use my old copy of XP (32 bits) to play the game but the frame stutter persisted
March 25, 2010 1:09:41 PM

There is definitely something wrong somewhere. With my 5750, Mass Effect 1 runs smoothly at 1280x1024 with the highest details, but you are definitely running at a higher resolution than I am. I can't go any higher with mine because of my LCD monitor. Have you tried player it at a lower resolution to see if that fixes it? I know it probably won't look as great, but that would possibly be a way to decide if the 1440x900 is too much.
November 24, 2011 5:12:27 AM

I got my MASS EFFECT on a STEAM Sale and the stuttering was so bad the BIOWARE logo wouldnt even load. Upon further research - this is what I ended up doing. Right on Mass Effect in the Library tab and uncheck the Box that says STEAM IN-GAME COMMUNITY. Run Game booster. close all unneccessary applications. i disabled Ad-Aware. and boom! Works for me. Try it
!