Sign in with
Sign up | Sign in
Your question

KOTOR LAGGY

Last response: in Video Games
Share
Anonymous
April 8, 2010 9:22:52 AM

soo i just pulled kotor out of my dusty closet ehehe spring cleaning :cry: 
any way i installed it and started playing then i went WTF LAGG no matter what my settings are it lags
System specs

ATI 57701gb
Intel i3 530 2.93ghz
4gb DDrr3 ram
100gb free harddrive space
Windows 7 64bit

so like wtf i have a more or less overkill computer for this game i should have NO problem with fps
cause seriosly if i can play crysis on very high 2x AA enabled with an avg of 39fps I SHOULD HAVE NO PROBLEM
PLAYING THIS! im thinking just bad optimization kinda like *ehem* assassins creed 1 lolz

Soo any suggestions? :sweat: 

More about : kotor laggy

April 8, 2010 9:50:26 AM

find the correct GPU-drivers
most drivers are specially made for the current games and neglect the older ones.
April 8, 2010 12:06:41 PM

Strange. I have KOTOR and it runs just fine on my machine with the latest ATI drivers. I'm running a 5750 and a Phenom II 720 BE.

Have you installed the latest sound and graphics drivers? Have you tried uninstalling and reinstalling the game to make sure it wasn't a botched install? Also, try defragging your hard drives as well.
Related resources
April 8, 2010 1:49:17 PM

It is because tech has moved along. Is it constant lagging, or just a periodic freeze? Try older drivers (like 9.12). Make sure nothing is forced in CCC.
April 9, 2010 8:26:46 PM

Kotor has been a strange game graphically to me. Sometimes updating drivers/graphics card causes improved preformance, sometimes things get worse.

Last time i tried to play after upgrading my graphics card, I had to disable movies or it locked up every time a movie tried to play.

I finally just quit, as I had already finished the game a few times. Kind of buggy, but a one of my favorite games ever.
May 30, 2011 4:28:51 AM

OK, here's a solution not as much for the original poster but for the ones who googled their queries (Like myself) and ended up here. I have a beastly system, so running this is no problem, if you want to stop the lag try disabling "Force software sound" Ironically it's usually sound issues that produce lag, not not necessarily video drivers! Hope this helps!
May 30, 2011 9:34:37 AM

TakezoDunmer2005 said:
OK, here's a solution not as much for the original poster but for the ones who googled their queries (Like myself) and ended up here. I have a beastly system, so running this is no problem, if you want to stop the lag try disabling "Force software sound" Ironically it's usually sound issues that produce lag, not not necessarily video drivers! Hope this helps!

Yep that's what I did on my old vista PC, worked like a charm. However, for Win7 that didn't work for me :( 
May 30, 2011 10:34:34 AM

As Far as i know Kotor Doesn't Like Duel Core's you may want to test just running on a single core.

If you don't know how to do this open up Kotor, go to your task manger, and set affinty to CPU00 or CPU01
!