Sign in with
Sign up | Sign in
Your question

Crysis stuttering on ATI 5970

Last response: in Video Games
Share
April 9, 2010 5:21:12 PM

this is the sole reason why i signed up here. because of crysis. it's been days now and i still haven't found a solution. my problem is that crysis stutters on my system no matter what settings i use. i have read dozens of forums and searched tons of times for a solution. ive tried everything, from reformatting my system and installing fresh new drivers. i tried solutions that were posted in the internet ie: disabling all monitoring apps because they mess up crysis or something like that. the thing is, none of them worked. i can play all games fine like dirt 2, batman arkham asylum, mass effect 2, nfs shift. but i always have to switch to windows classic mode theme before doing so because the fps drops really low when i dont do so. my system is windows 7 ultimate 64 bit. core i7 930, rampage II extreme, 2gbx3 gskill tri channel 1600mhz, HIS ATI 5970 overclocked to 900/1300(did this to see if it'll help remove the stuttering in crysis since the stock setting didn't, but it also did not fix the stuttering) ati official 10.3 drivers, corsair hx850. i play crysis on all settings very high with AA set to 8x. i get about 40-60 fps. i have tried every setting possible, high settings no aa, changed the ccc settings to blah blah but nothings just seems to work out. please help. i hope i get the right answer in this forum. and i only play crysis on 1440x900, all the games actually. still saving funds for a 1980x1200 monitor.
April 9, 2010 7:43:25 PM

Just forget about Crysis it was probably not designed for such hardware.
m
0
l
April 9, 2010 7:56:09 PM

curiously on one part of one level my 8800gtx would pause for 1sec every 5secs or so regardless of qual settings (made it bloody hard), got past this level all went away, its a funny old game
m
0
l
Related resources
April 9, 2010 8:02:01 PM

Yeah it's really weird. Don't worry that game is badly optimized.
m
0
l
April 10, 2010 12:09:45 AM

Since no one has been able to give you any help so far I will try to do so, I can imagine how frustrating that can be cause similar things have happened to me. Let me start by saying I too have a 5970, and a very similar rig as yours.

Have you overclocked your CPU at all? Do you have stock or special cooler for your CPU?

Could be bottlenecked by the GPU being so powerful, I overclocked my i7-920 to 4.1ghz with ease and that's a fairly large OC.

I would suggest to you to pickup a custom config. If you want complete smoothness, try CCC here: http://www.incrysis.com/forums/viewtopic.php?id=18999 .

Your next option would be to live with the relatively low amount of stuttering that I would imagine on your rig. I occasionally get some stuttering and slowdown with a high graphical quality config, but it usually subsides rather quickly.
m
0
l
April 10, 2010 1:15:13 AM

Ok then what your PSU?
m
0
l
April 10, 2010 1:51:13 AM

i stated that above. corsair hx850.
m
0
l
April 10, 2010 1:52:59 AM

Jamrock said:
Since no one has been able to give you any help so far I will try to do so, I can imagine how frustrating that can be cause similar things have happened to me. Let me start by saying I too have a 5970, and a very similar rig as yours.

Have you overclocked your CPU at all? Do you have stock or special cooler for your CPU?

Could be bottlenecked by the GPU being so powerful, I overclocked my i7-920 to 4.1ghz with ease and that's a fairly large OC.

I would suggest to you to pickup a custom config. If you want complete smoothness, try CCC here: http://www.incrysis.com/forums/viewtopic.php?id=18999 .

Your next option would be to live with the relatively low amount of stuttering that I would imagine on your rig. I occasionally get some stuttering and slowdown with a high graphical quality config, but it usually subsides rather quickly.


i haven't the climate here in our country's really hot so yeah. and i haven't bought a cpu cooler yet. but i don't think that will be the reason for the stuttering. i see youtube videos with the same spec as my rig playing crysis flawlessly. that's why im so pissed off.
m
0
l
April 10, 2010 2:43:44 AM

applied the patch you gave me, stuttering on the sky wasn't there anymore, only some minor stuttering in vegetation. but the rest is all good. and the fps dropped to 30-50. is that normal?
m
0
l
April 10, 2010 11:39:07 AM

Do you think you motherboard could be damaged?
You could go ask a computer technician (don't go to the Geek squad they are not good).
m
0
l
April 10, 2010 1:43:12 PM

i dont think it's damaged but i am having some thoughts about it. because of the stuttering issues and slow loading time of windows 7 ultimate 64 bit. compared to before i reformatted it for crysis. it would load about less than one minute. now it load like 3 mins. i switched to another sata port but to no avail it didnt solve it.
m
0
l
April 10, 2010 2:48:51 PM

Maybe it's your HDD if you have another one test that one and see if it works better.
m
0
l
April 10, 2010 3:55:52 PM

I used to play world of warcraft and it would stutter. Later I found out it was my hard drive. So maybe userremoved is right.
m
0
l
April 10, 2010 4:04:25 PM

Just swap different HDD and see what happens.
Say what HDD are you using?
m
0
l
April 11, 2010 5:52:08 PM

i have 2 hard drives. 1 160gb seagate barracuda 7200 rpm and another 500gb seagate barracuda 7200 rpm. the one im currently using is the 500gb one. ill try your suggestions guys. thanks/
m
0
l
!