Sign in with
Sign up | Sign in
Your question

DX10 Issues

Last response: in Video Games
Share
April 24, 2010 7:48:40 AM

Can anyone help me please - I'm on the brink of insanity!

Most of my games: Bad Company 2, Bioshock 2, Metro 2033, Assasins Creed I, etc. Refuse to run in DX10 mode, as soon as I start them up they crash to the desktop. The only way to play these games is to run them in DX9 mode - which is a monumental waste of all the money I've spent on my pc lately. I have the latest drivers, I've downloaded the latest DirectX, I've tried going backwards with drivers and no luck. Ive even tried formatting my pc several times but still no luck..... Can someone please thow me a bone????

Something else to note which may be of interest, BF Bad Company 2 runs after I install new drivers but the second I enable Sli or Restart my PC it will no longer work...

Lastly my spec - PhenomII 965, 2xAsus 512MB 250gts, 4GB's Corsair Dominator Memory, and N750 Motherboard - M4N72-E. I'm running Win 7 64x.

More about : dx10 issues

April 24, 2010 6:25:56 PM

Might not be able to answer your question but.............. what power supply...specifics..... and ...... as per asus..............*Due to AMD CPU limitation, DDR2 1066 is supported by AM3/AM2+ CPU for one DIMM per channel only.
April 25, 2010 10:39:08 AM

I have a Corsair 850HX Power supply.... ok excuse my ignorance but what exactly does that last bit mean for me?

I'd like to add - if it helps in any way -I've noticed that my leading Graphics Card keeps clocking itself down until i make use of a 3d application to which it will clock itself back to standard/OC settings...
Related resources
Can't find your answer ? Ask !
April 26, 2010 9:55:37 AM

Did you look for mother board driver updates and bios updates from ASUS' site ? Older board - newer opsys.

google it.
*Due to AMD CPU limitation, DDR2 1066 is supported by AM3/AM2+ CPU for one DIMM per channel only.

You have the video card drivers downloaded. Disconnect from the net. Do not let windows install drivers... disable that. Go into the device manager and uninstall both cards. Reboot. ......cards will be
found...... both cards installed and sli coupler attached. Re-install drivers. Reboot. Does it work ?
April 26, 2010 10:39:19 AM

........ and, graphics cards will down clock themselves when in 2d.... or at idle.

i see toms still haven't fixed the ability for posters to edit messages..... how many years now ?
April 27, 2010 2:54:37 PM

Well, I have updated my Bios and I have downloaded the latest drivers for my motherboard from Nvidia... And yes sorry I had a mental lapse - I know about its limitations but it deeoesnt apply to me...

So wait, do I have this right????

"Disconnect from net and Disable auto install, uninstall drivers, then turn off and ensure my cards and bridge are connected then boot up and install drivers - reboot and see then??"

Thanks for all the help - i will give it i try and let you know! Sorry for the late reply its been a busy weekend and I'm also in South Africa so there's timezone issues! hehe

Well in windows (2d??) the primary card clocks to much lower settings and the secondary stays on its full clock(3d) settings no matter what.... the primary will change to the 3d clock if i launch a Game.
April 27, 2010 4:04:48 PM

With both cards installed and the sli bridge attached........
.......................................................................................................

I didn't say uninstall the drivers. I said uninstall the cards....... start/right click my computer/ properties/hardware/device manager/.... open up display adapters. Right click on each one and select UNINSTALL. Do not reboot until you uninstalled both cards. Reboot. Windows will find your new hardware ( cards ). After that install the drivers you have downloaded earlier.

Remember to shut off the auto driver install from windows like I said above and unhook from the net so it can't do it also.

After you installed the drivers, reboot. It might take a minute for the system to set itself but something will pop up saying to click here to enable sli. Follow instructions on screen.
May 3, 2010 6:49:05 AM

I tried your solution and unfortunately was unsuccessful... Got any other Ideas?

I spoke to a few of my friends and they reckon that Win 7 64bit might be the problem and that I should try Win7 32bit - should I give it a try or am I wasting my Time?
May 3, 2010 6:51:05 AM

Would like to add - I tried not enabling sli and my DX10 worked, the moment sli was enabled it caused the Games to not run in DX10 again... this was the case with both cards...
May 10, 2010 6:05:59 AM

Hi all,

I just thought I'd share that I found the solution...

I used an external hard drive I have and loaded a fresh copy of windows 7 32bit onto it and now games - of the ones I have tested - run without any hassle.

thanks for all the advice though!
!