Sign in with
Sign up | Sign in
Your question

I need help with BF: Bad Company 2 settings

Last response: in Video Games
Share
April 26, 2010 9:21:23 AM

I was wondering what settings I should be playing BF: Bad Company 2 on:



Here is my system's specs:

Motherboard: Gigabyte G31M-ES2L (rev 2.0)

Processor: Intel Core 2 Quad CPU Q6600 @ 2.40GHz

System memory: 4 GB

Hard drive: WDC WD6400AAKS-00A7B0 ATA Device, 596.17 GB

GPU: Gigabyte ATI HD 5770 Radeon 1 GB DDR5

PSU: Corsair CMP SU 450VX EU (450W)

Monitor: Samsung SyncMaster T220 Max res: 1680 X 1050

OS: Vistas Home Premium (32 bit) *(SP1)*

Case Type: Micro ATX



I was playing on 1680 X 1050 and medium settings and getting from ~ 45-60 FPS but sometimes (*a lot recently*), when I get into into an area with a lot of action going on (explosions, shooting, smoke, zooming in through the gun sight etc...) the FPS dips, anywhere from 11-30 FPS and then goes back to normal.

At 1280 X 1024 I was getting almost the same FPS (~ 45-60) and having the same problem.

Do I need to turn off AA or AF completely? change the resolution? etc...

Thank you for your help

More about : bad company settings

April 26, 2010 10:08:35 AM

faune said:
I was wondering what settings I should be playing BF: Bad Company 2 on:



Here is my system's specs:

Motherboard: Gigabyte G31M-ES2L (rev 2.0)

Processor: Intel Core 2 Quad CPU Q6600 @ 2.40GHz

System memory: 4 GB

Hard drive: WDC WD6400AAKS-00A7B0 ATA Device, 596.17 GB

GPU: Gigabyte ATI HD 5770 Radeon 1 GB DDR5

PSU: Corsair CMP SU 450VX EU (450W)

Monitor: Samsung SyncMaster T220 Max res: 1680 X 1050

OS: Vistas Home Premium (32 bit)

Case Type: Micro ATX



I was playing on 1680 X 1050 and medium settings and getting from ~ 45-60 FPS but sometimes , not always, when I get into into an area with a lot of action going on (explosions, shooting, smoke, zooming in through the gun sight etc...) the FPS dips, anywhere from 11-30 FPS and then goes back to normal.

At 1280 X 1024 I was getting almost the same FPS (~ 45-60) and having the same problem.

Do I need to turn off AA or AF completely? change the resolution? etc...

Thank you for your help


Havent played the game myself, but generally you will notice a big performance boost from disabling the AA. This chews up a lot of frame buffer. You could try overclocking your CPU aswell, that would give you a boost :) 
April 26, 2010 12:05:31 PM

RickyT23 said:
Havent played the game myself, but generally you will notice a big performance boost from disabling the AA. This chews up a lot of frame buffer. You could try overclocking your CPU aswell, that would give you a boost :) 



I am not sure how to disable the AA there is no "off" there is only 1X. As for overclocking I am not so familiar with it and don't want to mess up my computer.

Thanks for your reply.
Related resources
April 26, 2010 12:52:26 PM

There are a couple of bad company 2 tools for doing the configuration in more detail than you can in game. Try a search for "bad company 2 configuration tool" and optionally "liseda" who I think wrote one of them. They allow you to tweak lots of individual settings. I would suggest you start with AA and filtering both on minimum. HBAO and bloom to off, vsync to off, and everything else at medium and see how you go from there, maybe set textures to high. You could also look at setting your DX version to 9 rather than auto as I think BC2 is one of the games that runs better in DX9. I run a blend of low to medium settings and never go below high 30 FPS. Overclocking the Q6600 did help a bit though as this game seems quite CPU hungry.
April 26, 2010 11:31:36 PM

OllieUK said:
There are a couple of bad company 2 tools for doing the configuration in more detail than you can in game. Try a search for "bad company 2 configuration tool" and optionally "liseda" who I think wrote one of them. They allow you to tweak lots of individual settings. I would suggest you start with AA and filtering both on minimum. HBAO and bloom to off, vsync to off, and everything else at medium and see how you go from there, maybe set textures to high. You could also look at setting your DX version to 9 rather than auto as I think BC2 is one of the games that runs better in DX9. I run a blend of low to medium settings and never go below high 30 FPS. Overclocking the Q6600 did help a bit though as this game seems quite CPU hungry.



I will try to look for the config tool. As I have said I am not familiar with over clocking :(  (yes I know what it is but I do not know how much power I will need, cooling the system ect...)

I actually installed Vista SP2 and it seems that Bad Company 2 is less laggy in terms of its graphics.

Thank you for your reply and if you have any more suggestions for me... by all means.
!