Sign in with
Sign up | Sign in
Your question
Solved

Left4Dead 2: The Passing

Last response: in Video Games
Share
May 3, 2010 1:31:02 PM

Hi,

So recently, Steam updated L4D2 and downloaded the new campaign 'The Passing'. When I start the campaign, the usual splash screen comes up where the game is loading. However, when the progress bar fills up, the game crashes to the desktop with an error message 'Engine Failure'....something to the effect that some AI isn't precached.

I tried checking the integrity of cached files and there's always the same report.....'couldn't verify i file(s) File(s) will be reacquired'

Then Steam starts updating L4D2. But the error keeps coming. I can run all the other campaigns, but not the passing, either online or single player.

As usual, turned to Tom's for help! :) 

Cheers'...

More about : left4dead passing

Best solution

May 4, 2010 12:06:52 PM
Share

I would go into Steam and right click on the L4D2 entry in your library and tell it to delete the local content. This will remove the game from your hard drive. Then, right click on the L4D2 entry again and tell it to install the game.

It sounds like something is corrupted and maybe a clean install of the application will help.

If you really don't want to delete it completely, you can rename the directory it is in to something else and then reinstall the game.
May 5, 2010 8:32:03 AM

Thought as much! I also considered reinstalling the game but was apprehensive that I'd lose the progress, etc. Just thinking: doesn't Steam Cloud take care of the problem? I believe that all your personal settings are saved on Steam Cloud. So if I were to reinstall, wouldn't my previous settings be restored?

Thanks again...
Related resources
May 5, 2010 11:48:43 AM

If you set up L4D2 to use the steam cloud, then yes you will be okay. I can't be sure, but I THINK that your save games are saved in your profile directory, not in the game directory, so removing the game from Steam shouldn't delete your save games. But, definitely, you were using Steam Cloud, then you're safe.
May 5, 2010 1:46:44 PM

Hmmmm. Guess there's only one way to find out. :)  Will be trying at tonight.

Again, cheers' for the help.....will post the outcome soon!
May 5, 2010 2:03:53 PM

Good luck. Hopefully that helps.
May 7, 2010 10:54:32 AM

Ok, so I deleted the local content, reinstalled/ re-downloaded the game and guess what....IT STILL DOESN'T WORK! :(  However, I'm now able to JOIN an online campaign. Although sometimes I get disconnected with an error 'could not authenticate user with Steam'. So basically, I can JOIN games (the passing) but NOT HOST them or even play it in single player.

Really dunno why this is happening. All my games are original, etc.
May 7, 2010 11:32:05 AM

What are your system specs?
May 7, 2010 11:54:35 AM

My specs are:

Intel G41 Mobo
Core2Quad @ 2.33
4 GB DDR2-SDRAM
MSI GTS250 Twin Frozr 1GB
Windows Vista Ultimate 32bit
Seagate 500 gb hdd
Cooler Master 500W Real Power PSU
May 7, 2010 12:11:43 PM

Well, the only other thing I can think of is uninstalling Steam altogether which will delete all your installed games that are under Steam. Then, reinstall Steam and see if that helps because I'm at a loss.
May 7, 2010 12:17:50 PM

This calls for some serious reconsideration! Deleting Steam and re-downloading ALL the games will be a right pain in the butt! :( 
You never know though.....one might just decide to uninstall out of sheer frusto!
Thanks for the help buddy...if I get some results, will def. post them! :) 
May 7, 2010 12:20:45 PM

Best answer selected by namelessonez.
Anonymous
June 13, 2010 7:01:50 AM

I have the same exact issue with passing on my computer too. Seems like a big hassle to re-install them game especially with all the custom skins, sounds and campaigns I have. Wonder why the campaign can't be found for seperate downlaod anywhere.
Anonymous
June 13, 2010 7:11:33 AM

Oh- PS, I did all the things like updating L4D2, re-installing add on support tool(have another issue when trying to run custom campaigns that tells me there are two errors that can't be fixed.) All this began after I installed The Passing and played it one time. The errors say things like 'Biker.mdl not cached and will be reinstalled'. I also get an error when runing custom campaigns in the add on window saying 'Please do not play add on campaigns until Left4dead2 has fully installed', however when I try and check to see if the game is in need of update it simply tells me the game is fully updated and ready to play. I am geussing this is an issue a lot of people are having and I am geussing it has something to do with steam adding a new campaign into the L4D main campaigns directory.
!