Sign in with
Sign up | Sign in
Your question
Closed

Assassin's Creed 2 (PC) continuous drops in FPS (slows down)

Last response: in Video Games
Share
May 5, 2010 12:56:10 PM

Hi There

I am having an issue with Assassin's Creed 2 for PC. My FPS runs between 40 and mostly 60 FPS. At intervals AC2's FPS drops to 15 FPS or even as low as 5FPS.

It is worth to note that I do NOT have ANY problem with any other game on my PC - In actual fact ALL other games run great at maxed out settings. Generally my PC is great with games.


What I have tried the following to rectify the issue:

1.) I have ensured to update AC2 to patch version 1.01
2.) I have installed the latest ATI driver - 10.4
3.) I have installed the latest Audio & Chipset drivers
4.) I have installed the latest DirectX Runtimes
5.) I have re-installed the game
6.) I have changed (reduced) all settings in the game - resolution, quality on various textures, vsync, AA settings, AF settings. None of these have made a major impact on the performance

My PC spec:

* Intel Core 2 Quad CPU clocked to 3.5GHz
* Asus Rampage Formula motherboard (ROG series)
* Kingston HyperX 4GB RAM (2X 2GB)
* Windows 7 PRO (32bit)
* Seagate 1TB SATA2, 7200 RPM
* Asus ATI Radeon 5870 1GB

Has anyone experienced any similar issues with AC2 for PC? Can anyone please help or advise me on the issue I have? Thanks so much!
May 5, 2010 3:37:28 PM

I`m experiencing the same problems, i can run almost every game on maxed out settings and else i have to lower them a bit but with this game its just failing big time, it doesnt even matter if i have max settings or lowest settings i just keep having these weird fps drops.. its running 35-45 fps most of the time on max settings but when i start running and look arround the fps could even drop to 22 :S.. also the castle of your uncle "mario" when i look at it from a distance i just get fps drops like hell xD

Specs:
AMD Athlon II X4 620 (Clocked to 3,05 Ghz)
3GB Ram
ATI Radeon 5770 1GB GDDR5
SATA Raptor (250gb)
May 5, 2010 9:24:27 PM

HI GUYS I ALSO AM DISAPPOINTED WITH THIS GAME, AC1 WAS MUCH BETTER IN PERFORMANCE AND THE GRAPHICS LOOK SIMILIAR IN BOTH AC1 AND AC2 SO WHY IS THIS AC2 NOT PERFORMING SIMILIAR.

DO YOU GUYS THINKS THAT AC2 HAS BETTER GRAPHICS OR SOMETHING.
Related resources
May 6, 2010 5:52:05 AM

I personally think that everyone is so console crazy (game developers & end-users), that it results in games being primarily developed for the console platform and a rushed ported version to PC is the outcome for us PC gamers.

Typical examples include:

1.) Gears of War for PC (still cant get the game to work properly after more than 3 years of its release on PC)
2.) Batman - Arkham Asylum (extremely buggy - a lot of people still can't complete the game even though its been released last year already)
3.) Assassin's Creed 2 (well we all know about this one!)
4.) and the list goes on...

I hate this!

I don't mind if things aren't rosy and perfect at date of launch or on 1st version, but hell, please, we need some of the major bugs fixed in the patches to follow (which we all know doesn't really happen)

screw consoles
May 6, 2010 7:42:23 AM

Maybe the slowdowns are related to the constant online server connection. This is the price you pay for buying legal copy of the game...
May 6, 2010 7:58:03 AM

FunSurfer said:
Maybe the slowdowns are related to the constant online server connection. This is the price you pay for buying legal copy of the game...



if thats the case then then i honestly give up. we dont live in 1st world countries with 8meg+ uncapped unshaped lines at next to nothing prices.

here we get ripped off for everything - including internet
May 6, 2010 11:17:22 AM

mm, maybe someone can look into this, i`m having slightly the same problems with the new splinter cell.. high or low graphics dont make any difference in the frame rate :(  (it runs good but not mm perfect, sometimes 25 fps) and its also from ubisoft like ac2, is it ubi that just cant
make a game run properly on a pc ? xD
May 7, 2010 9:42:23 AM

I tried a couple of things where it was suggested to disable some CPU cores (coz i have a quad core), playing with AC2's EXE priority. disconnecting my flash card reader, tried using an XBOX 360 controller etc. Nothing works!
May 7, 2010 1:05:52 PM

Would be weird if the game doesnt have multicore compatibility.
Also ive checked the usage of my processor/ram/gfx on my 2nd screen
while playing and they all stay under 60% total usage :S
That would mean that none of the parts are to slow.
And it also means i have no frkn clue whats causing these fps drops xD
May 7, 2010 2:09:04 PM

I had no issues with Batman. I finished the game without a single crash. I still need to go back and find all of the Riddler's stuff, but it's never crashed on me.
May 10, 2010 5:57:05 AM

I have an update:

Somehow I got AC2 to function normally now. I don't see how my "possible solution" is at all related to AC2 but hey, maybe just give it a bash:

When I was fiddling with AC2's .EXE with the affinity (disabling cores etc) and priority settings via task manager, I ended up screwing up the game. Even if I put everything back to the way that it was it still did not function at all.

I then (out of the blue) decided to flash my motherboard's BIOS to the latest version - which thankfully did work without bricking my board. Thereafter I decided to uninstall the game while ensuring to remove all savegames & profiles.

I then reinstalled the game. Then first applied patch 1.01, then only started a new game under a new profile. Game seems as smooth as a baby's bottom now.

Sow from what I can gather there might be two possible solutions:

1.) Flash your mobo's BIOS (I can't see how this is related ?!?!?)
2.) Remove the game completely including savegames & profiles. Then apply patch 1.01 1st, before attempting to run AC2 on a new game & profile

I do need to point out that initially I ran version 1.00 of the game and experienced lag issues on FPS. I tried to aplly patch 1.01 after I already stared a game & profile. It might be that the patch 1.01 does fix performance issue on a "clean" profile.

I don't know... give it a try and it might just help you.

Please keep me posted as i would really like to know if this helped anyone. Thanks.
May 10, 2010 8:37:01 PM

whiplash1212 said:
mm, maybe someone can look into this, i`m having slightly the same problems with the new splinter cell.. high or low graphics dont make any difference in the frame rate :(  (it runs good but not mm perfect, sometimes 25 fps) and its also from ubisoft like ac2, is it ubi that just cant
make a game run properly on a pc ? xD



yeh i think most of the new games have issues with framerates
likes AC2, THEN JUST CAUSE 2 AND ALSO BATTLEFIELD BADCOMPANY 2 AND AS YOU TOLD SPLINTER CELL
bad company 2 also becoming bottlenecked by cpu
so i guess theres something wrong here.

May 17, 2010 2:04:14 PM

Weird thing is that Just Cause 2 & Bad Company 2 are working perfect only assasins creed is having weird fps drops to 25-22 sometimes and splinter cell has the same.
But i`l just live with it.
Anonymous
January 31, 2011 6:06:17 PM

Hey guys, I have tried ac2,bad comp 2, and splinter cell convinction,and started wondering,whats wrong with my rig ?? I ran battlefield bad comp 2 kinda smoothly at 25 fps on medium-high graphics,and im seriously looooosing it ! :pt1cable: 
Does ac2 require more graphics than battlefield ?! cuz ac2 doesnt run smoothly at all,maybe playable but not smooth =/
March 19, 2011 1:58:57 AM

I just posted this to neoseeker but it might help you here too:

Problem: So I'm currently running Win7 x64 on a laptop (Acer Aspire 6920) and I have a very modest video card (NVIDIA 9500M GS) that I need to overclock to run the game. Anyway what typically happens for me, and other users, is that I start up the game and for the first minute or two everything is fine and dandy, then all of a sudden my framerate cuts in half or worse and I find myself struggling to even play 800x600 on the lowest settings.

The fix: I was chugging along at 10fps or so when I had to get up to do something and closed the lid to my laptop which put it into sleep mode. Normally my laptop doesn't sleep but I changed my power policy recently. When I opened it back up I got that few minutes of speedy game back and then lag again. So I tried it again, same thing. I did it a few more times and once did it while I was on a transition screen where the game was loading another scenario and *bam* my fps are staying at roughly 25-30 (eyeball judgment) which for me is more than playable.

My guess would be that this solved some sort of memory leak or similar issue and I would suggest that anyone who is experiencing slow-downs should try this out. Even if you're on a desktop you can probably hotkey the sleep function or just alt-tab to your desktop. Quite frankly this is the strangest solution I have ever seen to any game or computer problem I've ever had. I currently run the game in 1280x720 and it's much smoother than 800x600, graphic settings are still set low of course.
March 19, 2011 1:28:20 PM

This topic has been closed by Mousemonkey
!