Sign in with
Sign up | Sign in
Your question

MAC cloning weirdness (WRT54G)

Last response: in Wireless Networking
Share
October 13, 2004 2:03:52 AM

Archived from groups: alt.internet.wireless (More info?)

I downloaded and installed the latest firmware revision from Linksys for the
WRT54G. The good part is that we have noticed much less signal
fluctuation, and even the more distant clients hold the connection with a
weaker signal.

The weird part is that MAC address cloning is now "Enabled" by default (not
"Disabled" as it used to be under the old firmware), and the address showing
up in the field is *not* my PC's MAC, nor one from any of the other
connected machines.

Suspecting a security breach, I reset MAC cloning to "Disabled," but then
the client systems could connect to the router OK but could not access the
Internet. I had to enable MAC cloning again.

Any idea what's going on here?
Anonymous
October 13, 2004 4:58:54 AM

Archived from groups: alt.internet.wireless (More info?)

"Hackworth" <NoSpam4Me@spamless.net> wrote in message
news:5uSdnRi-ZNaYEPHcRVn-vQ@comcast.com...
> I downloaded and installed the latest firmware revision from Linksys for
the
> WRT54G. The good part is that we have noticed much less signal
> fluctuation, and even the more distant clients hold the connection with a
> weaker signal.
>
> The weird part is that MAC address cloning is now "Enabled" by default
(not
> "Disabled" as it used to be under the old firmware), and the address
showing
> up in the field is *not* my PC's MAC, nor one from any of the other
> connected machines.
>
> Suspecting a security breach, I reset MAC cloning to "Disabled," but then
> the client systems could connect to the router OK but could not access the
> Internet. I had to enable MAC cloning again.
>
> Any idea what's going on here?
>
>
>
>
>
if you are talking v2.04.4 the mac cloning should be disabled. click on
"more" in the mac address clone section of status. there is a default number
darkened out when it is disabled--you probably inadvertently clicked enable
and you're now seeing this mac address that is just the one linksys put in
to fill in the field. as far as your machines not accessing the internet,
recheck your settings in the basic setup field--you may have to adjust mtu.
there has been a noted problem with the latest firmware using auto mtu and
pppoe. try manual and 1450 size.
October 14, 2004 3:48:35 AM

Archived from groups: alt.internet.wireless (More info?)

"Bob Schmidt" <Smitty@telecom.SPAMNET> wrote in message
news:kC2bd.37$XE3.60445@news20.bellglobal.com...
>
> "Hackworth" <NoSpam4Me@spamless.net> wrote in message
> news:5uSdnRi-ZNaYEPHcRVn-vQ@comcast.com...
>> I downloaded and installed the latest firmware revision from Linksys for
> the
>> WRT54G. The good part is that we have noticed much less signal
>> fluctuation, and even the more distant clients hold the connection with a
>> weaker signal.
>>
>> The weird part is that MAC address cloning is now "Enabled" by default
> (not
>> "Disabled" as it used to be under the old firmware), and the address
> showing
>> up in the field is *not* my PC's MAC, nor one from any of the other
>> connected machines.
>>
>> Suspecting a security breach, I reset MAC cloning to "Disabled," but then
>> the client systems could connect to the router OK but could not access
>> the
>> Internet. I had to enable MAC cloning again.
>>
>> Any idea what's going on here?
>>
>>
>>
>>
>>
> if you are talking v2.04.4 the mac cloning should be disabled. click on
> "more" in the mac address clone section of status. there is a default
> number
> darkened out when it is disabled--you probably inadvertently clicked
> enable
> and you're now seeing this mac address that is just the one linksys put in
> to fill in the field. as far as your machines not accessing the internet,
> recheck your settings in the basic setup field--you may have to adjust
> mtu.
> there has been a noted problem with the latest firmware using auto mtu
> and
> pppoe. try manual and 1450 size.

Bob, many thanks for your reply, but Manual and 1450 didn't help. If MAC
address cloning is not set to "Enabled," none of the client machines can
access the Web, mail, or news servers. The machines can connect to the AP,
but not the Internet. It does indeed appear that the MAC address in the
field is just something that Linksys filled in but, regardless, I still have
to set it to "Enabled." I tried "repairing" the connection, rebooting,
etc., but nothing else works.

BTW, the firmware revision in question is v2.04.4 as you had suspected.
Related resources
Can't find your answer ? Ask !
Anonymous
October 14, 2004 4:11:18 AM

Archived from groups: alt.internet.wireless (More info?)

"Hackworth" <NoSpam4Me@spamless.net> wrote in message
news:me2dnVVpmsqSavDcRVn-qg@comcast.com...
>
> "Bob Schmidt" <Smitty@telecom.SPAMNET> wrote in message
> news:kC2bd.37$XE3.60445@news20.bellglobal.com...
> >
> > "Hackworth" <NoSpam4Me@spamless.net> wrote in message
> > news:5uSdnRi-ZNaYEPHcRVn-vQ@comcast.com...
> >> I downloaded and installed the latest firmware revision from Linksys
for
> > the
> >> WRT54G. The good part is that we have noticed much less signal
> >> fluctuation, and even the more distant clients hold the connection with
a
> >> weaker signal.
> >>
> >> The weird part is that MAC address cloning is now "Enabled" by default
> > (not
> >> "Disabled" as it used to be under the old firmware), and the address
> > showing
> >> up in the field is *not* my PC's MAC, nor one from any of the other
> >> connected machines.
> >>
> >> Suspecting a security breach, I reset MAC cloning to "Disabled," but
then
> >> the client systems could connect to the router OK but could not access
> >> the
> >> Internet. I had to enable MAC cloning again.
> >>
> >> Any idea what's going on here?
> >>
> >>
> >>
> >>
> >>
> > if you are talking v2.04.4 the mac cloning should be disabled. click on
> > "more" in the mac address clone section of status. there is a default
> > number
> > darkened out when it is disabled--you probably inadvertently clicked
> > enable
> > and you're now seeing this mac address that is just the one linksys put
in
> > to fill in the field. as far as your machines not accessing the
internet,
> > recheck your settings in the basic setup field--you may have to adjust
> > mtu.
> > there has been a noted problem with the latest firmware using auto mtu
> > and
> > pppoe. try manual and 1450 size.
>
> Bob, many thanks for your reply, but Manual and 1450 didn't help. If MAC
> address cloning is not set to "Enabled," none of the client machines can
> access the Web, mail, or news servers. The machines can connect to the AP,
> but not the Internet. It does indeed appear that the MAC address in the
> field is just something that Linksys filled in but, regardless, I still
have
> to set it to "Enabled." I tried "repairing" the connection, rebooting,
> etc., but nothing else works.
>
> BTW, the firmware revision in question is v2.04.4 as you had suspected.
>
>
>
>
>
>
>
>
>
Hmmm...that is very odd. I would probably reset the router to defaults (the
little button thing on the back), turn all security off (including MAC
filtering of course) on the router, set clients to default, enable SSID,
etc. and see what luck you have then. If you can then get a connection with
MAC cloning off, step up gradually to full security and see if it stays
connected. Are you using all Linksys client gear?

I wonder if there is some issue with your ISP (do you have PPPOE?) and this
particular MAC, as it relates to any gear that you have and internet access.
Try to get a list of all of the MAC addresses on everything you have
(including all of the router interfaces--there will some on the router that
the client software will show it is connected to--I think but I'm not sure,
that they're MACs for the antenna or internal wireless interface that your
client is hooked wirelessly to your router through) and see if that clone
address is the same as one of them.

I'm not that familiar with MAC cloning but I have a link here you might find
informative. Maybe you got a bad firmware update--you could try another
update and see if that solves it. Good luck. I'd really be interested to
know how you resolve it so please post your solution whenever you get there.

http://compnetworking.about.com/library/weekly/aa062202...
October 15, 2004 3:37:16 AM

Archived from groups: alt.internet.wireless (More info?)

"Bob Schmidt" <Smitty@telecom.SPAMNET> wrote in message
news:G%mbd.70$XE3.78272@news20.bellglobal.com...
>
> "Hackworth" <NoSpam4Me@spamless.net> wrote in message
> news:me2dnVVpmsqSavDcRVn-qg@comcast.com...
>>
>> "Bob Schmidt" <Smitty@telecom.SPAMNET> wrote in message
>> news:kC2bd.37$XE3.60445@news20.bellglobal.com...
>> >
>> > "Hackworth" <NoSpam4Me@spamless.net> wrote in message
>> > news:5uSdnRi-ZNaYEPHcRVn-vQ@comcast.com...
>> >> I downloaded and installed the latest firmware revision from Linksys
> for
>> > the
>> >> WRT54G. The good part is that we have noticed much less signal
>> >> fluctuation, and even the more distant clients hold the connection
>> >> with
> a
>> >> weaker signal.
>> >>
>> >> The weird part is that MAC address cloning is now "Enabled" by default
>> > (not
>> >> "Disabled" as it used to be under the old firmware), and the address
>> > showing
>> >> up in the field is *not* my PC's MAC, nor one from any of the other
>> >> connected machines.
>> >>
>> >> Suspecting a security breach, I reset MAC cloning to "Disabled," but
> then
>> >> the client systems could connect to the router OK but could not access
>> >> the
>> >> Internet. I had to enable MAC cloning again.
>> >>
>> >> Any idea what's going on here?
>> >>
>> >>
>> >>
>> >>
>> >>
>> > if you are talking v2.04.4 the mac cloning should be disabled. click on
>> > "more" in the mac address clone section of status. there is a default
>> > number
>> > darkened out when it is disabled--you probably inadvertently clicked
>> > enable
>> > and you're now seeing this mac address that is just the one linksys put
> in
>> > to fill in the field. as far as your machines not accessing the
> internet,
>> > recheck your settings in the basic setup field--you may have to adjust
>> > mtu.
>> > there has been a noted problem with the latest firmware using auto mtu
>> > and
>> > pppoe. try manual and 1450 size.
>>
>> Bob, many thanks for your reply, but Manual and 1450 didn't help. If MAC
>> address cloning is not set to "Enabled," none of the client machines can
>> access the Web, mail, or news servers. The machines can connect to the
>> AP,
>> but not the Internet. It does indeed appear that the MAC address in the
>> field is just something that Linksys filled in but, regardless, I still
> have
>> to set it to "Enabled." I tried "repairing" the connection, rebooting,
>> etc., but nothing else works.
>>
>> BTW, the firmware revision in question is v2.04.4 as you had suspected.
>>
>>
>>
>>
>>
>>
>>
>>
>>
> Hmmm...that is very odd. I would probably reset the router to defaults
> (the
> little button thing on the back), turn all security off (including MAC
> filtering of course) on the router, set clients to default, enable SSID,
> etc. and see what luck you have then. If you can then get a connection
> with
> MAC cloning off, step up gradually to full security and see if it stays
> connected. Are you using all Linksys client gear?
>
> I wonder if there is some issue with your ISP (do you have PPPOE?) and
> this
> particular MAC, as it relates to any gear that you have and internet
> access.
> Try to get a list of all of the MAC addresses on everything you have
> (including all of the router interfaces--there will some on the router
> that
> the client software will show it is connected to--I think but I'm not
> sure,
> that they're MACs for the antenna or internal wireless interface that your
> client is hooked wirelessly to your router through) and see if that clone
> address is the same as one of them.
>
> I'm not that familiar with MAC cloning but I have a link here you might
> find
> informative. Maybe you got a bad firmware update--you could try another
> update and see if that solves it. Good luck. I'd really be interested to
> know how you resolve it so please post your solution whenever you get
> there.
>
> http://compnetworking.about.com/library/weekly/aa062202...

It *is* odd, huh? The MAC address showing in the field is not even close to
any on my network (including the router or the cable modem). It could be
just a firmware glitch but, because i'm a geek, it bothers me that I have to
keep MAC cloning set ot "Enabled" just to keep my network up. Perhaps I
should set it to "Disabled," power the modem and router down, wait, then
bring everything back up one at a time. I hope to have some time this
weekend to play with the network, so I'll try again and keep my fingers
crossed.
Anonymous
October 16, 2004 2:23:48 PM

Archived from groups: alt.internet.wireless (More info?)

>
> It *is* odd, huh? The MAC address showing in the field is not even close to
> any on my network (including the router or the cable modem). It could be
> just a firmware glitch but, because i'm a geek, it bothers me that I have to
> keep MAC cloning set ot "Enabled" just to keep my network up. Perhaps I
> should set it to "Disabled," power the modem and router down, wait, then
> bring everything back up one at a time. I hope to have some time this
> weekend to play with the network, so I'll try again and keep my fingers
> crossed.
>

I know some ISP only recognise equipment supplied by them (ie with
certain MAC addresses). That is why some modems support MAC address
cloning. Sounds like your ISP is one of those. Just guessing.
Anonymous
October 19, 2004 3:22:50 AM

Archived from groups: alt.internet.wireless (More info?)

MAC addy for the Lan and a MAC addy for the wireless side.. Are you seeing
the wireless side or LAN side, just a thought




"Hackworth" <NoSpam4Me@spamless.net> wrote in message
news:5uSdnRi-ZNaYEPHcRVn-vQ@comcast.com...
>I downloaded and installed the latest firmware revision from Linksys for
>the WRT54G. The good part is that we have noticed much less signal
>fluctuation, and even the more distant clients hold the connection with a
>weaker signal.
>
> The weird part is that MAC address cloning is now "Enabled" by default
> (not "Disabled" as it used to be under the old firmware), and the address
> showing up in the field is *not* my PC's MAC, nor one from any of the
> other connected machines.
>
> Suspecting a security breach, I reset MAC cloning to "Disabled," but then
> the client systems could connect to the router OK but could not access the
> Internet. I had to enable MAC cloning again.
>
> Any idea what's going on here?
>
>
>
>
>
October 20, 2004 3:22:42 AM

Archived from groups: alt.internet.wireless (More info?)

"David Chong" <davidchong@iinet.net.au> wrote in message
news:41708633$0$25593$5a62ac22@per-qv1-newsreader-01.iinet.net.au...
> >
>> It *is* odd, huh? The MAC address showing in the field is not even close
>> to any on my network (including the router or the cable modem). It could
>> be just a firmware glitch but, because i'm a geek, it bothers me that I
>> have to keep MAC cloning set ot "Enabled" just to keep my network up.
>> Perhaps I should set it to "Disabled," power the modem and router down,
>> wait, then bring everything back up one at a time. I hope to have some
>> time this weekend to play with the network, so I'll try again and keep my
>> fingers crossed.
>>
>
> I know some ISP only recognise equipment supplied by them (ie with certain
> MAC addresses). That is why some modems support MAC address cloning.
> Sounds like your ISP is one of those. Just guessing.

OK, I had time to play over the weekend. I set the MAC address cloning back
to "Disabled," and of course the same thing happened; the client computers
could all connect to the AP just fine, but not to the Internet. So, I
powered the AP and the cable modem down and waited 10 minutes, after which I
brought up the modem, waited a minute or two until it was done initializing,
then I brought up the AP. After that, all the clients connected perfectly,
MAC address cloning was still disabled in the router's setup, and everything
has been working great since then.

I just had a funny feeling that the firmware update I did on the router last
week went way too smoothly! I should have guessed that I'd get at least one
little glitch. Of course, I was remiss for not resetting the network after
the firmware flash... should have done that right away.
!