Sign in with
Sign up | Sign in
Your question

FarCry2

Last response: in Video Games
Share
Anonymous
a b D Laptop
May 22, 2010 3:27:40 PM

Hello, I have two laptops, and for some reason FarCry2 runs much faster and better on a lower quality laptop. One of them has a Windows Experience Index base score of 4.6, the other has a base score of 5.9. Both running FarCry 2 with the exact same settings and resolution, the one with an index score of 4.6 runs it at 29 frames per second, however the one with a score of 5.9 runs it at 14 frames per second. Please help because the second one is a brand new alienware laptop, and im really disappointed :|

More about : farcry2

Anonymous
a b D Laptop
May 22, 2010 3:32:19 PM

Also, the alienware running the game at it's native resolution of 1920 x 1080, with settings on optimal give 5 frames per second which is completely unplayable. It even has the new intel i5 processor and 4GB ram, and a NVIDIA GeForce GT 240M graphics card, i seriously don't know what's wrong? Could it be something to do with the fact i've got Windows 7 64-bit?
May 22, 2010 4:23:45 PM

Do you mean that the game runs at 1920 X 1080 on both laptops?

Update the display drivers on the Alienware. Also do you play when the laptop is plugged in, or running on it's battery? In case of the latter, the laptop might be throttling cpu/gpu performance to prolong battery time. Check the power settings.
Running Win7 64 bit doesn't matter.
Related resources
Anonymous
a b D Laptop
May 22, 2010 4:45:48 PM

Okay thanks, well to even it out, I play it at 1280 x 800 on both laptops, and thats how i got the 29 fps on the slower, and 14fps on the quicker. But the alienware has capabilities of going up to 1920 x 1080, so i tried it and got 5fps which is ridiculous. And well i only got it 2 weeks ago, so i presumed there wouldnt be any new drivers, and i always play/test with both laptops on high performance and plugged in.
May 23, 2010 6:49:45 AM

Still I'd check for new drivers. OEM pc/laptops usually do not have the latest ones.
!