Sign in with
Sign up | Sign in
Your question
Closed

Battlefield Bad Company 2 no servers visible

Last response: in Video Games
Share
July 4, 2010 1:43:54 AM

Hello,

Just installed Bad Company 2 on steam and there are no servers visible... I ticked the filters on the side, played around with different combinations but still nothing. My AV and firewall allows the game....

Any suggestions?

Thanks,

Milo
July 4, 2010 1:54:29 AM

I guess you just updated to the new version, 53... released on 30 of june. After doing the update my game freezes when i click on search for servers.(i cannot play online) I cannot see any servers either games available. It was fixed for a while when I clicked on the reset button, but then the issue came back. Help...
July 4, 2010 1:59:01 AM

Hey I got it fixed with my mate....

Everything on teh filters side has to be unticked only tick the punkbuster (tick or cross)
Related resources
July 4, 2010 2:16:15 AM

Im glad it worked for you, It doesn't for me :( 
July 4, 2010 2:22:11 AM

do u have teh steam version ?
July 4, 2010 2:27:36 AM

no, I have the disc, no problems untill i made the update,now the game freezes. I just tried installing latest punkbuster and nothing...
July 8, 2010 6:44:30 AM

I have the same problem...no servers visible and when I try to join single player it crashes to desktop.
July 8, 2010 10:04:18 AM

I'm just waiting for them to release a fix for it. My game does not crash to desktop, it just hangs.
In that case try to update your drivers.
July 8, 2010 11:48:07 AM

I bought the game on June 30th after the new patch came out, when I search for games on the "play now" screen nothing shows up. The only way for me to find servers is to go the the server browser and search there but EA servers do not show up for some reason.
I went on EA's forum and complained but no one seems to have a possible solution to this problem.
July 8, 2010 6:51:28 PM

The game is f*cked up!!!!!!!!!!!!!!!!!!!!!!!! Wait until patch would be released for this crap
July 8, 2010 10:07:16 PM

k this worked for me:
For server browser: Made sure windows firewall allowed the game through private and public. if that doesn't work do the same w/ punkbuster and exit out of steam(if not a steam game) and nv monitor.

for single player: went through single player> my campaign > select mission > then used the start button on the lower-mid part of the screen. any other way caused it to CTD.
Once again, never had to do or worry about any of this till the last patch..Hope it works for u guys.
Anonymous
July 12, 2010 10:44:15 PM

mspisz said:
Hey I got it fixed with my mate....

Everything on teh filters side has to be unticked only tick the punkbuster (tick or cross)


were did you find the filters
May 21, 2011 11:47:39 AM

mspisz said:
Hey I got it fixed with my mate....

Everything on teh filters side has to be unticked only tick the punkbuster (tick or cross)




Thanks man it works
May 21, 2011 4:45:03 PM

This topic has been closed by Mousemonkey
!