Sign in with
Sign up | Sign in
Your question
Closed

Crysis black screen crash at end of relic mission

Last response: in Video Games
Share
July 5, 2010 6:52:16 AM

crysis black screen crash at end of relic mission,,,,,,,,,,,,, yes the VTOL lands to pick me up and yes i get in it to find myself in a cut-screen sequence leading to the next level.... but Crysis cashes to a black screen every time..... it had done that on other "transitions" between levels and somehow i was always able to eventually get it to load the next level .. not this time...... end of Relic crash has me stumped.. any ideas?............... AMD Phenom II X4 965 3.4 GHz...... 4 GB DDR3 RAM......... ATI Radeon HD 5870........


i just read Spac13's post ..... he said

"ok i'll help you out, the game isn't good enough to be stuck on a level you can't finish due to bugs.

this is not a "cheat" as such but it will work for you.

look at the walkthrough and find out what level is next.

open the benchmark tool that is in the game file.

select the level from the benchmark list and run the benchmark

it will load the level from the start and allow you to play the level.....

this is ANOTHER HUGE problem with the game as it will save the game as if you have reached that level. so once it loads just save it and close the game.

re-start crysis.exe on your desktop and load the save game.

and your sweet.

and lets face it, if crytek can't release a game that actually runs the benchmark without saving it as an actual level you have played then why can't we use it to skip the crap they stuffed up.

happy shooting "


....... so .... ok... i got a list of the levels in Crysis..... but now i have no idea how to "open the benchmark tool" in Crysis..........
any ideas?

Best solution

July 5, 2010 1:28:29 PM

Forget that, if you open the properties of the Crysis shortcut on your desktop and at the end of the TARGET line you put in "-dx9" (eg "c:\program files\Electronic Arts\Crytek\Crysis\Bin32\crysis.exe" -dx9) it'll run the game in DX9 mode. Apparently the game has a billion and 1 bugs when you run it in dx 10 or 11 mode, stick it in dx9 mode and it runs fine. I had the same problem on the last level, crashed and some silly moment when sparks flew in a small explosion, I reckon it had a problem rendering the lighting effects in dx10 but once I stuck it in dx9 mode it was fine, only difference I noted was the effects on the water reflection, other than that the game was the exact same.
Share
July 5, 2010 8:15:52 PM



Thanks to collie147 for providing the answer............. although his solution did not work for the 64 bit version of the game that i play, i was able to apply it to the 32 bit version and then actually get to the next level of the game.............
........... then i saved the game and then i restarted it in 64 bit mode and loaded the saved game............. works great

Score
0
Related resources
July 16, 2010 9:15:24 PM

well, it didn't work at the end of the next mission "Assault"........ i saved the game at the end before the tanks blow a hole into the mine......... but when i load it in x32 mode, the tanks are there but all the men are gone, and i can't get to the next mission........... i tried replaying from farther and farther back in x32 mode....... still can't get to next level.......... i guess i may have to play the entire level over on x32
Score
0
July 10, 2011 3:25:03 PM

This topic has been closed by Mousemonkey
Score
0
July 20, 2011 4:07:08 PM

Best answer selected by SteveMuadDib.
Score
0
!