Sign in with
Sign up | Sign in
Your question

App through Citrix is slow and choppy

Tags:
  • Management
  • Citrix
  • Business Computing
Last response: in Business Computing
Share
February 12, 2013 6:12:58 PM

Sorry if this is in the wrong area...


I work for an IT company that handles onsite support as well as network support for companies all over the world. I am the onsite tech for one of their clients and access my company's ticketing program through Citrix. I just built myself a new system and the app runs real slow and freezes on the new system. I RDP into my old system and it runs flawlessly. Citrix, IE(8), and Java are all the same versions with the same updates on both systems.


The only hardware change was:

OLD System (Dell Optiplex 780) - Intel Core 2 and a Radeon HD graphics card running dual monitors
New System (Dell Optiplex 990) - Intel Core i5 and dual Radeon HD grpahics cards running quad monitors

RAM in both systems is DDR3 4gbs

I'm at a loss at what the issue could be...

More about : app citrix slow choppy

February 12, 2013 7:38:02 PM

New system plugged into the same cable as the old one or both on a router?
February 13, 2013 11:58:51 AM

both are on gig ports... I just switched them and still getting latency. I've also uninstalled my Citrix receiver, deleted the Citrix folder under Program Files, and deleted all Citrix registry entries under local machine and current user.
February 20, 2013 12:25:32 PM

Finally fixed it... had to run the command

"netsh interface tcp set global autotuninglevel=disabled"

Latency was gone immediately
February 20, 2013 1:47:06 PM

Congrats! That's outside my scope :) 
February 28, 2013 7:57:48 PM

Way out of mine too... lol Another team member told me about it.
April 15, 2013 2:44:49 AM

Wow thanks for the advice indyitguy, I applied the settings you suggested and my response through citrix gateway seems to be really smooth on my windows 8 laptop. Thanks a million for the info as I was really frustrated doing remote support over the weekend while on standby:bounce:  You're a star thanks once again will do some further testing tonight

regards tunie777
April 15, 2013 2:44:49 AM

Wow thanks for the advice indyitguy, I applied the settings you suggested and my response through citrix gateway seems to be really smooth on my windows 8 laptop. Thanks a million for the info as I was really frustrated doing remote support over the weekend while on standby:bounce:  You're a star thanks once again will do some further testing tonight

regards tunie777
April 15, 2013 2:44:50 AM

Wow thanks for the advice indyitguy, I applied the settings you suggested and my response through citrix gateway seems to be really smooth on my windows 8 laptop. Thanks a million for the info as I was really frustrated doing remote support over the weekend while on standby:bounce:  You're a star thanks once again will do some further testing tonight

regards tunie777
August 20, 2013 5:31:54 PM

indyitguy said:
Finally fixed it... had to run the command

"netsh interface tcp set global autotuninglevel=disabled"

Latency was gone immediately


Where do I rum this command?
August 23, 2013 1:23:52 PM

rm11 said:
indyitguy said:
Finally fixed it... had to run the command

"netsh interface tcp set global autotuninglevel=disabled"

Latency was gone immediately


Where do I rum this command?


from the command line
XP - Click start, run, type cmd and press enter
Vista/7 - Click Start, type cmd in the search box and press enter
December 12, 2013 8:53:05 AM

indyitguy said:
rm11 said:
indyitguy said:
Finally fixed it... had to run the command

"netsh interface tcp set global autotuninglevel=disabled"

Latency was gone immediately


Where do I rum this command?


from the command line
XP - Click start, run, type cmd and press enter
Vista/7 - Click Start, type cmd in the search box and press enter


on which computer? the one i am remoting from or the remoting to?
December 16, 2013 1:46:16 PM

indyitguy said:

OLD System (Dell Optiplex 780) - Intel Core 2 and a Radeon HD graphics card running dual monitors
New System (Dell Optiplex 990) - Intel Core i5 and dual Radeon HD grpahics cards running quad monitors


Are you really completely good to go now? I have a similar problem with RDP over Citrix from my windows 7 box, which has a Radeon HD 5570 (quad monitor) display adapter. I had previously tried all kinds of tcp tweaks including the one you mentioned with no luck. I even just tried the exact thing you posted for the heck of it, but no change. I have a crappy old laptop with XP on it that works like a champ, yet my beastly i7 is cripplingly slow for RDP over Citrix.

The only way I have been able to get Citrix to run without ridiculous lag on this machine has been to boot into windows in safe mode with networking. This disabled my Radeon drivers and I was just running off generic VGA drivers. I believe the root of this problem has to do with this card/drivers and however Citrix is trying to interface with it.
January 24, 2014 7:55:51 AM

This solution didn't work for me. I have severe lag on my Windows 8 machine. I use Citrix to access our Medical Software that resides in a Database in Chicago. It has something to do with our Antivirus, because when I disable it....it runs smoothly. I've put the Website in the Trusted Sites but still has lag. Still looking.........
January 27, 2014 6:55:56 AM

What antivirus are you using?
January 27, 2014 6:57:39 AM

Trend Micro...........
January 27, 2014 7:06:21 AM

You put the url in the trusted sites within IE settings or your trend micro settings? You could try using a wild card within those lists. i.e. instead of adding citrix.mysite.com add *.mysite.com.

Here is some documentation on Antivirus guidelines from Citrix. Not sure if they'll help or not...
http://support.citrix.com/article/CTX127030
February 2, 2014 11:32:16 PM

The solution described above also didn't work for me. I installed the Citrix Receiver through the Windows Store and noticed that the response was very very slow. When looking in my task manager I saw that the Citrix Receiver would go to almost a 100% CPU utilisation everytime I performed some action on the remote desktop. So that would explain why the response was so very very slow. As a possible solution I installed the Cytrix Receiver by downloading it from the Citrix website (http://receiver.citrix.com/) and use that version of the Citrix Receiver instead of the one that's in the Windows Store. That at least solved the problem for me.
February 3, 2014 8:19:54 AM

Yes, I tried that version of citrix receiver from the Windows Store and that brought me other issues! I'm not using that version. I ended up uninstalling Trend Micro and installing Norton and everything works fine now. All my Windows 8 machines are on Norton.
!