Sign in with
Sign up | Sign in
Your question

HELP me with TelNet

Tags:
  • Connection
  • Telnet
  • Networking
Last response: in Networking
Share
August 7, 2002 8:40:04 PM

I have an horrible problem with microsoft TelNet. Every time i tries to connect it sais "Can't connect to host on port 23, could not connect because main computer active denied it" something like that. I realy need it to work many programs are using it.

I have no firewall or anything like that, the ports are clear.

Please help me!

Boa Was here<P ID="edit"><FONT SIZE=-1><EM>Edited by boa on 08/07/02 04:44 PM.</EM></FONT></P>

More about : telnet

August 7, 2002 8:57:44 PM

You need to set up port forwading on port 23. At the moment, your firewall on your router (NAT setup?) is probably blocking connections on port 23.

Unfortunately, doing this will leave open your port 23 for other to pop in.

<b><font color=blue>~ BIOS SETTINGS: Fast, Hot, Unstable...That ought to work. ~</font color=blue></b> :wink:
August 7, 2002 11:52:07 PM

is this accross a wan or lan?

how do you shoot the devil in the back? what happens if you miss? -verbal
Related resources
August 8, 2002 10:49:38 AM

also, What OS is each machine running?

<i>It's always the one thing you never suspected.</i>
August 8, 2002 7:18:48 PM

it's a lan with internet connection thru a router. I'am not trying to TelNet the other computer...... but one have xp home the other has xp pro... if that makes any difference.

Boa Was here
August 9, 2002 10:42:16 AM

so you're trying to telnet FROM one of your local PC's (the home or pro) TO a machine on the Internet somewhere? If so, what does the config at the remote site look like?

BTW - details like this should really be included in the original post.

<i>It's always the one thing you never suspected.</i>
August 9, 2002 11:04:35 AM

I don't know but it dosen't matter because i can't even TelNet my own router. which i have to do when i update the firmware. Something is very wrong here!

Boa Was here
August 9, 2002 11:33:36 AM

OK, now you're giving more useful details. Have you EVER successfully telnetted to your router? Which model is it? Maybe there's some config setting to enable/disable telnet?

BTW - if you're running any sort of server you can test whether telnet is working by telnetting to the particular port. e.g. if you're running an HTTP server you can type

TELNET XXX.XXX.XXX.XXX 80

And the server will "answer" the telnet. For HTTP you can type "HELO" and you should get a reply. If you're not behind a firewall you can even try this to tomshardware.com like so:

TELNET www.tomshardware.com 80

type HELO and see if you get anything back

<i>It's always the one thing you never suspected.</i>
August 9, 2002 9:27:55 PM

TelNet has never been successfull... I tried to TelNet without the router too, with no success... I know that my internet company allow TelNet, I hate this [-peep-].

Boa Was here
August 10, 2002 1:56:52 AM

what did you try to telnet to without the router?

<i>It's always the one thing you never suspected.</i>
August 10, 2002 11:20:29 PM

I tried several adresses, now i also tried to TelNet Tomshardware when the router was disconnected... with no success!

Boa Was here
August 11, 2002 3:21:08 AM

can you give some more details? Did you try to telnet to tomshardware.com port 80? or default 23? What was the error? Can you possibly cut and paste the session into a reply here?

<i>It's always the one thing you never suspected.</i>
!