Sign in with
Sign up | Sign in
Your question

Find Product Keys on Remote Computers

Last response: in Business Computing
Share
February 13, 2013 11:51:26 AM

So I'm just coming in as a Systems Administrator to a medium sized business or mixed 50/50 windows/linux machines. First job is more so an inventory of machines in the office, and find Product Keys (for our windows machines). I need to find a free/cheap product that will allow me to scan our network and pull product keys for mostly Windows OS and Office Products. I have tried ProduKey by Nirsoft and it only works SOME of the time. I have a list of about 40 or some machines, and I pulled the keys from 5 of them. Other times I get an access denied Error, or "Error 53: Network Path Not Found."

I have tried a few ways of trouble shooting:

1) Comparing wireshark captures from a host I received keys from to a capture of each access denied and Error 53 to find the ports used by the application.

2) Disabling Windows Firewall completely.

3) Enabling the ports used.

Nothing fixes it. Anyone else have a good suggestion/application that I can use to get the job done?

EDIT: Only thing I can think of is more ports to enable, but the only ones I see used are 135, 139, 445 (NetBIOS session)
February 13, 2013 12:45:02 PM

you may need to enable "file and printer sharing" in the firewall on the pc's you can't get to. this can be done through group policy. Belarc Advisor can pull they keys, but i am not sure it will network scan, you may have to touch each machine. Spiceworks can pull keys via the network, but requires more confinguriation to get the ports open.
Related resources
February 13, 2013 1:02:40 PM

@Alvine

I'm not using MS Ops Manager.

@Randini

I have tried to enable all those rules in the Windows Firewall both inbound and outbound. Belarc I looked at and it is expensive to use within a network. Plus the one reason I'm doing this is so I don't have to go to every computer and pull the keys. I haven't taken a look at Spiceworks just yet, but that is next on my list.
February 13, 2013 2:38:45 PM

I have figured out the issue:

On top of the Windows Firewall, there are some local network security settings in secpol.msc and you MUST have Remote Registry services enabled and started.
!