Sign in with
Sign up | Sign in
Your question

Oblivion Poor Performance

Last response: in Video Games
Share
July 21, 2010 5:31:35 PM

Don't have a problem running games like Bad Company 2 at full settings, and even Oblivion's sister game, Fallout 3, runs perfectly with framerates over 80. However, in Oblivion I'm lucky to get 40 fps, and frequently get as low as 15 whenever there are NPC's in the screen.

I've already tweaked the Oblivion.ini file

System
Intel i7 920 @ 2.66 ghz (Not overclocked, though I could do so easily if need be)
6 GB RAM
Radeon 4890 HD
(if you think anything else might be the problem I can give more hardware specs)

Running Windows 7
July 21, 2010 6:05:38 PM

Hmmm, well that would really suck.
But lowering my resolution or any settings makes absolutely no difference in my framerate. Is there anything I could do to improve performance?
m
0
l
July 21, 2010 6:47:33 PM

That's odd, my spec is lower than yours (intel i3 530 with 4 GB RAM GeForce 8800GT) and I play Oblivion with no problems at all (resolution 1980x1200). No tweaks.
How about your drivers?
m
0
l
Related resources
July 21, 2010 7:03:37 PM

Newest Radeon Catalyst Control Centre. Went on the Radeon website just last night to make sure I was updated. I'll try and look for an update i might have missed.
Any drivers except video ones I should look into?
m
0
l
July 21, 2010 7:53:43 PM

Is this a cpu bottleneck perhaps?
I've checked my cpu usage while playing and it never goes higher than may 40%
m
0
l
July 21, 2010 7:57:21 PM

But I have intel i3 and you have i7. I have no problem with this game...
m
0
l
July 21, 2010 8:15:46 PM

Yeah, but one wouldn't expect to get LOWER performance with new hardware.
m
0
l
July 21, 2010 8:40:05 PM

I just did so, and I enabled a setting called "catallyst AI"
Gave me an extra 5 fps actually. Thanks for the tip.
Still concerned why its so low on a pretty good system...
m
0
l
July 21, 2010 9:18:36 PM

Do you have an add in Soundcard or using Onboard --- Try disabling Music in the .ini file and see if the FPS picks up -- if it does look for updated sound drivers and\or tweak the ini settings to lower the maximum # of sounds the game will process (the game really has some issues with the sounds and various Codecs.)
m
0
l
July 21, 2010 10:31:36 PM

Actually, I've noticed something very strange, no matter how many times i change the in game settings they always change themselves to something weird.
For example I tried turning down interior and exterior shadows to 8, played for 15 minutes.
When i went back into the menu, exterior shadows was at 10 and interior was at 2.
This happens with all the sliders.
My specular distance went from 40 to 100, the various Actor fades and such were all at seemingly random numbers as well.
m
0
l
July 21, 2010 11:29:39 PM

i can play this game on absolutely full detail on an 8800gts and a core 2 e6600 with 2xaa on 1650x1050, so you should be able to run it fine. Some people are having issues with quad core cpu's. There is another thread about this where you can disable cores or something.... Also update you oblivion to the latest patch if you havn't already. Also if you dont mind disabling grass, that will help, i had to do that when i was running a 9800xt and single core athlonXP to get smooth gameplay.
m
0
l
July 22, 2010 1:25:57 AM

There is no bottleneck. Your system should run it fine. I played oblivion with a E5200 2.5ghz with GTX260 maxed out with HDR on Bloom Off. Flawless.

Try turning off bloom and turn on HDR if you haven't already. When I did that the game ran a lot smoother.
m
0
l
July 25, 2010 7:36:26 PM

Had already did it, even with every setting on low, all textures down, no HDR or Bloom. Get about 15 fps in the Imperial City. With all settings on high I get the exact same fps.
m
0
l
!