Sign in with
Sign up | Sign in
Your question
Solved

Riddick-Assalt on Dark Athena Win 7 crashes with sound...

Last response: in Video Games
Share
July 25, 2010 9:53:14 PM

I've been desperately trying to get Assault on Dark Athena running on my new machine.

Specs:

Core i5-750 Quad Core
Asus P7P55D Pro
OCZ Gold 8GB PC10666 DDR3
eVGA GeForce GTX 465


The game has been freezing since day one. I've tried installing it on both Win XP Pro 32bit and Win 7 Home Premium. After all my tinkering I've got it running best on the Win 7 machine. At first I thought it was a graphic card issue (which it still might be). I ran across a thread talking about turning down the hardware acceleration for sound in dxdiag. Problem is this option doesn't exist in Win 7, and installing it on WinXP actually makes all these issues worse for some reason. Video settings don't change a thing. The only thing that makes the problem go away temporarily is if I disable my sound card, run the game, exit, enable the sound card, and then play. Sometimes I can get a half hour in before it starts freezing and crashing again. I've tried updating directx, sound card drivers, vid card drivers, and I've tried using both my on board sound and my soundblaster x-fi xtreme audio card. Any help would be appreciated because I'm about ready to give up on this damn game.
July 26, 2010 9:12:34 PM

Is that original or obtained in some different ways? If it's legal, is the version up to date?
Honestly, I'm not very familiar with Nvidia's drivers, but it's possible you have some feature turned on there, whatever it could be, and it might have some issues with the game.
About freezing in general, it could be caused by GPU overheating, but I guess you would have noticed that.

So, does it crash at certain point or is it mostly random?
Is this the only game that's doing this?
m
0
l
July 26, 2010 11:36:07 PM

As far as I know she's patched up to date with the 1.01 patch. I thought about the GPU overheating but it never goes past 75 degrees celcius. Other games run fine. I got Mass Effect maxed out, I just passed Dead Space with the graphics maxed out, Fallout3 with the high def pack maxed out. Like I said, I think its got something to do with the sound because when I disable my sound card, the game runs fine. Its like it seems to freeze when there are a lot of things going on audio wise. For example the beginning of the game with the water crashing on the shore makes it freeze up a lot, or when someone is speaking. But again, for some reason if I disable my sound card, run the game, then exit and enable my sound card, I'm able to play for about a half hour with no issues. And again, the vid card isn't running that hot. Isn't there some way to disable directx hardware acceleration in Windows 7?
m
0
l
Related resources
July 27, 2010 10:50:49 AM

Have you tried changing sound sampling? It's also quite possible, that X-Fi Crytalizer or any other sound effect you might have turned on there does some mess...although nobody else seem to have this issue D: . I'd try uninstalling those Creative drivers (including the control panel) but it could be quite a pain to get them back...oh and I think Riddick runs on OpenGL. You could try setting compatibility with Win.xp or something like that in the exe's properties, but I doubt it would help.
m
0
l
July 27, 2010 4:03:47 PM

Yeah, I've played around with the sound sampling. I also turned off all the effects including X-Fi Crystalizer. That's how I got to the point I'm at now where the game seems to play a bit better. Before I touched any of those options the game would usually freeze before you could even play, like when I was navigating the menu. At least now I'm able to play it somewhat but the glitches and crashes happen often enough to make the game unplayable because I end up having to clear the same area 3 times, sometimes more, just hoping that I'll make it to the next checkpoint before another crash. I haven't tried uninstalling the creative drivers. We'll see what happens there.
m
0
l

Best solution

July 27, 2010 8:21:35 PM

Well, all I can think of now is reinstalling drivers, then game, then system ^.^ . In other words, I'm out of ideas. Hopefully someone else will give an advice.
Share
July 28, 2010 2:36:58 AM

After trying to delete all traces of previous drivers and then installing fresh ones in Windows 7, I realized the only thing left to try is a fresh install of Windows. I got too much work put into my Windows 7 install so I decided to do a fresh format and install of XP Pro. I installed the absolute bare minimum I could think of. Hell, I didn't even put the install CD in for my SB X-Fi and just let windows update take care of it for me. As for my GeForce GTX 465 drivers I went and installed the newest ones straight off of eVGA's website. Having done all that, the game seems to be running better. The glitches and freezes are still there, but no where near as often as when I was playing it on Win 7. And when it does freeze to the point that I can't go on, simply hitting ctrl+esc to get me to the start menu and then clicking on the game again refreshes everything and I pick up right where I left off. A minor inconvenience considering how fun the game is. One thing that just occured to me that I forgot to try was to mess around with the directx sound hardware acceleration options now that I'm running it in XP. I'll give that a go tomorrow and see what happens. Thanks for the help and I'll keep you posted.
m
0
l
July 30, 2010 1:53:18 AM

Okay, finally got the game working no problem. Here's my solution:

-Fresh install of Windows XP Pro 32bit
-Updated to SP3
-Manually installed all necessary auto updates
-let auto update install my SB X-Fi drivers
-installed latest drivers for my GeForce GTX 465 from eVGA's site
-set directx audio hardware acceleration in dxdiag to 'basic acceleration'

All this had the game running pretty good. Although the odd freeze up and sometimes complete crash would occur. I did notice that everytime a crash happened and I'd get kicked back to windows, I'd have some damn notification icon in my quicklaunch tray, usually to do with auto update. So the last thing I did was...

-disable windows auto update

Once I did that, I played the rest of the game straight through to the end without a single hitch. I hope this helps someone else out there with similar issues. Thanks Aoyagi for your advice.
m
0
l
August 12, 2010 2:40:04 PM

Best answer selected by Inseinos.
m
0
l
!