Sign in with
Sign up | Sign in
Your question
Solved

Starcraft 2 issue: Computer reboots when starting missions

Last response: in Video Games
Share
July 28, 2010 2:54:10 PM

I recently bought StarCraft 2 last night and installed it with the great anticipation of playing. After the very long install, I was finally able to install the StarCraft client and log onto Battlenet. However, when I selected a 1 player mission against the AI, the computer will reboot right before the mission loads completely. This happens every time.

System Specs:
Operating System: Windows XP SP3
Direct X Version: 9.0c
Brand/Model: Emachines T3256
Board/Processor: FIC AU31, Athlon XP 3200+ 2.2ghz
Memory: 1.5Gb
Video: Radeon HD 4670 AGP, 1Gb memory
PSU: 460W

I have spent three weeks upgrading my system, bringing it up to speed for Starcraft 2.
The graphics card has been upgraded along with the system memory.

Possible issues:
Here are my thoughts on what might be going wrong.

1. The SC2 installation notified me that my video card driver is old. Here is the issue with that. I have tried to upgrade it but with no success. I first installed the HIS drivers that came with the Catalyst. I then went to the ATI/AMD site and tried to upgrade it to the latest however when I did so the version did not update. Also, it then listed 2 duplicate video cards in the display properties. This was frustrating so I removed all drivers and tried to install from the ATI/AMD site directly but after the install, the computer kept asking me to install a video driver and the screen refresh was very slow.

2. My direct x version. I have 9.0c which is the highest compatible version for windows xp. Although there may be uddates for this, I am not sure.

3. All along, before the game came out, the minimum requirements for the processor were 2.2ghz Pentium 4/AMD Athlon which is what I have. When the game came out the minium requirements were raised to 2.6ghz. That is a problem because I think I have the fastest processor for my board. I don't think however that a .4 ghz variance would make that much of a difference but what do I know.

I realize that I have an old system hence this is why I started upgrading it. I am ok with playing the game on Medium.

If anyone has any comments or suggestions on how this issue can be resolved, it would be greatly appreciated.

Best solution

July 28, 2010 3:19:09 PM

My money is on the video card driver issue. After you uninstall the video drivers, download and run Driver Sweeper to clean out any remaining ATI drivers. Reboot. Then install the latest drivers from ATI's website. Reboot again.

SC2 supports DX9. Should be no issue there.

EDIT: What do your CPU and GPU temps look like? Have you ruled out overheating? Maybe try running Memtest86+ to test the system RAM?
Share
July 28, 2010 3:45:02 PM

Thanks for your comments. I will look into updating the video card drivers tonight.
Where do I get Driver Sweeper and does it cost money?
The Catalyst program has a monitor for the GPU temp which looks good- 50c, but how do I find out what my processor temp is?
m
0
l
Related resources
July 28, 2010 3:59:04 PM

Google Driver Sweeper. I believe it is the first hit on Guru3D.com website.

There are a few utilities to monitor your CPU temps. SpeedFan and HWMonitor are a couple off the top of my head.

Good luck.

EDIT: Be sure to check the temps while the system is sitting at Idle and Under Load.
m
0
l
July 28, 2010 6:52:02 PM

Speaking of temp... what is a good temp at idle and under load?
(also what is bad temp?)
m
0
l
July 28, 2010 9:11:29 PM

sliem said:
Speaking of temp... what is a good temp at idle and under load?
(also what is bad temp?)



Depends on the type of CPU and GPU in question. They may have different thresholds depending on the model.
m
0
l
July 29, 2010 3:31:24 AM

If you have Intel chip and its not overclocked, with a stock fan at around 32-35c. Video card varies on manufacturer specs check the manual for the card. Some video cards can run as high as 100c according to manufacture specs.

Edit: 100c though is NOT the idling temperature. Give an example, 9600 gt by PNY runs idle at 49-51c on 50% fan speed.
m
0
l
July 29, 2010 11:30:08 AM

I uninstalled the drivers that were provided by the HIS manufacturer. I then cleaned the remaining drivers with the Driver Sweeper (great program). Afterwards, I installed all the drivers from the ATI/AMD site. However, these drivers did not even recognize my card. I know that I selected XP on the OS selection page. I reboot after install and there is no change. I do not even see the Catalyst program in the system tray as I did before when I installed the drivers from the disk.

Here is the link to the drivers that I downloaded and installed.

http://support.amd.com/us/gpudownload/windows/Pages/rad...
m
0
l
July 29, 2010 12:58:38 PM

I had the same problem in first cinematic of the first mission. Brand new drivers and a computer that should eat this game for lunch.

Processor Intel(R) Core(TM) i7 CPU X 980 @ 3.33GHz, 3334 Mhz, 6 Core
6 GB of Ram
and 2 xfire linked Radeon 2gb 5970 on new drivers that came out two days ago.

I spent 2 plus hours on the phone with alienware support and he couldn't figure out what was causing it. We ran diagnostics on CPU and GPU temp and nothing stood out.

Even though this computer should be able to run it on ultra settings I turned it all to low, and was able to make it through the cinematic. I moved the graphics quaility up and was able to get through the cinematic on all but ultra setting. Then I turned vsync on and was able to get through the cinematicon ultra.

Now I'm rebooting on mission 4 and havn't tried changing graphics qualites to get through the game. That is today's mission while I am waiting for alienware and Blizzard to get back to me on the open tickets.

The game runs perfectily fine on ultra settings on my 2 year old system with just a quad core, 3 gb of ram, Geforce 280.

m
0
l
July 29, 2010 1:54:49 PM

PaulAustin said:

Now I'm rebooting on mission 4 and havn't tried changing graphics qualites to get through the game. That is today's mission while I am waiting for alienware and Blizzard to get back to me on the open tickets.
.


Wow, I can't believe you are having issues with such an advanced system. This definitely sounds like a software issue on the blizzard/amd/ati side. This does make me feel better though. I have a system that is not even half as advanced as yours and you are having the same issue as me. This re affirms to me that it is a software problem and not a system/hardware issue.
m
0
l
July 29, 2010 2:11:59 PM

PaulAustin said:


I am waiting for alienware and Blizzard to get back to me on the open tickets.



Paul: Please respond to this thread when you get a response from Blizzard.

I don't think this is related to your system since I have the same issue.

By the way, what is vsynch?
m
0
l
July 29, 2010 7:18:54 PM

As I understand it it has something to do with synching the top and bottom half of your display so it doesn't look like the screen is tearing. I guess this is a problem with flat panel monitors and wasn't with CRT's. But I could be entirely wrong. Most games have a check box for it.

The alieware guy also put something in one of the files in the starcraft directory concerning framerate =60. But I don't know what file that was, or what the full format of the line was. They were supposed to test some stuff out and call me back today or tomorrow, when he calls back I will add that to the thread, since that seemed to get me through the cinematic further.

Its weird that the game would crash on me during a cinematic, because that should be just like playing a movie.
m
0
l
July 30, 2010 6:53:45 AM

Quote:
'Anyone else have StarCraft II try to melt their hardware? Blizzard admits that it's a known issue and has a fix for you.

Apparently, the game's menu screens aren't framerate-limited. This means that when there's nothing else going on, your graphics hardware renders the bejeezus out of those screens, causing nasty overheating problems. The fix is easy, requiring players to add the following lines to your "Documents\StarCraft II Beta\variables.txt" "Documents\StarCraft II\variables.txt" file (nice catch, commenter LegolElf):

frameratecapglue=30
frameratecap=60

Good to know. Personally I would have appreciated a heads-up before my video card fried, but maybe this can save someone else from the hassle I've been dealing with since yesterday afternoon.




http://gameinformer.com/b/news/archive/2010/07/28/blizz...


I found this at http://www.teamliquid.net/forum/viewmessage.php?topic_i...

I'm not sold that this is a fix, but I have very little GPU knowledge. And I am also very sad that this is an issue...
m
0
l
July 30, 2010 12:52:32 PM

Everyone: all is good in StarCraft 2, for now.

There was a fix on ATI/AMDs website specifically for AGP cards. It is a separate download that you can only find on a Solution document. The fix included a new Catalyst and display driver designed for the older AGP cards. I will fault AMD for poor placement of this. When initially searching for AGP Card drivers, selecting my OS, and card type, I was taken to a page with drivers that were not compatible with my system. These drivers were not even detected. This caused hours of frustration.
After installing the correct drivers, I was able to play my first game of Starcraft 2 last night on the HIGH settings - can you believe it - considering my system has been called "ancient".

Thanks for the help everyone.

Paul: I would still like to hear your update from Blizzard.
m
0
l
July 30, 2010 1:18:27 PM

brett1042002 said:
My money is on the video card driver issue.


Since the issue was with the video card, I am naming this "best answer". Although it was not as straightforward it should have been (no thanks to AMD/ATI), I got it to work.
m
0
l
July 30, 2010 1:19:51 PM

Best answer selected by sanderson73.
m
0
l
July 30, 2010 1:26:56 PM

Renseru said:
Quote:
'Anyone else have StarCraft II try to melt their hardware? Blizzard admits that it's a known issue and has a fix for you.

Apparently, the game's menu screens aren't framerate-limited. This means that when there's nothing else going on, your graphics hardware renders the bejeezus out of those screens, causing nasty overheating problems. The fix is easy, requiring players to add the following lines to your "Documents\StarCraft II Beta\variables.txt" "Documents\StarCraft II\variables.txt" file (nice catch, commenter LegolElf):

frameratecapglue=30
frameratecap=60

Good to know. Personally I would have appreciated a heads-up before my video card fried, but maybe this can save someone else from the hassle I've been dealing with since yesterday afternoon.




http://gameinformer.com/b/news/archive/2010/07/28/blizz...


I found this at http://www.teamliquid.net/forum/viewmessage.php?topic_i...

I'm not sold that this is a fix, but I have very little GPU knowledge. And I am also very sad that this is an issue...


Thats what the alienware guy did to my pc, but I am still rebooting after he did that.
And the Drivers I have are new, so that didn't fix my issue. And my cards are not older AGP cards, so I don't think that will fix my problem. The only way I can get past the points where it reboots is to lower my settings to at least medium, and that should not be somethign I have to do with my PC. Today is day three waiting on Starcraft, so hopefully I will get an answer from them.
m
0
l
!