Sign in with
Sign up | Sign in
Your question

Bios updating problems,please help me...

Last response: in Motherboards
Share
January 15, 2005 7:13:35 PM

I've got an Asrock K7upgrade 880 motherboard and i can't get the bios to update.
I'm using all the Asrock supplied files but it just won't work.
I have:-
Downloaded ASRFLASH from Asrock,along with 1.10,1.30.
unzipped bios files.

Presently cpu is running standard mhz and loaded bios default settings.

Formatted a floppy disc,transferred ASRFLASH,K7U880_1.10,K7U880_1.30

Restarted machine with a 98 startup disc inserted.

When in msdos,inserted my flash floppy at the A:\> prompt i have typed:-
A:\>ASRFLASH K7U880_1.30
A:\>ASRFLASH K7U880_1.10
A:\>ASRFLASH.EXE K7U880_1.10
A:\>ASRFLASH.EXE K7U880_1.30
A:\>ASRFLASH K7U880_1.30.bin
A:\>ASRFLASH K7U880_1.10.bin

And a few more,they all come back with ERROR 3 file does not exist.

Does ANYONE have ANY idea what is wrong?

More about : bios updating problems

January 15, 2005 7:45:13 PM

Are you sure that you dont have to put some option at the end as /py /cc or anything that should apply?

Are you serious when you think that this board will be a good upgrade path??? Hey, going 939 (or 754??) from 462 only to change CPU is not a wise move... You upgrade to get better performance overall, and this board is performing somewhat slower than a normal board, and wont make the A64 running as fast as it should be...

IMHO, you should have spent your money on a much better nforce3 board initially and after that, when really needed, upgrade to A64 with both a CPU and MOBO. Or better, wait a bit to save maybe 50 more $$ and you could have get a nice nforce3 board with a nice a64 cpu...

-Always put the blame on you first, then on the hardware !!!
January 15, 2005 7:56:25 PM

Yeah,getting this board has been problematic from the start.
But,The upgrade board was only £20 and i got a 3100sempron at a real good price.

IF i'd have known what a knightmare these boards can be then i'd just gone and got an NF3 board.

As it is right now,i've got a 3100 in the new board waiting to be inserted in the Motherboard but i can't do that untill i get the bios updated(3100's were'nt out when first released).

All reports'reviews were pretty good for the 754board,comparable performance to dedicated boards etc it looked good to start with.

As of right now though,it's a FUING pile of crap that i don't want.

What i do want though is to get this bios updated so that i can try out the 3100.

3100's overclock like a goodun and when i finally relise my error and get an NF3 250 board,it'll probably hit about 2.3 - 2.4 ghz and be on par with an A64 3400.
Who needs 64bit computers right now?
There's nowt to run on em and games are a couple of years away still.



<P ID="edit"><FONT SIZE=-1><EM>Edited by petrolhead2003 on 01/15/05 05:19 PM.</EM></FONT></P>
Related resources
January 15, 2005 11:25:43 PM

try
a:\>dir
to see if they (program and files) exist otherwise, and maybe, the full path might help like:
A:\>: ASRFLASH a:\K7VT2_1.20

<A HREF="http://www.asrock.com/support/index_BIOS_INS.htm" target="_new">howto</A>
Quote:

At the "A:\" prompt, type ASRFLASH, hit space bar once, and type BIOS file name then press <Enter>. For example: A:\ASRFLASH K7VT2_1.20 <Enter> then you will see a message "Please wait for BIOS loading ROM".

The loving are the daring!
January 16, 2005 7:17:35 AM

I printed the guide of and followed it word for word.

It just won't work.

I can see the files with a dir on A:\>

Still won't work though.
January 16, 2005 9:23:15 AM

Try asrflasf without adding anything. Maybe you get the program starting and allowing you to select the file, that's the normal way of flashing.
a b V Motherboard
January 16, 2005 3:45:33 PM

<b>Warning: Once you start a BIOS Flash and the program actually starts to run, <font color=red>DO NOT TURN THE COMPUTER OFF UNTIL YOU GET A SUCCESSFUL FLASH CONFIRMATION</font color=red></b>


There should be nothing wrong other than typing in exactly what the program is looking for, but check the items below to be sure. Once you get the flashing program running then heed the warning, but until the flashing program starts to run you're not doing anything.

First of all the DOS bootdisk must be <b>SYS FILES ONLY</b>, if its just a normal bootdisk you need to create a <b>SFO</b> bootdisk and boot from that.

Second the <b>Show All Files</b> option should be activated on your computer when creating the flashing disk, in the first place, that way if there is a hidden file it will be also put on the flashing disk, otherwise hidden files will not be written to the flashing disk.


Last the last available BIOS flash is usually the one you'll need, unless there was a previous flash that changed the flashing protocol, I have run into that situation, not many times but I have run into it, check the flash history and make sure the BIOS flash protocol hasn't been changed by a previous flash and compare that flash identity with the existing flash identity and make sure you're past that flashing date, I hope that didn't just confuse you, its no big deal its just something you need to check out. If and only if, the flashing protocol has been changed, you may need to flash with the changed protocol flash first, if you're not already flashed with that flash. Now the odds of you running into that are rare, that was more common on older M/Bs, so just check the flash history to be sure.



To get the flash program started its just finding what its looking for.


Try;

A:\>ASRFLASH
or
A:\>ASRFLASH.EXE
or
A:\>ASRFLASH EXE
or
A:\>ASRFLASH.EXE/K7U880_1.30.BIN
or
A:\>ASRFLASH.EXE K7U880_1.30.BIN


Remember:
The ASRFLASH file is an .EXE file, the K7U880_1.30 file is a .BIN file.

Typing;

A:\>DIR and pressing Enter, will take you into the Floppy Directory and show you exactly how the files on the floppy disk are written, write down how they are exactly written, and input them as they are written.

<font color=red>Remember the warning you have unlimited chances to get this thing right, unless you shutdown the computer with an unsuccessful flash, if you do, your M/B is toast.</font color=red>

If this doesn't help you enough PM me. Ryan






I'm 4ryan6 <b><font color=green>><></font color=green></b> and I approved this message!
<A HREF="http://forums.btvillarin.com/index.php?act=ST&f=41&t=25..." target="_new">Specs</A>


<P ID="edit"><FONT SIZE=-1><EM>Edited by 4ryan6 on 01/16/05 12:53 PM.</EM></FONT></P>
a b V Motherboard
January 16, 2005 4:10:09 PM

FROM THE ASR WEBSITE

BIOS Update Utility

ASRFLASH.EXE: This is the Flash Memory Writer utility that updates the BIOS by uploading a new BIOS file to the programmable flash ROM chip on the motherboard. To determine the BIOS version of your motherboard, press <F2> to enter the BIOS setup utility during bootup, and check the BIOS version from the Main menu. Larger numbers represent a newer BIOS file. This utility works only in DOS mode.
You can please click here to download the ASRFLASH.EXE.
ASRock motherboard MUST use ASRock's ASRFLASH.EXE utility to update BIOS, those uncertified BIOS flashing tools will cause motherboard damage.



Updating BIOS Procedures
Create a bootable system floppy disk.
Download the ASRFLASH.EXE and copy ASRFLASH.EXE to the just created boot disk in step 1.
Download an updated ASRock BIOS file (WinZip format with .zip file extension) from the web site, unzip the BIOS file and save to the disk you created in step 2.
Boot from the disk you created in step 3.
At the "A:\" prompt, type ASRFLASH, hit space bar once, and type BIOS file name then press <Enter>. For example: A:\ASRFLASH K7VT2_1.20 <Enter> then you will see a message "Please wait for BIOS loading ROM".
After 1 minute, you will see the message "Flash ROM Update Completed - Pass", then you have finished upgrading the BIOS.
After finishing upgrading the BIOS, please remove the floppy disk. Restart your system and press <F2> to enter the BIOS setup utility during boot up.
In Exit menu, please select "Load Default Settings" and press <Enter> to continue.
Select "Exit Saving Changes" and press <Enter> to exit the BIOS setup utility.
Now, system is booting up with new BIOS.



<b><font color=red>Notice</font color=red></b> : If you encounter problems while updating the new BIOS, DO NOT turn off your system since this corrupt BIOS might cause your system failed to boot up. Just repeat the process, and if the problem still persists, update the original BIOS file. If the Flash Memory Writer utility was not able to successfully update a complete BIOS file, your system may not be able to boot up. If this happens, your system will need service.





<b>Sometimes I've had better results by creating the Sys Files Only bootdisk and creating the separate flashing disk, with the ASR.EXE and BIOS.BIN files on them, I usually boot into the system with the SYS FILES ONLY bootdisk and when it gets to the A:\> dos prompt, remove the Sys Files Only bootdisk and insert the flashing disk, type in DIR first to confirm the files are on the floppy, and if they are proceed.</b>








I'm 4ryan6 <b><font color=green>><></font color=green></b> and I approved this message!
<A HREF="http://forums.btvillarin.com/index.php?act=ST&f=41&t=25..." target="_new">Specs</A>
Anonymous
a b V Motherboard
September 8, 2009 4:46:14 PM

hi darix30 here..

THIS IS A WORKING SOLUTION

I downloaded the asrock bios update for asrock1333-dvi/h version 2.10 and the bios was named cr133gd2.10

i use a windows 98 machine that i have and made the bootable floppy and then placed both the asrflash.exe and the bios file cr133gd2.10 and then rebooted from floppy.

the flash program attempted to start but with the "error 3 file does not exist" after, so i queried online to no avail.

Then i had a thought. in the old dos code you were only allowed 8 alpha numeral characters, a dot and then a 3 apha numeral extension. (12345678.123)

I removed the GD and the dot in 2.10 because in dos mode it has cr133gd2.10 then extension is .10 which should be .BIN. so it should be 12345678.BIN . If you look at the file in windows xp up the file is known as a 10 file so if you click once on the filename so you get a box with the name highlighted in blue reduce the name to only 8 alpha numeral characters then .BIN like for mine i reduced it from CR133GD2.10 to CR133210.BIN rebooted and typed at the A: prompt.......ASRFLASH.EXE CR133210.BIN (have a space between the flash.exe name and the bios file name).

BINGO!!!! worked a treat loaded up and was automated just needed to reboot
a b V Motherboard
September 9, 2009 6:25:32 AM

Now there's a little bit of history for ya Ryan (ya ol' timer :lol:  )

@Darix, it's nice that your trying to help others with PC problems, but you may want to check the dates a little closer?

PS: Welcome to Tom's, and enjoy your stay!!! :hello: 
April 4, 2010 9:46:05 PM

Hey Anonymous/darix30 ... thank you! I was having the same error but after reading your post I see now what the problem is. ASRock was a little dumb for naming their bios files with a period in it to designate the version. Of course in DOS that screws everything up. For instance my bios file was originally called "K7U880_1.50"... lol what a dumb mistake. Dos thought the 50 was the extension of the file.

Thank you for taking the time to post the solution even so long after the OP.

As for unclefester ... go to hell, sir. :p  I'm kidding but, seriously, don't diss him for posting late. I am playing around with that same motherboard now, and his post really helped me!

Thanks again! :) 
a b V Motherboard
April 5, 2010 6:35:34 AM

Hey Darussiaman, welcome to Tom's. Glad Darix30's post helped ya out.

My intention wasn't to put Darix down, just thought I'd post before somebody else did. I've seen where a couple of the regulars ride some of the new guys pretty hard for reviving an old thread, so I was actually trying to be tactful and not hurt anybody's feelings. Hopefully he took it as such.

Besides it gave me a chance to give that ol' guy a little jab!!! LOL :whistle: 

UF
!