Alt-Tab Lag

CPU - Core I7 960 (stock)
RAM - 12 GB DDR3 1333
Video - PNY GTX 470
PSU - Corsair TX 750
OS - Windows 7 64 bit

Just took shipment of my new computer yesterday. Immediately installed new GPU and power supply.

I'm having an issue with some fairly sizeable freezes when coming out of or going into games while using Alt-Tab. My screen goes black for anywhere from 20-30 seconds before the switch takes place.
So far, this is happening in the only two games I've tried on the new computer - Borderlands and Just Cause 2 (both playing from Steam, and in case you're interested, I'm having the exact same issues with the Shift-Tab command in-game to bring up the Steam UI - only difference is that in this case, i get a screen that looks like a merged screenshot of my current position in the game and a very transparent Steam UI. Again, after 20-30 seconds, it "lets go" and allows me to see whichever screen I intended to get to.)

So far, this only occurs when switching to/from a game. I never had this problem on my old rig, running Vista 32 bit.

To the best of my knowledge, all drivers are up-to-date, certain that MoBo and GPU drivers are.

Any help you could provide would be fantastic.

7 answers Last reply Best Answer
More about tomshardware
  1. Best answer
    are all your drivers up to date?
  2. To the best of my knowledge, all drivers are up-to-date, certain that MoBo and GPU drivers are.
  3. Double checked all drivers. Everything is up to date. Installed newest version of DirectX 9.0c and C++2008 Redist. (which had been suggested in a different forum). This has fixed the majority of the problems I'm experiencing, but two of my games within Steam are still having the exact same problem: Borderlands and Just Cause 2. Every other game I have on Steam (Valve and otherwise) work perfectly when Shift-Tabbing to or from Steam UI and Alt-Tab. Any idea why these two games in particular would be causing such issues?
  4. Install the latest june MS DXSDK or NVidia SDK and play the game then try the game.

    GTX 470 have DX11 support and just cause 2 have DX11 support, so play the game in Dx11 mode then you can enjoy the game.

    if still you faced the problem, this may be driver issue. contact NVidia team.
  5. Thanks for the feedback. I got the latest DirectX and C++ updates yesterday, which fixed the majority of the problems I was having with Steam games, but did not fix these two in particular. I'll have to check whether I'm playing JC2 in dX 10 or 11 at the moment. If not set to dX 11, will definitely change it. Will also try reinstalling the most recent NVidia drivers to see if they have any effect. Thanks for the suggestions!
  6. After trying everything under the sun, I fanally had to assume that uninstalling the bloatware preinstalled on the computer left some hooks in the registry causing the issues. I decided to start from scratch with a fresh install of Windows 7, and it did the trick. Just posting this in case someone else comes across the same or a similar issue in the future. Thanks again for everyone's help in the matter. I'm just glad to be playing my games as they should be!
  7. Best answer selected by trydian.
Ask a new question

Read More

PC gaming Games Video Games