Sign in with
Sign up | Sign in
Your question
Closed

Sniper: Ghost Warrior (Steam) fails to launch

Last response: in Video Games
Share
August 1, 2010 5:09:30 PM

I just got a new system. The company that I got it from does a fairly decent stress and burn in period, so let's assume it was 100% when I opened the box. I added a Killer K1 NIC card and a DVD/CDRW. Put my games on it. Originally, WOW and CODMW2 were crashing randomly...the PC would just entirely lock up and I'd have to reboot. I disabled the onboard lan in bios and that stopped.
Simultaneously, Sniper Ghost Warrior has stopped working. Whether or not Steam is already loaded, no matter how I launch the game, it gets to the screen with the "City Interactive" logo, and then just shuts down to desktop. No error messages, nothing. I can't figure out what it could be, especially since there were no changes of any sort made from one day to the next when it quit working.

Any ideas?


*EDIT* Running WIN7 Home ultimate, 64Bit
12GB ram
Nvidia GTX465
2 1TB HD in Raid 0

Highest temperature I have seen on CPU is 54C after about 4 hours of playing WoW on Ultra video settings. Also, if it were the GPU temp it wouldn't happen even after the first boot up of the day. I have searched all over for Sniper specific issues, and reading this and a couple other forums seemed to indicate maybe the problem is with WIN7. The only issue really covered in the STEAM Sniper forums was a multiplayer issue they fixed with a patch very recently.

Thanks for reading.
August 1, 2010 9:01:07 PM

Maybe this info will help someone be able to help me?

Faulting application name: Sniper_x86.exe, version: 1.2.0.0, time stamp: 0x4c5161b9
Faulting module name: filesystem_x86.dll, version: 1.0.0.1, time stamp: 0x4c3f10c0
Exception code: 0xc0000005
Fault offset: 0x00003769
Faulting process id: 0xfe8
Faulting application start time: 0x01cb31bbe54a3a89
Faulting application path: c:\program files (x86)\steam\steamapps\common\sniper ghost warrior\Sniper_x86.exe
Faulting module path: c:\program files (x86)\steam\steamapps\common\sniper ghost warrior\filesystem_x86.dll
Report Id: 245c1ad4-9daf-11df-9810-a2a533eeff27
Score
0
August 2, 2010 12:22:39 PM

Since this developed, I have updated the audio drivers, and then rolled them back when that didn't fix it. I also updated the video drivers and when that didn't fix it, uninstalled those and put in 2 different sets of video drivers, the ones that came with the card and the release from June that just got updated in July. I'm to the breaking point of just reinstalling everything and starting clean, but this system is less than 2 weeks out of the box, and this game is the only one I'm having problems with.
Score
0
Related resources
August 2, 2010 3:47:06 PM

I uninstalled the game, and checked the box that said "Delete all local files". Re-downloaded it and it did the same thing. I would do the same for the Steam application itself, but the other games I play through Steam all work fine.
Score
0
August 2, 2010 7:27:41 PM

City Interactive had me delete a folder inside the folder the game placed in "My Documents". Once I did the game actually launched and stayed launched but locked up during the cutscene. I have deleted every reference to the game I can find, had Steam uninstall it's content, deleted the folder from under Steam and am re-downloading it now. This is ridiculous.

I'm fairly certain they won't refund money, but the game DID work, that's what is so completely bizarre. I don't know what changed to make it stop working in the first place.
Score
0
August 2, 2010 8:28:05 PM

I guess this can be closed out. I reinstalled everything. Started the game, it locked up. Went back in a deleted the settings folder and it works. Only took 3 times downloading it but meh, whatever.
Score
0
August 3, 2010 7:18:47 AM

This topic has been closed by Mousemonkey
Score
0
!