Bioshock Installation Patch Failure; No explaination?

I got Bioshock just today and I have internet connection. It took a good 10 minutes maybe to install. But then it said that it was downloading a patch. After not even 10 seconds, it said that it failed to download patch. Then everything just dissapeared. Nothing got installed. I tried it again, and the same thing happened. What the heck is going on? Why is it automatically failing like that?
It's extremely frustrating and I need help figuring this out...
2 answers Last reply
More about bioshock installation patch failure explaination
  1. Where did you get Bioshock from? Did you purchase it online or purchase it from a store? If you purchased it online, get with the online dealer you got it from.

    If you purchased it from the store, not sure what you can do. Have you tried 2k support?
  2. Check you Internet connection.I've also this problem,when I upgrade my OS Vista to Win7.I was worried because i install this game month ago but it not installing that time(patch download failed ).Then i call my isp & reconfigure my net connection.After that my problem is solve.Have you upgrade your OS or change your computer name?
Ask a new question

Read More

PC gaming Download Internet Connection Video Games