Closed Solved

StarCraft 2 Ultra setting problem

just wondering if anyone else having problems with SC2

ive looked at all different Forums except 4 battlenet cuz their down right now and ppl are saying that thier getting crashes and artifacts and cards ared being overheated

my problem is with the settings ULTRA... thats just it, its set to ULTRA and the graphics look like crap. Example no detail on character everything is one smooth color like

when i first started the campaign the guy picking up the glass had no detail whats so ever his whole hand was one color no finger nail detail. also plenty of artifacts

appearing everywhere, in fires, explosions, deaths.

so im thinking theres something wrong with the game cuz all my other games run perfect on full settings

my system is brand new 2 months is the oldest

and i cant be overheating with all 3 cards liquid cooled at 40C

is there another patch coming soon to fix this crappy game that i souldnt of bought


i7 960 (3.2) was over clocked at 4.0GHz
motherboard MSI X58 PRO-E
3 ATI 5870 in crossfire all liquid cooled
64 bit Quad-Core Processor
12GB DDR3 1600
1.5TB SATAII
24X DL DVD+/-RW Drive
Sound card - Integrated
Ethernet
Realtek chipset, Gigabit LAN
1200watts
Windows 7 Home Premium 64-bit
Swiftech H20-220 Apex Ultima XT Liquid Cooling Kit
Liquid Cooling
11
answers
Last reply
Best Answer
More about starcraft ultra setting problem
  1. hmm? try reinstalling your graphic cards
  2. it didnt work microwave and now all my games cause artifacts
  3. hmm, try doing a system restore to a different date and let me know how it goes.
  4. It worked!!! :) thanks microwave your the best, man this game is hella tight.
  5. Best answer
    There was an ATI patch to enable AA on SC2. Try that...google catalyst 10.7a. Also, cards are over heating in certain screens of the game, this could be causing the artifacts etc. Just have to insert some lines in an ini file...Google that also lol i can't link it as i'm at work.
  6. no problem microwave glad I could help
  7. hooray4boobies said:
    There was an ATI patch to enable AA on SC2. Try that...google catalyst 10.7a. Also, cards are over heating in certain screens of the game, this could be causing the artifacts etc. Just have to insert some lines in an ini file...Google that also lol i can't link it as i'm at work.



    my cards arnt overheating thier liquid cooled its was the new ATI paTCH for the 5870 that was messing with my games the 10.7
  8. thanks anyways ive fixed it
  9. I have spent some time with this problem too - after removing all other potential issues, I have discovered that this is a software setting in the user profile - not a hardware problem at all!

    I have an ATI 5850 card on an i7-860, no overclocking (right now) - more than enough to run Starcraft 2. It started experiencing artifacts during the tutorial. I ran clean sweep on the drivers, installed the latest, tried running several other games like Crysis - monitoring the temperature of the card on my second monitor. Crysis took it up to about 78C, but Starcraft 2 never went over 58C - hardly stressing the card!

    I tried lowering the graphics settings in the game options, I used the "cap" settings in the .INI file - nothing changed.

    I finally created a new user account on my Windows installation (thus a new profile for game settings), logged in and ran it again - all my problems went away.

    It's a SOFTWARE problem, not a HARDWARE problem - hopfully Blizzard will figure it out soon - I'd rather not have to log into another account just to play one game, but it's better than returning the game!
  10. Best answer selected by mousemonkey.
  11. This topic has been closed by Mousemonkey
Ask a new question

Read More

PC gaming Starcraft 2 Video Games