Sign in with
Sign up | Sign in
Your question

Long load times in Starcraft 2

Last response: in Video Games
Share
August 10, 2010 3:29:08 AM

Specs below:

Asus P5N-D SLI Intel Core 2 Duo E8400 LGA775 Dual-Core (45nm / 3.0GHz / 6MB / 1333FSB)
4GB 667MHz (2X-2GB) DDR2 PC5300 Dual-Channel RAM 320GB 7200RPM
SATA2 Hard Disk Drive
GeForce GTS 250 Video Card - 512MB DDR3, PCI-E 2.0, DVI-I, VGA, HDMI, SLI Ready
Windows 7
DirectX 11

Essentially load times on my missions are very long, 4+ minutes in most cases. Reloads are much faster, 15 seconds but still longer than I'd expect. Initial start up of the missions are filled with stuttering and poor frame rates for about 20 seconds. Occasional in game slow downs also occur.
I have more than met recommended specs and yet even on medium/high settings I am getting huge loads.

Anyone else have this problem? Any idea what I should upgrade/fix?

Thanks!

More about : long load times starcraft

August 10, 2010 4:09:30 AM

killswitch1968 said:
Specs below:

Asus P5N-D SLI Intel Core 2 Duo E8400 LGA775 Dual-Core (45nm / 3.0GHz / 6MB / 1333FSB)
4GB 667MHz (2X-2GB) DDR2 PC5300 Dual-Channel RAM 320GB 7200RPM
SATA2 Hard Disk Drive
GeForce GTS 250 Video Card - 512MB DDR3, PCI-E 2.0, DVI-I, VGA, HDMI, SLI Ready
Windows 7
DirectX 11

Essentially load times on my missions are very long, 4+ minutes in most cases. Reloads are much faster, 15 seconds but still longer than I'd expect. Initial start up of the missions are filled with stuttering and poor frame rates for about 20 seconds. Occasional in game slow downs also occur.
I have more than met recommended specs and yet even on medium/high settings I am getting huge loads.

Anyone else have this problem? Any idea what I should upgrade/fix?

Thanks!



well im getting the same stuttering in the beginning. but it usually last only about 10 seconds so not a big deal for me.

as for the long loading times at least for me when i usually first play a game it takes longer to load. then after playing for a while it loads alot faster. possibly something to do with the Ram, not a problem though. its normal. also your Ram isnt the fastest anyway
m
0
l
August 10, 2010 5:03:14 PM

You hardware should not be the reason. I have similar system (except Vista32) and do not have much problems.
I know, it sound stupid, but try to unload antivirus, or disable it and test the game.
Also, do you login to battlenet server? Did you try playing as guest or disconnected (I mean physically detach cable, but use your name to play) from internet?
m
0
l
Related resources
August 11, 2010 3:17:38 PM

There has been a lot of players having loads issues in SC. Usually my load bar takes a few seconds to rach 80% complete but then is a minute or so with the rest. Some players experience this other don't - so it is hard to pinpoint the cause. In any case make sure your CPU is not preoccupied or running hot.

Don't know if a patch will fix this but you are definitely not alone :) 
m
0
l
February 14, 2013 1:28:41 PM

disable pagefile, no more suttering.

But you need above 4GB RAM, 8 is great for gaming , 16GB for photoshop/development.
m
0
l
February 14, 2013 8:03:11 PM

Maybe try some simple things like defragging your HDD. If it is a long load time, and considering the other hardware, I'd say it is your hard drive if not a software/driver issue. The hdd could just be spending tons of time to search for the correct files on your HDD (especially if it's near capacity), so defrag would help that for sure. E8400 is plenty enough for SC2, and a GTS250 should be fine to run the game on OK settings.

As a side note on the hdd, when i got my first SSD, i put SC2 on it and the load times drastically increases, which make sme think of an hdd issue first.
m
0
l
!