Sign in with
Sign up | Sign in
Your question

K8N and SATA HDD problems

Last response: in Motherboards
Share
February 22, 2005 4:40:02 AM

I am having a heck of a time with this computer build. I will list the specs at the bottom of the message for everyones review. Here is the MAIN issue.

I cannot get Windows XP to load fully without experiencing the following error:

Fatal Error

One or many of the components required to complete setup cannot be installed. Check to make sure that the disc is not damaged or dirty or that all of the files are at the source (network Install)

Data Error (cyclic redundency error)

Cannot load "ASMS" component d:\i386


Resolution:

I have been back to the store where I bought the Windows XP and witnessed them switch it for another sealed new copy of the disc. I got back home and experienced the same error. Always at the same point in the installation process which is after the first reboot and with ~39 minutes left to complete installation. You can hear the CD "spin-up" real fast and then all of a sudden the drive clicks and moments later the error will appear. I have tried 3 different CD/DVD-ROM/DVD drives to read the disc's and each time with each different drive I get the error at the same point in the installation. The system does not exhibit any other signs of problems (during the numerous re-formatting from NTFS to FAT back to NTFS) with retaining the information that does copy to the hard drive. And NEVER has the system had any issue posting or entering the BIOS etc... Everything seems to be pretty standard with all my previous builds.

Also I have tried using the Xcopy function in FAT configurations and at that time there were errors in copying some of the files to the hard drive. They didn't seem important (gifs, jpgs...) so I continued with the installation and lo and behold I got an error asking me to point the PC to the i386 directory on the hard drive. I try and try to direct it to the source files in these cases and it doesn't take, it just blinks and doesn't proceed to continue.

Theory:

THIS IS THE FIRST system that I have attempted to build using SATA devices (The hard drive and dvd writer). I have been attempting to load the NVidia Nforce Storage Controller driver (from the ASUS CD) during the F6 screen but whether I load it or not (in NTFS or FAT) I get the same results. I have not yet had the chance to try any other type of HDD with the current setup, hopefully I will be able to do so soon. I am using the onboard SATA ports on the motherboard NOT a controller card.

The XP Home disc that I was sold is a full version INCLUDING SP2 but was sold to me as a "OEM" disc, on the documentation it states that it should only be distributed with a new PC. This was sold to me by a large computer superstore because I was buying all the part to build a PC from them. I am curious to know if perhaps this OEM version is not all that it should be in terms of installation prompts/pathes and data as compared with the Retail Upgrade or Full version...

Bad disc, what is the chances of getting two bad discs in two days... I am thinking that this is not the true cause as the discs look fine.

Help is appreciated in advance, I leave it to you folks to show me the way on this install. If I can get it running it should be a blazing setup...

Specs: Only what is currently connected to get this thing going...
AMD Athlon 64 3200+
ASUS K8N mobo with onboard audio
Nvidia Nforce3 chipset
2 IDE ports
2 SATA ports
Numerous onboard USB connections
1 512meg DDR 3200 Kingston Xtreme Dimm
Maxtor 250 Gig Sata Ultra series hard drive (SATA 1)
ATI All in Wonder 9600
Samsung CD/DVD-ROM combo drive (IDE 1)

More about : k8n sata hdd problems

February 22, 2005 6:39:22 AM

I say its your harddrive. Wouldn't be the first new Maxtor drive which failes.
I'd recommend you try another drive.
February 22, 2005 7:07:43 PM

Hi!

Please read this.
http://forumz.tomshardware.com/hardware/modules.php?nam...
I posted this and after my post for about a day or so, you can find the same complain with K8 as well.

Basically, I do not know why SATA really cause problem with booting. I could not get SATA hard disk to be primary so I use IDE as primary and after that, SATA plugged as secondary does not cause anything. Just like normal.
I do use another SATA as primary for an 865 chipset that is new enough to support Prescott. It works fine. So people blame VIA chipset for that.But the interesting point is that few days ago, I tried to boot an with SATA in P4P800 Gold motherboard, which is about 2 years old and could not go.

All failure comes in the same form: could not read some file during file copy installation.With the 754 mobo, I got exactly problem as you. It all stop at one point. But I did not blame the CD as I have used it for installation for so many times so I know it works.
More interesting is that the ASUS gold mobo system I installed a few days ago, after the error booting up with SATA, for some reason, the error stick wityh the mobo and after that I could not even boot with IDE driver, using Windows. I had to use Linux as OS on that machine untill now.
It seems that you have to press F6 during set up to setup RAID or the like. Do google and you will see much more. BTW, do search the forum.

Regards.
Related resources
February 22, 2005 9:42:03 PM

If your SATA controller is set as RAID in BIOS, but used with only one drive, this may lead to some problem. Using the SATA controller on a nforce3 or 4 board as a regular controller doesnt need to press F6 at windows installation.

So, I would check in the BIOS to make sure that RAID is disabled for SATA controller, as well as for IDE controller.

The option should look like;

SATA 1 RAID: disabled. I dont have this board, but I've seted up some nforce3 and 4 board only with one SATA drive and I"ve noticed that RAID is enabled in BIOS by default.

-Always put the blame on you first, then on the hardware !!!
Anonymous
a b V Motherboard
February 23, 2005 7:56:08 AM

Hey, that's huge :smile: Thanks for the info man, that could have given me problems.

<font color=green> Woohoo!! I am officially a <b> Member </b>!! </font color=green>
Anonymous
a b V Motherboard
February 23, 2005 8:19:32 AM

Ok question here, in the harddrive forum I was asking about installing a 74gb raptor with my WD 80gb 8mb buffer HD in a non raid set up (i.e. just 2 drives, using the raptor as boot) Anywho, they guy there recommended this :
Quote:
If you just want two seperate drives,(e.g. one for the OS and one for storage) but want to boot from the Raptor you will need to enable booting from a SCSI device in your BIOS. During POST you should see the option to enter the RAID configuration utility. Enter it and just setup a single disk array. You should now see the disk/partition during the XP install. During the XP install watch the bottom of the screen and it will tell you to hit F6 to install RAID drivers. I can't remember if this comes before or after you format so just keep watching until you see it. If possible have the drivers on a floppy to insert at this point. These drivers should have come with your mobo or be availabe at their site.

Once XP is installed and working reconnect the other drive and your BIOS and windows should see it.

Does this make sense to you, seems like you guys are telling me to do opposites.
edit: BTW I am using windows xp, and mb is a DFI Lanparty UT nf4 Ultra-D

<font color=green> Woohoo!! I am officially a <b> Member </b>!! </font color=green><P ID="edit"><FONT SIZE=-1><EM>Edited by Wraithfire on 02/23/05 02:21 AM.</EM></FONT></P>
February 23, 2005 11:37:25 AM

It doesnt make sense to set it up like RAID if you dont want to RAID them... Unless you are using the onboard SATA controller instead of the native one, then you may need to install third party drivers. But by disabling RAID for the native controller, then your SATA controller will be treated like a normal IDE controller, and your drive will be detected like if it was a normal IDE drive by Windows.

Problem is that people think that SATA=RAID, which is not. SATA is just another IDE controller standard that can be RAIDed or not, just like parallele ATA drive.

And, before you ask, native controller is provided by the chipset(nforce4 in your case) while onboard is provided by thid party controller like Promise, Sil,...

People often doesnt look at their manual and plug the drive in the onboard controller and while it is disabled in BIOS, complain about the board not seeing their drive...

So, to make a short story, when setting up the board, look at your manual to find the native SATA1 connector and plug your boot drive in. Then find the SATA2 and plug your other drive in. In the BIOS, the native SATA should be enabled, but RAID should be disabled for them.

If setted up correctly, then your windows installation should see the drive and install the OS without any drivers needed.

This is how SATA installation went on a Soltek board and lately, one Gogabyte nforce4 board... no drivers needed.


-Always put the blame on you first, then on the hardware !!!
Anonymous
a b V Motherboard
February 24, 2005 10:50:04 AM

thanks PAT, that helps :smile:

<font color=green> Woohoo!! I am officially a <b> Member </b>!! </font color=green>
!