Sign in with
Sign up | Sign in
Your question
Closed

The Sims 3 Random Lag and Sound Cut Out

Last response: in Video Games
Share
August 13, 2010 4:06:45 PM

Hey everyone, I just recently updated my graphics card and PSU (from a geforce 9500gt and a 350w diablotek PSU to a ATI Radeon HD 5770 and a 550w corsair PSU). I play The Sims 3 quite frequently and I noticed that after a while of playing the game will lag (FPS drops from 80 to about 30) and the sound cuts off. This happened even before I made the upgrade to my computer (when I used to play with the Nvidia Geforce 9500GT), but I noticed it again last night when I was playing with my new setup. The strange thing is that if I leave the game on it will work through it and return to normal but when it does all the sounds that were cut out during the lagging period play right before it speeds back up (mostly the sound the game makes when changing the in game clock speed). I have no idea what this could be. Does anyone have any ideas? Thanks in advance! (btw, my drivers are all up to date and my system has 4GB ram with an amd athlon II X2 215 processor ~2.7GHZ).
August 13, 2010 8:39:43 PM

If you could, how long do you think you can play before the sound cuts out?
Score
0
August 13, 2010 9:25:31 PM

Hey lazyperson17, I'd say about 2 or 3 hours
Score
0
Related resources
August 13, 2010 9:32:14 PM

is it a legal copy of the game?
Score
0
August 13, 2010 9:41:54 PM

what OS are you using?
Score
0

Best solution

August 13, 2010 9:51:30 PM

is it fully patched?

try running it in compatibility mode (xp sp3)
Share
August 13, 2010 9:55:11 PM

Yep its fully patched...I haven't tried that yet, I will next time I play. Thanks for the suggestion!
Score
0
August 13, 2010 9:56:08 PM

also try running as admin
Score
0
August 13, 2010 9:58:16 PM

ok thanks for both of the suggestions jefe, I really appreciate it!
Score
0
August 16, 2010 7:52:50 AM

only 1 thing i can tell you nothing wrong with youre specs cuz i got the same gpu u got and i play sims 3 no problems but i think u should limit youre fps to 60 that fixes lot of sound problems in some games

and agin youre problem is only about software
Score
0
August 16, 2010 4:28:04 PM

thanks for the response nightstalker_n...I've noticed with the radeon hd 5770 that the shadows look pixelated in the daytime and have heard that numerous people are having the same problem, are you? Also if you wouldn't mind can you tell me what ati catalyst settings you use and what your settings are in the sims 3 itself...thanks in advance :) 
Score
0
August 17, 2010 11:01:16 AM

well 1st my specs are the same as yours expect the cpu i got athlon ii x4 630 2.8 but that doesnt matter cuz i dont think the game uses more than 2 cores

my catalys settings are the default version 10.7

sims 3 setting every thing on max expect shadow turn off

and there was a setting says number of buildings rendered at the same time put it on 1 only and its youre house or the place youre at

and AAx4

and since sims 3 doesnt have a vertical sync setting i downloaded an APP wich allow you to turn vsync on

its Rivatuner and D3DOverrider comes with it (google it) so open D3DOverrider after you install Rivatuner and enable vsync and triple buffering

limiting youre FPS would help alot

thats all im doin to run the game hopfully it works for you :wahoo: 

Score
0
August 18, 2010 4:41:50 AM

Thanks for taking the time to let me know your settings nightstalker, I really appreciate it! I'll try things out and play with the settings you use :) 
Score
0
Anonymous
September 11, 2010 2:24:43 PM

hey i just had the same problem and i just istalled the power shell 2.0 update while i had the sims in window mode, and now the sound is back and no more lag. good luck
Score
0
September 28, 2010 3:57:34 AM

Best answer selected by Keepnitreal2007.
Score
0
September 28, 2010 5:10:19 AM

This topic has been closed by Mousemonkey
Score
0
!