Running an older game in 4:3 aspect ratio

Hey everyone,

I recently bought a digital copy of Return to Krondor from GOG.com and I'm having a hard time figuring out how to get this thing to run in 4:3 aspect ratio on a widescreen monitor.

I put my monitor in 4:3 as it has this option built into the monitor, but for some reason this game seems to override that and launches in widescreen aspect ratio.

I've tried to launch it in a window by adding the s-w and -window to the shortcut but that doesn't seem to work for this one.

Does anyone have any idea how I can get this game to run in 4:3 or in a window?

I am running Windows XP with a Geoforce 8800 GT.
5 answers Last reply
More about running older game aspect ratio
  1. I can't recall exactly for NVidia, but I know for ATI you look in the Video card control panel for a scaling option and set it to maintain aspect ratio or use centered timings. Perhaps for NVidia it is similar.
  2. I do believe NVidia is similar, however they seemed to have dropped this option from a certain forceware version on. I do not have this option in my NVidia control panel on my 8800 GT, I might be able to install older drivers and gain this option, however I'm not sure if it will make a difference due to the fact that I can set my monitor to do the same thing, but I will give it a try.

    I had another idea as well, I was thinking of using VMplayer to create a windows XP virtual machine, install the game and run it on that. In theory I would have an entire Virtual Machine running in a window, and thus could get the 4:3 aspect ratio, it will just take some time to install XP on the virtual machine, run windows update, etc...
  3. I learned the hard way that you cannot use aspect ratio scaling unless the Nvidia Control Panel detects you monitor as an LCD, which it doesn't if you use a VGA cable. I had to buy a DVI cable before I could set the aspect ratio. maybe you have the same problem.
  4. The 8800 GT doesn't have VGA, only DVI. I use an HDMI cable from my monitor to DVI converter at the video card. I have read that Nvidia dropped the aspect ratio scaling option from certain cards/drivers but I'm not sure. MY monitor handles this perfrectly though for pretty much everything I wanted to put in 4:3 until this game. For some reason this game overrides my monitor's settings, which is very odd. I keep thinking there has to be something simple.

    I checked the config file but there is nothing that I can see that would be of use. There was an option to stop the cinematic (movies) from stretching but not the actual game.
  5. My old card was an 8800GTS. Nvidia scaling worked perfectly on that.
Ask a new question

Read More

PC gaming Games Monitors Video Games