Why I can't see my D-Link DCS-2100+ from the Internet??? N..

Archived from groups: alt.internet.wireless (More info?)

Hello,

I have:

1. LinkSys Wireless-B
2. D-Link DCS-2100+ Internet Camera
a. http port = 85
b. control port = 5001
c. audio port = 5002
d. video port = 5003

When I try to access the camera at work, I get a warning message (not
sure
if it's Window's or IE's warning message) but it reads "Because the
connection problem of network environment, the transmission protocol
changes to HTTP" with the OK button. I click "OK" and the camera
always says "Connecting...."
but I am not receiving the stream video in the window. I can do
remote management on the camera, ex., configure the camera's settings
but I am just not getting the video.

The tech guys at D-Link are no help. As soon as they hear the camera
is working fine, then that's not their problem.

I've reviewed some of the settings in IE and did not see anything that
could
cause this problem. I believe it's either a security issue at work or
IE setting related. By the way, my machine is W2K PROF and IE v6.0

If you have some ideas or know what the problem might be, please let
me know.


Sydney
sydneyluu@yahoo.com
14 answers Last reply
More about link 2100 internet
  1. Archived from groups: alt.internet.wireless (More info?)

    Would assume if its saying;
    "Because the connection problem of network environment,
    the transmission protocol changes to HTTP"
    This would mean your camera is set internally UDP probably by default.
    Admin login has a connections page offering check boxes for UPD/TCP/HTTP
    Try choosing TCP - that's what I use for dlink router / dlink dcs2000,
    with camera set UDP and the dlink di624a router would not work here - and
    produces same message which goes no where.


    "Sydney Luu" <sdluu@sunocoinc.com> wrote in message
    news:3883e5dd.0410270552.4a8f1292@posting.google.com...
    > Hello,
    >
    > I have:
    >
    > 1. LinkSys Wireless-B
    > 2. D-Link DCS-2100+ Internet Camera
    > a. http port = 85
    > b. control port = 5001
    > c. audio port = 5002
    > d. video port = 5003
    >
    > When I try to access the camera at work, I get a warning message (not
    > sure
    > if it's Window's or IE's warning message) but it reads "Because the
    > connection problem of network environment, the transmission protocol
    > changes to HTTP" with the OK button. I click "OK" and the camera
    > always says "Connecting...."
    > but I am not receiving the stream video in the window. I can do
    > remote management on the camera, ex., configure the camera's settings
    > but I am just not getting the video.
    >
    > The tech guys at D-Link are no help. As soon as they hear the camera
    > is working fine, then that's not their problem.
    >
    > I've reviewed some of the settings in IE and did not see anything that
    > could
    > cause this problem. I believe it's either a security issue at work or
    > IE setting related. By the way, my machine is W2K PROF and IE v6.0
    >
    > If you have some ideas or know what the problem might be, please let
    > me know.
    >
    >
    > Sydney
    > sydneyluu@yahoo.com
  2. Archived from groups: alt.internet.wireless (More info?)

    test
    "bumtracks" <posted@usenet.bud> wrote in message
    news:g4Ofd.5348$dW.4586@trnddc08...
    > Would assume if its saying;
    > "Because the connection problem of network environment,
    > the transmission protocol changes to HTTP"
    > This would mean your camera is set internally UDP probably by default.
    > Admin login has a connections page offering check boxes for UPD/TCP/HTTP
    > Try choosing TCP - that's what I use for dlink router / dlink
    dcs2000,
    > with camera set UDP and the dlink di624a router would not work here - and
    > produces same message which goes no where.
    >
    >
    > "Sydney Luu" <sdluu@sunocoinc.com> wrote in message
    > news:3883e5dd.0410270552.4a8f1292@posting.google.com...
    > > Hello,
    > >
    > > I have:
    > >
    > > 1. LinkSys Wireless-B
    > > 2. D-Link DCS-2100+ Internet Camera
    > > a. http port = 85
    > > b. control port = 5001
    > > c. audio port = 5002
    > > d. video port = 5003
    > >
    > > When I try to access the camera at work, I get a warning message (not
    > > sure
    > > if it's Window's or IE's warning message) but it reads "Because the
    > > connection problem of network environment, the transmission protocol
    > > changes to HTTP" with the OK button. I click "OK" and the camera
    > > always says "Connecting...."
    > > but I am not receiving the stream video in the window. I can do
    > > remote management on the camera, ex., configure the camera's settings
    > > but I am just not getting the video.
    > >
    > > The tech guys at D-Link are no help. As soon as they hear the camera
    > > is working fine, then that's not their problem.
    > >
    > > I've reviewed some of the settings in IE and did not see anything that
    > > could
    > > cause this problem. I believe it's either a security issue at work or
    > > IE setting related. By the way, my machine is W2K PROF and IE v6.0
    > >
    > > If you have some ideas or know what the problem might be, please let
    > > me know.
    > >
    > >
    > > Sydney
    > > sydneyluu@yahoo.com
    >
    >
  3. Archived from groups: alt.internet.wireless (More info?)

    On 27 Oct 2004 06:52:46 -0700, sdluu@sunocoinc.com (Sydney Luu) wrote:

    >1. LinkSys Wireless-B

    Is there some reason that you've failed to disclose the exact model of
    your Linksys Wireless Router? Is it a secret unannounced model
    perhaps? Fear of numbers?

    >2. D-Link DCS-2100+ Internet Camera
    > a. http port = 85
    > b. control port = 5001
    > c. audio port = 5002
    > d. video port = 5003

    Looks good so far.

    >When I try to access the camera at work, I get a warning message (not
    >sure
    >if it's Window's or IE's warning message) but it reads "Because the
    >connection problem of network environment, the transmission protocol
    >changes to HTTP" with the OK button. I click "OK" and the camera
    >always says "Connecting...."

    Two possibilities:

    1. Welcome to the joy of proxy servers. Your office apparently (my
    guess) has a proxy server running for outgoing connections. Any ports
    not specifically specified in the proxy server is not going to work.
    The usual default is to redirect the traffic to port 80(http). That
    seems to be what the message is mumbling. Your port 85 traffic is
    going out via port 80. Since port 80 is not configured on your
    unspecified Linksys model router to be directed to the camera, it will
    try forever to connect to something that's not there.

    2. You screwed up in redirecting the IP ports in your unspecified
    model Linksys wireless router.

    >but I am not receiving the stream video in the window. I can do
    >remote management on the camera, ex., configure the camera's settings
    >but I am just not getting the video.

    Ahah. A clue. The proxy server apparently is only setup to manage
    "well known ports" which are those less than 1024. Port numbers
    greater than 1024 go right through. Change the configuration of your
    DCS-2100+ to set the http port to 5000. Change the IP redirection in
    your unspecified model Linksys wireless router to correspond to the
    port change. It should work.

    >The tech guys at D-Link are no help. As soon as they hear the camera
    >is working fine, then that's not their problem.

    Yep. Applications support is not provided.

    >I've reviewed some of the settings in IE and did not see anything that
    >could
    >cause this problem. I believe it's either a security issue at work or
    >IE setting related. By the way, my machine is W2K PROF and IE v6.0
    >
    >If you have some ideas or know what the problem might be, please let
    >me know.
    >
    >
    >Sydney
    >sydneyluu@yahoo.com

    --
    # Jeff Liebermann 150 Felker St #D Santa Cruz CA 95060
    # 831.336.2558 voice http://www.LearnByDestroying.com
    # jeffl@comix.santa-cruz.ca.us
    # 831.421.6491 digital_pager jeffl@cruzio.com AE6KS
  4. Archived from groups: alt.internet.wireless (More info?)

    Thanks for responding.

    Fear of numbers? Not really. Just didn't think it was neccessary to
    troubleshoot this problem at the time when I composed this message.

    However, here's what I have left out and maybe it's important to know.
    I contacted two friends of mine who work for different companies and
    they
    had no problems seeing my camera. Does this still sound like a port
    issue?

    I believe all ports are blocked at my company except 80. But I will
    definitely give it a try by changing the camera's + router to point to
    port 5000 as you suggested. At this point, I am willing to try
    anything...

    Thanks again.

    Sydney
    sydneyluu@yahoo.com


    Jeff Liebermann <jeffl@comix.santa-cruz.ca.us> wrote in message news:<9cj0o0pc6q791cueokpootn7spsi70063h@4ax.com>...
    > On 27 Oct 2004 06:52:46 -0700, sdluu@sunocoinc.com (Sydney Luu) wrote:
    >
    > >1. LinkSys Wireless-B
    >
    > Is there some reason that you've failed to disclose the exact model of
    > your Linksys Wireless Router? Is it a secret unannounced model
    > perhaps? Fear of numbers?
    >
    > >2. D-Link DCS-2100+ Internet Camera
    > > a. http port = 85
    > > b. control port = 5001
    > > c. audio port = 5002
    > > d. video port = 5003
    >
    > Looks good so far.
    >
    > >When I try to access the camera at work, I get a warning message (not
    > >sure
    > >if it's Window's or IE's warning message) but it reads "Because the
    > >connection problem of network environment, the transmission protocol
    > >changes to HTTP" with the OK button. I click "OK" and the camera
    > >always says "Connecting...."
    >
    > Two possibilities:
    >
    > 1. Welcome to the joy of proxy servers. Your office apparently (my
    > guess) has a proxy server running for outgoing connections. Any ports
    > not specifically specified in the proxy server is not going to work.
    > The usual default is to redirect the traffic to port 80(http). That
    > seems to be what the message is mumbling. Your port 85 traffic is
    > going out via port 80. Since port 80 is not configured on your
    > unspecified Linksys model router to be directed to the camera, it will
    > try forever to connect to something that's not there.
    >
    > 2. You screwed up in redirecting the IP ports in your unspecified
    > model Linksys wireless router.
    >
    > >but I am not receiving the stream video in the window. I can do
    > >remote management on the camera, ex., configure the camera's settings
    > >but I am just not getting the video.
    >
    > Ahah. A clue. The proxy server apparently is only setup to manage
    > "well known ports" which are those less than 1024. Port numbers
    > greater than 1024 go right through. Change the configuration of your
    > DCS-2100+ to set the http port to 5000. Change the IP redirection in
    > your unspecified model Linksys wireless router to correspond to the
    > port change. It should work.
    >
    > >The tech guys at D-Link are no help. As soon as they hear the camera
    > >is working fine, then that's not their problem.
    >
    > Yep. Applications support is not provided.
    >
    > >I've reviewed some of the settings in IE and did not see anything that
    > >could
    > >cause this problem. I believe it's either a security issue at work or
    > >IE setting related. By the way, my machine is W2K PROF and IE v6.0
    > >
    > >If you have some ideas or know what the problem might be, please let
    > >me know.
    > >
    > >
    > >Sydney
    > >sydneyluu@yahoo.com
  5. Archived from groups: alt.internet.wireless (More info?)

    On 28 Oct 2004 06:10:55 -0700, sdluu@sunocoinc.com (Sydney Luu) wrote:

    >Fear of numbers? Not really. Just didn't think it was neccessary to
    >troubleshoot this problem at the time when I composed this message.

    Well, there was a possibility that the problem was at your end in your
    router. Knowing the manufactory, model, and firmware versions are
    important. However, in this case, it's not at your end.

    >However, here's what I have left out and maybe it's important to know.
    >I contacted two friends of mine who work for different companies and
    >they
    >had no problems seeing my camera. Does this still sound like a port
    >issue?

    It's an IP port (proxy server) issue at your company end. Staying
    away from ports below 1024 should take care of it. The clue was that
    you were able to access the control ports (5001-5003) but not the web
    server (http) image port (85). Move the image port and it should
    work.

    >I believe all ports are blocked at my company except 80. But I will
    >definitely give it a try by changing the camera's + router to point to
    >port 5000 as you suggested. At this point, I am willing to try
    >anything...

    I don't think *ALL* ports are blocked because you were able to get to
    the control ports (5001-5003). If desperate, you can chance the
    camera image port to 80. However, that will work only if your
    unspecified router does not expose it web configuration to the
    internet on port 80, and if the port forwarding will allow redirecting
    port 80. There are some routers that do this badly so have an
    accomplis help with the testing from the internet side.


    --
    Jeff Liebermann jeffl@comix.santa-cruz.ca.us
    150 Felker St #D http://www.LearnByDestroying.com
    Santa Cruz CA 95060 AE6KS 831-336-2558
  6. Archived from groups: alt.internet.wireless (More info?)

    Jeff, again thanks for responding.

    I took your suggestion. I reconfigured my router and camera to have my
    HTTP set to 5000 last night. Tried at work today and still got the
    warning
    message. Did not work. If ports like, 21 (FTP), 23 (Telent) are
    being used at work, could I use one of these as the HTTP? I am not
    network guy so I don't have the technical knowledge of how ports work.

    Also the video control port = 5003, by looking at the description, I
    thought
    this was responisble for delivering the video/image, not HTTP=85 which
    I had
    it before. Can you clarify these ports? When you make a request to
    the camera
    from office and when the signal travels back to office from home, what
    kind of
    port information does this signal have? I am just trying to
    understand how
    the information is being delivered back to the client/caller. Can you
    or anyone provide some details to this?

    Thanks.
    Sydneyluu@yahoo.com


    Jeff Liebermann <jeffl@comix.santa-cruz.ca.us> wrote in message news:<mf52o09abrih00sja56neij45ngmjjm9fr@4ax.com>...
    > On 28 Oct 2004 06:10:55 -0700, sdluu@sunocoinc.com (Sydney Luu) wrote:
    >
    > >Fear of numbers? Not really. Just didn't think it was neccessary to
    > >troubleshoot this problem at the time when I composed this message.
    >
    > Well, there was a possibility that the problem was at your end in your
    > router. Knowing the manufactory, model, and firmware versions are
    > important. However, in this case, it's not at your end.
    >
    > >However, here's what I have left out and maybe it's important to know.
    > >I contacted two friends of mine who work for different companies and
    > >they
    > >had no problems seeing my camera. Does this still sound like a port
    > >issue?
    >
    > It's an IP port (proxy server) issue at your company end. Staying
    > away from ports below 1024 should take care of it. The clue was that
    > you were able to access the control ports (5001-5003) but not the web
    > server (http) image port (85). Move the image port and it should
    > work.
    >
    > >I believe all ports are blocked at my company except 80. But I will
    > >definitely give it a try by changing the camera's + router to point to
    > >port 5000 as you suggested. At this point, I am willing to try
    > >anything...
    >
    > I don't think *ALL* ports are blocked because you were able to get to
    > the control ports (5001-5003). If desperate, you can chance the
    > camera image port to 80. However, that will work only if your
    > unspecified router does not expose it web configuration to the
    > internet on port 80, and if the port forwarding will allow redirecting
    > port 80. There are some routers that do this badly so have an
    > accomplis help with the testing from the internet side.
  7. Archived from groups: alt.internet.wireless (More info?)

    On 29 Oct 2004 07:36:07 -0700, sdluu@sunocoinc.com (Sydney Luu) wrote:

    >I took your suggestion. I reconfigured my router and camera to have my
    >HTTP set to 5000 last night. Tried at work today and still got the
    >warning
    >message. Did not work.

    Did you try it with a friend or accomplis when you set it up last
    night? First you make sure it's working before you try it at work.

    Also, what are you using to view the picture? A web browser or the
    D-Links surveillance software?

    >If ports like, 21 (FTP), 23 (Telent) are
    >being used at work, could I use one of these as the HTTP?

    You could, but I don't think it's necessary. The trick is to find a
    port or ports that are not being mangled by the office proxy server.
    That would be port 80(http). 5000 should have worked, but I can't
    tell from here what's happening.

    Time for some details:

    1. How are you addressing the camera from the browser?
    It should be something like:
    http://123.123.123.123:5000 (or whatever)
    http://123.123.123.123:5003 (not sure if this will work)
    http://123.123.123.123:80 (the official way)
    One of these should work. However, I would also try the "Monitor"
    application, and not the browser. Will your company allow you to
    install the Monitor application on your office computah?

    2. Are you sure you have the correct IP address for your home system?
    If DHCP or PPPoE is used, the IP address can change.

    3. Do you have any kind of "personal firewall" running on your office
    PC? XP SP2 firewall, ZoneAlarm, Kerio, Black Ice, Norton Firewall,
    McAffee Firewall, etc? These will block outgoing control requests.

    >I am not
    >network guy so I don't have the technical knowledge of how ports work.

    Well, have you considered asking the office network guy for some clues
    as to how his firewall/proxy/IDS system works? It would be easier if
    I knew what I was dealing with. The important thing is that it does
    work with other users that don't have a firewall/proxy/IDS in the way.

    >Also the video control port = 5003, by looking at the description, I
    >thought
    >this was responisble for delivering the video/image, not HTTP=85 which
    >I had
    >it before. Can you clarify these ports?

    80 (TCP) HTTP Port (allows access to web-configuration and transmits
    video if other ports are not forwarded)
    5001 (TCP/UDP) Control Channel Port (used to synchronize audio and
    video)
    5002 (TCP/UDP) Audio Channel Port (transmits synchronized audio)
    5003 (TCP/UDP) Video Channel Port (transmits synchronized video)

    It would seem that you could get video from *EITHER* 80 or 5003. My
    guess is that the 5003 is only useful to the monitor application.
    5001-5003 get used with the various monitor and security applications.
    If you don't care about audio, port 80 will deliver just video.

    This might help:
    "How do I remotely view DCS-2000 or DCS-5300 series cameras that are
    behind a router or gateway? "
    http://support.dlink.com/faq/view.asp?prod_id=1433

    Oh, this is cute.
    http://support.dlink.com/faq/view.asp?prod_id=1344
    If you look carefully at the Javascript code, they don't use port 80,
    but have redirected it to port 5004 instead. Well, instead of 5000,
    try 5004. Perhaps there's some non-obvious magic involved.

    >When you make a request to
    >the camera
    >from office and when the signal travels back to office from home, what
    >kind of
    >port information does this signal have?

    Well, the port numbers for the outgoing connections from the camera
    can be anything between 1024 to 65000. The web servers inside the
    camera assigns these on the fly, as needed. You can see these in
    action on your PC with:
    (open a dos window with Run->cmd or Run->command)
    netstat -n
    The numbers after the ":" in the "Foreign Address" column are the
    incoming port numbers. I don't think you have to worry much about
    the cameras outgoing port numbers. What's important is the incoming
    (controlling) port numbers to the camera.


    --
    Jeff Liebermann jeffl@comix.santa-cruz.ca.us
    150 Felker St #D http://www.LearnByDestroying.com
    Santa Cruz CA 95060 AE6KS 831-336-2558
  8. Archived from groups: alt.internet.wireless (More info?)

    Ok, this is where I am right now and still trying to resolve my one
    remaining
    issue, which is not receiving video from the Internet. Please read my
    comments
    below.

    Jeff Liebermann <jeffl@comix.santa-cruz.ca.us> wrote in message news:<t3m4o0tfdao7nlr42kkejraekgu1ddm3mj@4ax.com>...
    > On 29 Oct 2004 07:36:07 -0700, sdluu@sunocoinc.com (Sydney Luu) wrote:
    >
    > >I took your suggestion. I reconfigured my router and camera to have my
    > >HTTP set to 5000 last night. Tried at work today and still got the
    > >warning
    > >message. Did not work.
    >
    > Did you try it with a friend or accomplis when you set it up last
    > night? First you make sure it's working before you try it at work.

    No, I didn't do this but should have.

    >
    > Also, what are you using to view the picture? A web browser or the
    > D-Links surveillance software?
    >
    > >If ports like, 21 (FTP), 23 (Telent) are
    > >being used at work, could I use one of these as the HTTP?
    >
    > You could, but I don't think it's necessary. The trick is to find a
    > port or ports that are not being mangled by the office proxy server.
    > That would be port 80(http). 5000 should have worked, but I can't
    > tell from here what's happening.

    Made a wrong choice to set HTTP=21 on Friday. Like I said port 21 is
    designated for FTP service and the camera has logic to take on FTP
    requests
    when it sees 21. What happened was, after reconfiguring both router
    and camera
    to 21. When I tried to access camera from Internal LAN, it told me
    "Access
    Denied". Apparently I hadn't setup the FTP account on the camera. I
    couldn't
    get back to homepage anymore I had to click the "Reset" button to
    return
    the camera back to its orignal D-Link's defaults and I had to re-do
    the camera
    setup again. Bad decision on my part but you live and learn.

    After getting the camera going again, I reconfigured the HTTP=137 and
    asked a
    guy at work to try it, it didn't work and he got the same warning
    message that I had posted originally. I chose 137 since it showed up
    as being used and under the "Stealth" mode - protected by the
    firewall.

    >
    > Time for some details:
    >
    > 1. How are you addressing the camera from the browser?
    > It should be something like:
    > http://123.123.123.123:5000 (or whatever)
    > http://123.123.123.123:5003 (not sure if this will work)
    > http://123.123.123.123:80 (the official way)
    > One of these should work. However, I would also try the "Monitor"
    > application, and not the browser. Will your company allow you to
    > install the Monitor application on your office computah?

    Yes, I know my WANIP is changing but I have DDNS. Here's how I have
    been
    accessing the camera from the Internet:

    via Dynamic DNS:
    http://mystatichost.com:85 (orginally set at)
    http://mystatichost.com:5000 (orginally set at)

    via my WANIP:
    http://CurrentWANIP.com:85 (orginally set at)
    http://CurrentWANIP.com:5000 (orginally set at)

    I don't care about the audio signal. I only want the video. So what
    I will
    do today is reconfigure both the router and camera for HTTP = 80. I
    just wanted to try this port 80 again. It it fails, I will try:

    http://CurrentWANIP.com:5003

    since port 5003 will be forwarded to my camera's IP. Again, this is
    just all
    trail-and-error.


    >
    > 2. Are you sure you have the correct IP address for your home system?
    > If DHCP or PPPoE is used, the IP address can change.
    >
    > 3. Do you have any kind of "personal firewall" running on your office
    > PC? XP SP2 firewall, ZoneAlarm, Kerio, Black Ice, Norton Firewall,
    > McAffee Firewall, etc? These will block outgoing control requests.

    No software firewall on my work PC other the company's firwall (where
    and what
    ever this is).

    >
    > >I am not
    > >network guy so I don't have the technical knowledge of how ports work.
    >
    > Well, have you considered asking the office network guy for some clues
    > as to how his firewall/proxy/IDS system works? It would be easier if
    > I knew what I was dealing with. The important thing is that it does
    > work with other users that don't have a firewall/proxy/IDS in the way.
    >
    > >Also the video control port = 5003, by looking at the description, I
    > >thought
    > >this was responisble for delivering the video/image, not HTTP=85 which
    > >I had
    > >it before. Can you clarify these ports?
    >
    > 80 (TCP) HTTP Port (allows access to web-configuration and transmits
    > video if other ports are not forwarded)
    > 5001 (TCP/UDP) Control Channel Port (used to synchronize audio and
    > video)
    > 5002 (TCP/UDP) Audio Channel Port (transmits synchronized audio)
    > 5003 (TCP/UDP) Video Channel Port (transmits synchronized video)
    >
    > It would seem that you could get video from *EITHER* 80 or 5003. My
    > guess is that the 5003 is only useful to the monitor application.
    > 5001-5003 get used with the various monitor and security applications.
    > If you don't care about audio, port 80 will deliver just video.
    >
    > This might help:
    > "How do I remotely view DCS-2000 or DCS-5300 series cameras that are
    > behind a router or gateway? "
    > http://support.dlink.com/faq/view.asp?prod_id=1433
    >
    > Oh, this is cute.
    > http://support.dlink.com/faq/view.asp?prod_id=1344
    > If you look carefully at the Javascript code, they don't use port 80,
    > but have redirected it to port 5004 instead. Well, instead of 5000,
    > try 5004. Perhaps there's some non-obvious magic involved.
    >
    > >When you make a request to
    > >the camera
    > >from office and when the signal travels back to office from home, what
    > >kind of
    > >port information does this signal have?
    >
    > Well, the port numbers for the outgoing connections from the camera
    > can be anything between 1024 to 65000. The web servers inside the
    > camera assigns these on the fly, as needed. You can see these in
    > action on your PC with:
    > (open a dos window with Run->cmd or Run->command)
    > netstat -n
    > The numbers after the ":" in the "Foreign Address" column are the
    > incoming port numbers. I don't think you have to worry much about
    > the cameras outgoing port numbers. What's important is the incoming
    > (controlling) port numbers to the camera.
  9. Archived from groups: alt.internet.wireless (More info?)

    On 31 Oct 2004 08:37:35 -0800, sdluu@sunocoinc.com (Sydney Luu) wrote:

    >Made a wrong choice to set HTTP=21 on Friday. Like I said port 21 is
    >designated for FTP service and the camera has logic to take on FTP
    >requests

    Please stay away from port numbers < 1024. I'm fairly sure your
    company's firewall is "protecting" those ports. If this is gonna
    work, it has to be done on port numbers >1024. The Javascript example
    for the MacIntosh I posted may offer a clue. DLlink move the main
    HTTP port from 80 to 5004. That's worth trying.

    >I had to click the "Reset" button to return the camera back to its
    >orignal D-Link's defaults and I had to re-do the camera
    >setup again. Bad decision on my part but you live and learn.

    Note my URL. http://www.LearnByDestroying.com
    That's one of the nice things about working with wireless routers and
    devices. If you screw up, just punch reset and try again. My
    philosophy is that I can make more mistakes per minute than anyone
    else. That worked fine until I ran into the medical profession.
    Their attitude is to make no mistakes, ever. Somehow, they just
    failed to appreciate my methodology. Oh well.

    >After getting the camera going again, I reconfigured the HTTP=137 and
    >asked a
    >guy at work to try it, it didn't work and he got the same warning
    >message that I had posted originally. I chose 137 since it showed up
    >as being used and under the "Stealth" mode - protected by the
    >firewall.

    Your office has a NETBIOS proxy going through the firewall? Yech.

    >via Dynamic DNS:
    >http://mystatichost.com:85 (orginally set at)
    >http://mystatichost.com:5000 (orginally set at)
    >
    >via my WANIP:
    >http://CurrentWANIP.com:85 (orginally set at)
    >http://CurrentWANIP.com:5000 (orginally set at)

    OK. Either of those should work just fine. Actually, we know it
    works because a while back, other users at other locations were able
    to access the camera.

    >I don't care about the audio signal. I only want the video. So what
    >I will
    >do today is reconfigure both the router and camera for HTTP = 80. I
    >just wanted to try this port 80 again. It it fails, I will try:
    >
    >http://CurrentWANIP.com:5003
    >
    >since port 5003 will be forwarded to my camera's IP. Again, this is
    >just all
    >trail-and-error.

    Those are two very good tests. Setting it up for port 80 is a good
    idea because proxy servers almost invariably setup port 80(http) to be
    pass thru. I'm not sure what 5003 will do, but it's also worth a try.

    >No software firewall on my work PC other the company's firwall (where
    >and what ever this is).

    Well, the key to this puzzle is that firewall, which I'm guessing by
    the error messages is a proxy server. At least do some internal
    espionage and try to find out what make and model so that we know what
    we're dealing with. If my guess is a correct, and your company has a
    proxy server, simply re-using a port that goes through the proxy will
    work. Port 80 is my suggested best shot. 8080(http-alternate) is
    another good one to try. A possible problem with port 80 is that your
    router may not appreciate redirecting port 80, especially if it is
    used for remote configuration from the WAN. Just test it from a
    friends or accomplis's machine before you try it at work.

    Also, scanning the firewall from inside with a port scanner is
    probably a great way to get yourself fired, so I wouldn't do that.

    Keep trying and best of luck.

    --
    Jeff Liebermann jeffl@comix.santa-cruz.ca.us
    150 Felker St #D http://www.LearnByDestroying.com
    Santa Cruz CA 95060 AE6KS 831-336-2558
  10. Archived from groups: alt.internet.wireless (More info?)

    http://CurrentWANIP.com:85
    no .com on end of ip number
    4.4.4.10:85 and not 4.4.4.10.com:85

    fwiw.;
    Get nearly if not exact message here;
    "Because the connection problem of network environment, the transmission
    protocol changes to HTTP"
    apparently comes from either my dcs2000 or a di624a router. No proxy
    involved .
    - message has appeared whenever camera is set to stream UDP(UDP=least
    bandwidth=none or less sync check/correction audio/video)
  11. Archived from groups: alt.internet.wireless (More info?)

    On Mon, 01 Nov 2004 03:42:41 GMT, "bumtracks" <posted@usenet.bud>
    wrote:

    >http://CurrentWANIP.com:85
    >no .com on end of ip number
    >4.4.4.10:85 and not 4.4.4.10.com:85

    Please re-read the previous 2 replies. He's using a dynamic DNS
    service and apparently didn't want hackers like me to attack his
    system by posting the real fully qualified domain name. So, he used a
    name substitution. There were no IP addresses involved in the command
    line incantation. If there were, you would be correct to drop the
    ..com suffix.

    >fwiw.;
    >Get nearly if not exact message here;
    > "Because the connection problem of network environment, the transmission
    >protocol changes to HTTP"
    > apparently comes from either my dcs2000 or a di624a router. No proxy
    >involved .
    >- message has appeared whenever camera is set to stream UDP(UDP=least
    >bandwidth=none or less sync check/correction audio/video)

    Thanks. So much for my proxy server theory, maybe...

    My next potentially bad guess(tm) is that the message is coming from
    the camera. The router would have no reason to switch protocols on
    incoming traffic. If it really is coming from the DCS2000 camera,
    then he's able to make the connection through his router, only to be
    rejected by the camera. It would be interesting to know what happens
    when "connection problem of network environment" is displayed in the
    router or camera log pages.

    I thought all the outgoing audio and video was UDP. TCP with
    acknowledgements would have too much overhead and really slow things
    down. HTTP is always TCP, not UDP. The recommended router
    configuration:
    http://support.dlink.com/faq/view.asp?prod_id=1433
    shows both TCP and UDP being port forwarded. It shouldn't really
    complain about UDP.

    I have to remind myself that the camera DOES work through his router
    from a friends computah via the internet. That means that his camera
    and router configs are probably fine and that it has to be something
    at the office end.

    At this point, I would fire up a sniffer and see what's going back and
    forth. However, that's kinda difficult to do from here.


    --
    Jeff Liebermann jeffl@comix.santa-cruz.ca.us
    150 Felker St #D http://www.LearnByDestroying.com
    Santa Cruz CA 95060 AE6KS 831-336-2558
  12. Archived from groups: alt.internet.wireless (More info?)

    fwiw
    From a well secured large network IT guy couldn`t complete the connection
    to dcs2000 here until he dropped most IE Security settings at his
    workstation, ActiveX snafu I believe.
  13. Archived from groups: alt.internet.wireless (More info?)

    I still can't the video to be displayed in the browser at work. I
    have further
    experimented with the following:

    1. Reconfigured HTTP port on router and camera at 5000, 5004, 41300.
    All these
    are just trial-and-error and suggested by
    jeffl@comix.santa-cruz.ca.us.
    Setting ports at high numbers tend to make it worst, not allowing
    me to get
    the camera at all from internal LAN (inside the home).

    2. Took a closer look at some of the camera settings and saw
    "Connection Type".
    Clicked this button and the available options are UDP, TCP and HTTP
    in this
    order listed. Reviewed D-LINK's manual to see what these are.
    According to
    manual and for general users, use UDP and TCP. My LinkSys router
    does not
    have UDP and currently checked with TCP and HTTP when I did the
    "Forwarding".

    I manually made it to be "TCP" just for trying. Tried at work and
    still got
    the original warning message I posted and still no video. Remember I
    can get to
    the camera's homepage. With this experiment, I now believe this
    warning must come from the DCS-2100+ because when I logged on to the
    camera, I
    noticed it changed my setting to HTTP. Hence, "Because the
    connection problem
    of network environment, transmission protocol changes to HTTP". The
    camera
    is really saying, I am changing it to "HTTP" becuase of your network
    environment
    setting.

    Given a bit info here, maybe you guys could narrow this problem down
    for me. Is
    it still port issue? Remember I can get to camera's homepage and
    confirgue settings.

    Thanks for all your help!!


    "bumtracks" <posted@usenet.bud> wrote in message news:<aMqhd.8299$vB.353@trnddc03>...
    > fwiw
    > From a well secured large network IT guy couldn`t complete the connection
    > to dcs2000 here until he dropped most IE Security settings at his
    > workstation, ActiveX snafu I believe.
  14. Archived from groups: alt.internet.wireless (More info?)

    Maybe you can pull a single image? Then maybe make a html page with 5sec
    java image refresh at least until you figure out how to do the stream.
    Example DCS-2000 path ...
    http://logmein:please@192.168.0.26:86/cgi-bin/video.jpg

    If you can install homewatcher.com maybe it will do video for your desk
    which would tell you its just your ie settings.


    <sydneyluu@yahoo.com> wrote in message
    news:e5136ffb.0411020703.43c99f8@posting.google.com...
    > I still can't the video to be displayed in the browser at work. I
    > have further
    > experimented with the following:
    >
    > 1. Reconfigured HTTP port on router and camera at 5000, 5004, 41300.
    > All these
    > are just trial-and-error and suggested by
    > jeffl@comix.santa-cruz.ca.us.
    > Setting ports at high numbers tend to make it worst, not allowing
    > me to get
    > the camera at all from internal LAN (inside the home).
    >
    > 2. Took a closer look at some of the camera settings and saw
    > "Connection Type".
    > Clicked this button and the available options are UDP, TCP and HTTP
    > in this
    > order listed. Reviewed D-LINK's manual to see what these are.
    > According to
    > manual and for general users, use UDP and TCP. My LinkSys router
    > does not
    > have UDP and currently checked with TCP and HTTP when I did the
    > "Forwarding".
    >
    > I manually made it to be "TCP" just for trying. Tried at work and
    > still got
    > the original warning message I posted and still no video. Remember I
    > can get to
    > the camera's homepage. With this experiment, I now believe this
    > warning must come from the DCS-2100+ because when I logged on to the
    > camera, I
    > noticed it changed my setting to HTTP. Hence, "Because the
    > connection problem
    > of network environment, transmission protocol changes to HTTP". The
    > camera
    > is really saying, I am changing it to "HTTP" becuase of your network
    > environment
    > setting.
    >
    > Given a bit info here, maybe you guys could narrow this problem down
    > for me. Is
    > it still port issue? Remember I can get to camera's homepage and
    > confirgue settings.
    >
    > Thanks for all your help!!
    >
    >
    >
    > "bumtracks" <posted@usenet.bud> wrote in message
    news:<aMqhd.8299$vB.353@trnddc03>...
    > > fwiw
    > > From a well secured large network IT guy couldn`t complete the
    connection
    > > to dcs2000 here until he dropped most IE Security settings at his
    > > workstation, ActiveX snafu I believe.
Ask a new question

Read More

Internet Explorer D-Link Internet Wireless Networking