Sign in with
Sign up | Sign in
Your question

doom3 on linux sound problems

Last response: in Video Games
Share
Anonymous
December 7, 2004 12:26:32 AM

Archived from groups: alt.games.doom (More info?)

Anyone here running Doom3 on linux/Fedora Core 3?

I have installed the game successfully, latest nvidia drivers for my
6800GT. The game runs well (better fps that WinXP), but can't get sound
to work.

I read the sys requirements, and they say you need oss sound system, but
in the latest patch there was something about alsa is now supported. My
installation is just the default Fedora, which I understand uses alsa.
Sound works fine on the desktop etc.

I have been a linux user for years, but never had much need to know much
about how the sound system works - as long as I get sound out. Now I
have a reason to know more ;-)

--
T R O Y P I G G I N S
e : usenet@piggo.com
Anonymous
December 7, 2004 12:26:33 AM

Archived from groups: alt.games.doom (More info?)

Troy Piggins wrote:

> I have installed the game successfully, latest nvidia drivers for my
> 6800GT. The game runs well (better fps that WinXP), but can't get sound
> to work.

"Fedora uses ALSA by default if i'm not mistaken. You should proble
recompile the kernel and remove ALSA, then compile ALSA from source and
load the modules at start up."
- http://www.linuxquestions.org/questions/history/252868

That's the most relevant thing I can find, and while it doesn't look
like a quick, easy fix, it seems like the most promising thing I could find.

Hope it helps!


Btw, what was your performance on WinXP and what is it now on *nix?


--
Noob - "do you hack?"
Justin - "i hack like a maniac!"
Noob - "do you have digital cable?"
Justin - "i have *ALL* the cables!"
Anonymous
December 7, 2004 3:33:57 PM

Archived from groups: alt.games.doom (More info?)

On Mon, 06 Dec 2004 20:48:44 -0500, SnoopJeDi wrote:

> "Fedora uses ALSA by default if i'm not mistaken. You should proble
> recompile the kernel and remove ALSA, then compile ALSA from source and
> load the modules at start up."

Er... there is an oss-emulation module for alsa, no?

nicolas patrois : pts noir asocial
--
SPROTCH !

P : Non, y a rien de plus immonde que de chier sur la moquette...
M : Pas d'accord... A pire... Chier sous la moquette...
H : ?!!
Related resources
Anonymous
December 9, 2004 11:09:50 AM

Archived from groups: alt.games.doom (More info?)

* nicolas wrote:
>> "Fedora uses ALSA by default if i'm not mistaken. You should proble
>> recompile the kernel and remove ALSA, then compile ALSA from source and
>> load the modules at start up."
>
> Er... there is an oss-emulation module for alsa, no?

I do not know. I have never had need to know much about sound on
linux, so am just learning. I don't even know the difference between
them. I don't understand about sound servers etc, but am reading a bit
about it this weekend.

--
T R O Y P I G G I N S
e : usenet@piggo.com
Anonymous
December 9, 2004 11:15:06 AM

Archived from groups: alt.games.doom (More info?)

* SnoopJeDi wrote:
> "Fedora uses ALSA by default if i'm not mistaken. You should proble
> recompile the kernel and remove ALSA, then compile ALSA from source and
> load the modules at start up."
> - http://www.linuxquestions.org/questions/history/252868
>
> That's the most relevant thing I can find, and while it doesn't look
> like a quick, easy fix, it seems like the most promising thing I could find.

I read that the latest patch for linux /does/ support alsa, but still
can't get to work. I will need to spend some more time on it this
weekend.

> Btw, what was your performance on WinXP and what is it now on *nix?

Don't know how you define performance, but what I meant was that I get
about 20% more fps by the looks at the moment, but haven't tweaked any
settings as yet. I remmeber UT and Quake3 performed better in linux
native than Windows. That is not running them through wine/winex. I
ran Counter-Strike 1.5 through wine and was also getting better
performance than Windows. Shame when CS went to steam and couldn't do
it any more.

--
T R O Y P I G G I N S
e : usenet@piggo.com
Anonymous
December 10, 2004 3:14:49 PM

Archived from groups: alt.games.doom (More info?)

On Thu, 09 Dec 2004 08:09:50 +0000, Troy Piggins wrote:

> * nicolas wrote:
>>> "Fedora uses ALSA by default if i'm not mistaken. You should proble
>>> recompile the kernel and remove ALSA, then compile ALSA from source and
>>> load the modules at start up."
>>
>> Er... there is an oss-emulation module for alsa, no?
>
> I do not know. I have never had need to know much about sound on
> linux, so am just learning. I don't even know the difference between
> them. I don't understand about sound servers etc, but am reading a bit
> about it this weekend.

The ALSA mixer defaults to all channels silent. NOT muted, just zero
volume. I tore my hair until I discovered that the mixer on the Gnome
panel was NOT the ALSA mixer. Invoking alsamixer from a terminal session
and shoving some sliders up finally got me sound in FC3.
Anonymous
December 10, 2004 6:07:57 PM

Archived from groups: alt.games.doom (More info?)

Steve Rush wasted my time with the following on 12/10/2004 1:14 PM:

>
> The ALSA mixer defaults to all channels silent. NOT muted, just zero
> volume. I tore my hair until I discovered that the mixer on the Gnome
> panel was NOT the ALSA mixer. Invoking alsamixer from a terminal session
> and shoving some sliders up finally got me sound in FC3.
>

How productive.

I suppose that is our pal's problem, hopefully he is still keeping up on
this thread =)

--
Noob - "do you hack?"
Justin - "i hack like a maniac!"
Noob - "do you have digital cable?"
Justin - "i have *ALL* the cables!"
Anonymous
December 14, 2004 8:56:43 AM

Archived from groups: alt.games.doom (More info?)

* SnoopJeDi wrote:
> Steve Rush wasted my time with the following on 12/10/2004 1:14 PM:
>> The ALSA mixer defaults to all channels silent. NOT muted, just zero
>> volume. I tore my hair until I discovered that the mixer on the Gnome
>> panel was NOT the ALSA mixer. Invoking alsamixer from a terminal session
>> and shoving some sliders up finally got me sound in FC3.

Will try this. Thanks.

> How productive.
>
> I suppose that is our pal's problem, hopefully he is still keeping up on
> this thread =)

I am - just been having some ISP connection problems, but seem to be
working now.

I will try this, but I don't think it will solve the problem. D3
actually says in console "couldn't start sound" or some similar message.
I am at work at the moment and will get the actual message tonight if I
can.

Thanks for keeping reading the thread guys. I really want to get this
sorted.

Steve - you using Fedora 3? What soundcard? I have Soundblaster Live!
5.1 using the emu10k1 driver.

SnoopJeDi - you know some linux?

--
T R O Y P I G G I N S
e : usenet@piggo.com
Anonymous
December 14, 2004 7:17:37 PM

Archived from groups: alt.games.doom (More info?)

Troy Piggins wasted my time with the following on 12/14/2004 12:56 AM:
>
> SnoopJeDi - you know some linux?
>
Enough. I'm not the most well-read person when it comes to linux, but
I've had a little experience, and actually had quite a lovely (or not)
time getting sound to work in Mandrake.

Sorry I can't provide much knowledge on the ALSA issue.

--
Noob - "do you hack?"
Justin - "i hack like a maniac!"
Noob - "do you have digital cable?"
Justin - "i have *ALL* the cables!"
Anonymous
December 15, 2004 1:42:07 AM

Archived from groups: alt.games.doom (More info?)

* SnoopJeDi wrote:
> Troy Piggins wasted my time with the following on 12/14/2004 12:56 AM:
>>
>> SnoopJeDi - you know some linux?
>>
> Enough. I'm not the most well-read person when it comes to linux, but
> I've had a little experience, and actually had quite a lovely (or not)
> time getting sound to work in Mandrake.
>
> Sorry I can't provide much knowledge on the ALSA issue.

No problems. Don't know what you use your pc for, but there aren't many
things win can do that linux can't.

Only reason I use win at work is a lot of our structural analysis
software and autocad don't run on linux.

I am going to uninstall all sound drivers and reinstall. Although I
have disabled it in bios, I suspect my motherboard's onboard sound is
messing with my sb live card, coz some ac97 modules are loaded in lsmod.

Peace
--
T R O Y P I G G I N S
e : usenet@piggo.com
!