Sign in with
Sign up | Sign in
Your question

20-Pin PSU vs 24-pin Mobo Hookup?

Last response: in Motherboards
Share
May 5, 2005 8:16:43 PM

My Chaintech VNF4 Mobo just arrived along with AMD 64 3000 CPU and 1G Corsair ValueSelect RAM. My PSU is ANTEC TruePower 480 with a 20-pin connector. The Mobo has a 24-pin connector.
Each connector has a "latch" connector device at the center on one side. Should the PSU 20-pin connector be inserted into the Mobo connector "centered" so that the latching connectors line up, with two open pins on each end of the Mobo connector? If the PSU connector should be aligned with one end of the Mobo connector leaving 4 mobo pins vacant on and end, how can I determine which ends to align and which pins should remain vacant? The POS manual with the Mobo only says to "Plug in the ATX power cable to the mainboard's power connector and make sure the cable is connected". Also, there is no mention in the Mobo manual of the 4pin black/yellow 12v connector, but there's a connector on the Mobo labeled PW3. As the connectors seem to fit am I to assume that this PSU connector should be plugged into PW3? Thanks for any help here.
May 5, 2005 9:11:45 PM

Thanks for the link. I had read that post, but apparently not closely enough. What I came away with was "With the retainer clip on the right, the top four sockets will be empty. When the retainer clip is on the left, the bottom four sockets will be empty."

Now, after hooking up the PSU with CPU, video card, and RAM installed I get absolutely nothing. No fan. No beep. The PSU fan doesn't even come on.
Related resources
May 5, 2005 9:53:01 PM

You have the square 4 pins power connector plugged in, doesnt it??

<font color=red>Sig space for rent. make your offer.</font color=red>
May 5, 2005 10:25:54 PM

Yes the square 4-pin black/yellow connector is plugged in.
RAM, graphics card, and CPU are installed on the board and PSU connectors attached. When I turn the power on it's dead. I've tried connecting the power wires from the case switch to see if that would make any difference (no). Any suggestions, or should I RMA the Mobo? Any way to determine if it's the Mobo, CPU, or what without another Mobo to try the components in? Thanks.
May 5, 2005 10:48:16 PM

Right, I'm aware that they're completely different connects with separate sockets on the Mobo.
OK. I've found threads here and other forums with pictures and detail indicating how the connector should be inserted.
I've connected the PSU connectors, including the 4pin molex black/yellow connector for the CPU, to the Mobo as pictured in threads where the system was operating. RAM, CPU, and graphics card installed. Powered up... and nothing. No beeps. No CPU fan. No Mobo fan. I've tried attaching the case power leads for the front switch but it made no difference. I've removed and reinstalled the RAM, CPU, and graphics card. There's power going to the PSU, but when I power up nothing happens. Not even the PSU fan...
How can I determine if it's the Mobo, CPU, or what so I can RMA? Thanks for any advise...
May 6, 2005 1:06:55 AM

And what about the power switch at the back of the PSU???

<font color=red>Sig space for rent. make your offer.</font color=red>
May 6, 2005 11:20:53 AM

Do you have another rig you test this PSU in? Is it a new case or could the case power button be going bad?

__________________________________________________
<font color=red>You're a boil on the arse of progress - don't make me squeeze you!</font color=red>
May 6, 2005 4:27:27 PM

It is possible the Voltage switch on the PSU is in the wrong position. It should have a little red switch on the back that switches from 115 V to 230 V (Not sure about the actual numbers). Set the switch to conform to the voltage you get from the outlet in whatever part of the world you live in. If you're in the U.S. I think you should set it to 115 V.
May 6, 2005 4:37:47 PM

I think he would have gotten some obvious indications of electrical problems if he used the wrong voltage. :wink:

__________________________________________________
<font color=red>You're a boil on the arse of progress - don't make me squeeze you!</font color=red>
May 6, 2005 6:23:11 PM

I don't know. This happened to my dad's system when he built one several months ago. No matter what he did, he could not get the system to power on; no post, no nothing. Then I noticed that the voltage switch was in the wrong position. I switched it and the machine started right up.
May 6, 2005 7:53:13 PM

PSU voltage switch is OK and turned on. I've removed components and reassembled outside the case on a piece of cardboard, and shorted the switch pins on the mobo just in case the system switch was faulty. Nothing I've tried has worked, and I don't have another system to test with, as this is skt 939 cpu/mobo and PCI-E graphics with ram that isn't compatible with anything I have. I've RMA'd the Mobo back to NewEgg (bless them and their excellent website) and will continue when I receive a replacement. Hopefully it is the motherboard and I can get this resolved soon. Thanks for all replies and assistance.
!