Problems with any game with a Q3 based engine.

Any game I try to play on my desktop, that has an engine based on Q3 (Return to Castle Wolfenstein, Jedi Outcast, Jedi Academy, and for a while, all CoD games, but something I did fixed them) the game goes to the grey screen, then immediately crashes, just a standard Windows "Game.exe has stopped working" dialog pops up.

The funny thing is, while this happens with all Q3 games, it does not happen with Q3 itself, which I find strange.

I have tried all the obvious things, update drivers, downgrade drivers, completely clean out then reinstall drivers, updating Direct X, and I got fed up with not being able to play these games, so I did a complete reinstall.

Which did not fix the problem.

The only things I have installed are:

Steam
The Games, obviously,
ATi Drivers
Realtek Sound Drivers (It used to work just fine with these, and I tried the games before I installed these)
Raptr (Again, tested the games before I installed, and in-game overlay for these games is disabled)
Fraps
Mirillis SplashPRO (I like my movies with frame interpolation, :D)
Google Chrome

Thanks in advance!

My rig is in my profile, but I will post it here too,
XFX 750i SLi Motherboard
Intel C2Q Q8200 CPU (2.33 GHz each)
4 GB DDR2 800 MHz RAM
XFX Radeon HD 5670 GPU
4 answers Last reply
More about problems game based engine
  1. Set your sound card's output to 16 bit 44100hz.
  2. I have tried that, still no luck, :\
  3. Set compatibility/ disable desktop composition/ run as administrator.
  4. Tried it, no luck, thanks for the suggestions so far, got any more?
Ask a new question

Read More

PC gaming Engine Drivers Games Video Games