Sign in with
Sign up | Sign in
Your question

Is occasional "hiccuping" normal even on relatively high powered PCs?

Last response: in Video Games
Share
September 5, 2010 2:07:03 AM

Just asking mainly out of curiosity. I would've expected small "stutters" to not be an issue as technology progresses, but it seems I've seen them in every PC I've ever had.
I just recently built this rig

Phenom 2 x6 1055T @ 2.8Ghz (1.3v)
4GB DDR3 Kingston RAM
Corsair 650-TX
Gigabyte Ga-Ma790GPT-ud3h
HD 5770 Vapor-X

And it would seem the stuttering is worse than on any of the other PCs I have.
It's not stuttering in the sense that it is a sound loop or a long succession of freezes. It's just the occasional hiccup
Think of it like this - the game is running at 70fps...70fps...70fps...then suddenly a very short pause(Maybe 0.2-0.5 sec), accompanied by a drop to 64fps or so, then it immediately continues on as if nothing had happened.

This is completely normal, right? I don't experience it in ALL games (only most), and I don't see it in 3dmark.
It's just confusing =\
September 5, 2010 4:07:30 PM

i used to see 50fps in stalker cop dropping to standstill for a fraction of a second, on a gtx470,
September 5, 2010 7:41:11 PM

spongeguar said:
Just asking mainly out of curiosity. I would've expected small "stutters" to not be an issue as technology progresses, but it seems I've seen them in every PC I've ever had.
I just recently built this rig

Phenom 2 x6 1055T @ 2.8Ghz (1.3v)
4GB DDR3 Kingston RAM
Corsair 650-TX
Gigabyte Ga-Ma790GPT-ud3h
HD 5770 Vapor-X

And it would seem the stuttering is worse than on any of the other PCs I have.
It's not stuttering in the sense that it is a sound loop or a long succession of freezes. It's just the occasional hiccup
Think of it like this - the game is running at 70fps...70fps...70fps...then suddenly a very short pause(Maybe 0.2-0.5 sec), accompanied by a drop to 64fps or so, then it immediately continues on as if nothing had happened.

This is completely normal, right? I don't experience it in ALL games (only most), and I don't see it in 3dmark.
It's just confusing =\


brother, try updating your bios if they are outdated. and VGA card drives also if they are too. I also recently had this kind of Effect very rarely; but not in gaming but while multitasking. So i updated my bios and now its gone. And keep your Swap file a good space. Defrag hard drives and keep it run smooth.. ;) 
September 5, 2010 8:13:20 PM

Blame it on bad coding of the game. Memory leaks are common as are redundant loops ( Code trying to resolve an error).
All will cause stutter.
Make sure your anti-virus isn't running in the back ground.
You could crate an installation of windows with all the rubbish stripped out just for running games.
September 19, 2010 6:00:00 AM

Maybe try getting a SSD

from the recent notes from the intel devolper forums:

Modern game engines constantly stream data off the hard drive or optical drive during game play. Some level data is preloaded, but today’s games are far too large for levels to be completely loaded into system memory, even on Windows 7 64-bit with four or six gigabytes of RAM. So, the game is constantly making a best guess as to what data to stream to main memory or GPU VRAM in order to maintain smooth frame rates.

Intel noticed that, sometimes during game play, the game would momentarily freeze for a second. Intel calls these momentary pauses “hitching.”

Intel recorded uncompressed full-resolution streams of game play and compared them to recorded hard drive load traces and found that these “hitches” or pauses matched up to large amounts of data being loaded in a short period of time, as the game engine recovered from a bad guess
September 20, 2010 10:29:32 PM

I had a similar issue in some valve/steam games such as Left 4 Dead or Left 4 Dead 2. For me, the problem turned out to be that 'multicore rendering' was turned on. Even though I have a multi-core system, once I turned off this option, never had a problem again.

But then again, I'm not sure if this is limited to Steam/Valve/Source games.
!